summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-01 08:41:34 +0200
committerRemi Collet <remi@remirepo.net>2019-10-01 08:41:34 +0200
commit012e075c865d936ded0fc5d24be92e945a5dd7f4 (patch)
treef99aef07365bc34b0c5a3ea9534179de87c3b1f8
parent7d8d1f2ec0c2028ea8b78aae4c8aa817c3cc0762 (diff)
- update to 1.5.0
- raise dependency on PHP 5.6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION11
-rw-r--r--composer.json9
-rw-r--r--php-maxminddb.spec27
4 files changed, 28 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index 7bb98d0..0120a25 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
maxminddb
MaxMind DB Reader => enabled
-maxminddb extension version => 1.4.1
+maxminddb extension version => 1.5.0
libmaxminddb library version => 1.2.0
diff --git a/REFLECTION b/REFLECTION
index 07723e7..a25f27f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #197 maxminddb version 1.4.1 ] {
+Extension [ <persistent> extension #200 maxminddb version 1.5.0 ] {
- Classes [1] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
@@ -15,7 +15,7 @@ Extension [ <persistent> extension #197 maxminddb version 1.4.1 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:maxminddb, ctor> public method __construct ] {
- Parameters [1] {
@@ -36,6 +36,13 @@ Extension [ <persistent> extension #197 maxminddb version 1.4.1 ] {
}
}
+ Method [ <internal:maxminddb> public method getWithPrefixLen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $ip_address ]
+ }
+ }
+
Method [ <internal:maxminddb> public method metadata ] {
- Parameters [0] {
diff --git a/composer.json b/composer.json
index dce4428..2aa2ff5 100644
--- a/composer.json
+++ b/composer.json
@@ -9,11 +9,11 @@
{
"name": "Gregory J. Oschwald",
"email": "goschwald@maxmind.com",
- "homepage": "http://www.maxmind.com/"
+ "homepage": "https://www.maxmind.com/"
}
],
"require": {
- "php": ">=5.4"
+ "php": ">=5.6"
},
"suggest": {
"ext-bcmath": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
@@ -22,8 +22,9 @@
},
"require-dev": {
"friendsofphp/php-cs-fixer": "2.*",
- "phpunit/phpunit": "4.* || 5.*",
- "satooshi/php-coveralls": "1.0.*",
+ "phpunit/phpunit": "5.*",
+ "php-coveralls/php-coveralls": "^2.1",
+ "phpunit/phpcov": "^3.0",
"squizlabs/php_codesniffer": "3.*"
},
"autoload": {
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 2ad688f..cee378a 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -14,15 +14,10 @@
%global pkg_name %{name}
%global with_lib 1
%endif
-# for the pure PHP library - disabled on EL < 8 because of PHPUnit dependency
-%if 0%{?fedora} >= 20 || 0%{?rhel} >= 8
%global with_tests 0%{!?_without_tests:1}
-%else
-%global with_tests 0%{?_with_tests:1}
-%endif
-%global gh_commit eb83d0ee1c1f9b8a340206302136bc81ee02ae74
+%global gh_commit bd436094fc0a9b0558a899fb80b0ae34fe1808a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
@@ -36,16 +31,16 @@
Summary: MaxMind DB Reader extension
Name: %{?sub_prefix}php-maxminddb
-Version: 1.4.1
-%global rpmrel 2
-Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.5.0
+%global rpmrel 1
+Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo "1".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: pkgconfig(libmaxminddb) >= 1.0.0
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -115,15 +110,15 @@ BuildRequires: php-bcmath
BuildRequires: php-gmp
# from composer.json "require-dev": {
# "friendsofphp/php-cs-fixer": "2.*",
-# "phpunit/phpunit": "4.* || 5.*",
+# "phpunit/phpunit": "5.*",
# "satooshi/php-coveralls": "1.0.*",
# "squizlabs/php_codesniffer": "3.*"
BuildRequires: php-composer(phpunit/phpunit)
%endif
# from composer.json "require": {
-# "php": ">=5.4"
-Requires: php(language) >= 5.4
+# "php": ">=5.6"
+Requires: php(language) >= 5.6
# from composer.json "suggest": {
# "ext-bcmath": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
# "ext-gmp": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
@@ -266,7 +261,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with_lib} && %{with_tests}
cd ..
: Upstream test suite for the library
-for cmd in php php56 php70 php71 php72 php73; do
+for cmd in php php56 php70 php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
@@ -308,6 +303,10 @@ exit $ret
%changelog
+* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- raise dependency on PHP 5.6
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.4.1-2
- rebuild for 7.4.0RC1