summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-13 08:21:02 +0100
committerRemi Collet <remi@remirepo.net>2019-12-13 08:21:02 +0100
commit5fdbcacf79e38153de229779c0f16730e0d68aa0 (patch)
treef934ec64fc5822d5c414305e51822d8ad4425a40
parentf5a34136c705727994917402ac0b4a360eeb4803 (diff)
- update to 1.5.1
- drop patch merged upstream
-rw-r--r--90.patch46
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--composer.json5
-rw-r--r--php-maxminddb.spec15
5 files changed, 15 insertions, 55 deletions
diff --git a/90.patch b/90.patch
deleted file mode 100644
index 66b8bcc..0000000
--- a/90.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From cc5731a3b1c0257a7e227443dca69b64f2dbc4d0 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 1 Oct 2019 09:25:39 +0200
-Subject: [PATCH 1/2] expose MMDB_LIB_VERSION to userland
-
----
- ext/maxminddb.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/ext/maxminddb.c b/ext/maxminddb.c
-index 91dd706..239decc 100644
---- a/ext/maxminddb.c
-+++ b/ext/maxminddb.c
-@@ -665,6 +665,7 @@ PHP_MINIT_FUNCTION(maxminddb) {
- maxminddb_obj_handlers.offset = XtOffsetOf(maxminddb_obj, std);
- maxminddb_obj_handlers.free_obj = maxminddb_free_storage;
- #endif
-+ zend_declare_class_constant_string(maxminddb_ce, "MMDB_LIB_VERSION", sizeof("MMDB_LIB_VERSION")-1, MMDB_lib_version() TSRMLS_CC);
-
- return SUCCESS;
- }
-
-From 91e160eaf465d1646f18ecf182271d59ab219d31 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 1 Oct 2019 09:30:37 +0200
-Subject: [PATCH 2/2] skip test when running with extension build against old
- library
-
----
- tests/MaxMind/Db/Test/ReaderTest.php | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/MaxMind/Db/Test/ReaderTest.php b/tests/MaxMind/Db/Test/ReaderTest.php
-index 773bedd..3cbd0ff 100644
---- a/tests/MaxMind/Db/Test/ReaderTest.php
-+++ b/tests/MaxMind/Db/Test/ReaderTest.php
-@@ -243,6 +243,9 @@ public function testGetWithPrefixLen()
- */
- public function testV6AddressV4Database()
- {
-+ if (defined("MaxMind\\Db\\Reader::MMDB_LIB_VERSION") && version_compare(Reader::MMDB_LIB_VERSION, '1.2.0', '<')) {
-+ $this->markTestSkipped('MMDB_LIB_VERSION < 1.2.0');
-+ }
- $reader = new Reader('tests/data/test-data/MaxMind-DB-test-ipv4-24.mmdb');
- $reader->get('2001::');
- }
diff --git a/PHPINFO b/PHPINFO
index 0120a25..bfdb1fe 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
maxminddb
MaxMind DB Reader => enabled
-maxminddb extension version => 1.5.0
+maxminddb extension version => 1.5.1
libmaxminddb library version => 1.2.0
diff --git a/REFLECTION b/REFLECTION
index 162abb3..4161390 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #200 maxminddb version 1.5.0 ] {
+Extension [ <persistent> extension #105 maxminddb version 1.5.1 ] {
- Classes [1] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
diff --git a/composer.json b/composer.json
index 2aa2ff5..4ddcc36 100644
--- a/composer.json
+++ b/composer.json
@@ -31,5 +31,10 @@
"psr-4": {
"MaxMind\\Db\\": "src/MaxMind/Db"
}
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "MaxMind\\Db\\Test\\Reader\\": "tests/MaxMind/Db/Test/Reader"
+ }
}
}
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 3799db6..3e184cd 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
-%global gh_commit bd436094fc0a9b0558a899fb80b0ae34fe1808a0
+%global gh_commit f096bbe4d37e3d93e62626297bfc2179472a972d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
@@ -31,17 +31,15 @@
Summary: MaxMind DB Reader extension
Name: %{?sub_prefix}php-maxminddb
-Version: 1.5.0
-%global rpmrel 3
-Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.5.1
+%global rpmrel 1
+Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo "1".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/maxmind/MaxMind-DB-Reader-php/pull/90.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: pkgconfig(libmaxminddb) >= 1.0.0
@@ -157,7 +155,6 @@ Autoloader: %{_datadir}/php/MaxMind/Db/Reader/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr90
%if %{with_lib}
%{_bindir}/phpab \
@@ -307,6 +304,10 @@ exit $ret
%changelog
+* Fri Dec 13 2019 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+- drop patch merged upstream
+
* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 1.5.0-3
- update to 1.5.0
- raise dependency on PHP 5.6