summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-13 14:27:27 +0200
committerRemi Collet <remi@php.net>2023-07-13 14:27:27 +0200
commit5a242675ca54dfadf8b18190e0c73283b61140fd (patch)
tree49c989329cb9ae77d192193d79f4833f8b5022f6
parent5387c6cd0fe96cb4e9589b6675a10b41446e2ba0 (diff)
cleanup
-rw-r--r--php-libvirt.spec30
1 files changed, 10 insertions, 20 deletions
diff --git a/php-libvirt.spec b/php-libvirt.spec
index 68fe4b8..deaa94c 100644
--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -8,34 +8,24 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-libvirt
-%endif
-# The change to redhat-rpm-config to force symbols to be defined breaks all PHP extensions
-# c.f.: https://src.fedoraproject.org/rpms/redhat-rpm-config/c/078af192613e1beec34824a94dc5f6feeeea1568
-# c.f.: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7EHQUO6JIFRE4KIQQMFVQCAQ72NLKARO/
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-libvirt}
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
# from upstream 1.2.9 (but seems wrong, missing VIR_STORAGE_VOL_CREATE_REFLINK)
-%global req_libvirt_version 1.2.13
-%global extname libvirt-php
-%if "%{php_version}" < "5.6"
-%global ini_name %{extname}.ini
-%else
+%global req_libvirt_version 1.2.13
+%global extname libvirt-php
%global ini_name 40-%{extname}.ini
-%endif
Name: %{?scl_prefix}php-libvirt
Version: 0.5.7
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP language binding for Libvirt
Group: Development/Libraries
# libvirt-php is under the same terms as libvirt
-License: LGPLv2+
+License: LGPL-2.1-or-later
URL: http://libvirt.org/php
Source0: http://libvirt.org/sources/php/libvirt-php-%{version}.tar.xz
@@ -49,7 +39,6 @@ BuildRequires: xhtml1-dtds
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Filter shared private - always as libvirt-php.so is a very bad name
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
@@ -99,10 +88,8 @@ make install DESTDIR=%{buildroot}
install -pm 644 COPYING %{buildroot}%{_pkgdocdir}
if [ -f %{buildroot}%{php_inidir}/%{extname}.ini ]; then
- if [ "%{extname}.ini" != "%{ini_name}" ]; then
- mv %{buildroot}%{php_inidir}/%{extname}.ini \
- %{buildroot}%{php_inidir}/%{ini_name}
- fi
+ mv %{buildroot}%{php_inidir}/%{extname}.ini \
+ %{buildroot}%{php_inidir}/%{ini_name}
else
install -Dpm 644 src/libvirt-php.ini %{buildroot}%{php_inidir}/%{ini_name}
fi
@@ -130,6 +117,9 @@ rm %{buildroot}%{php_extdir}/%{extname}.la
%changelog
+* Thu Jul 13 2023 Remi Collet <remi@remirepo.net> - 0.5.7-2
+- cleanup
+
* Thu Dec 8 2022 Remi Collet <remi@remirepo.net> - 0.5.7-1
- Upgrade to 0.5.7
- raise dependency on PHP 7.0