summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-08 08:17:48 +0100
committerRemi Collet <remi@php.net>2022-12-08 08:17:48 +0100
commit5387c6cd0fe96cb4e9589b6675a10b41446e2ba0 (patch)
tree74f5d0fd791d13c0a9ffd99004a422c854bfc1d9
parent439692065f0c8ba8d59c45b687513a47cfa775f4 (diff)
Upgrade to 0.5.7
raise dependency on PHP 7.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--libvirt-php5.patch29
-rw-r--r--php-libvirt.spec20
4 files changed, 9 insertions, 44 deletions
diff --git a/PHPINFO b/PHPINFO
index b557fb0..679c8cd 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ libvirt
Libvirt support => enabled
Debug support => enabled, default maximum log file size: 1024 KiB
-Extension version => 0.5.6
+Extension version => 0.5.7
Libvirt version => 7.6.0
Max. connections => 5
ISO Image path => /var/lib/libvirt/images
diff --git a/REFLECTION b/REFLECTION
index a0b4a9b..9548039 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 libvirt version 0.5.6 ] {
+Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
- INI {
Entry [ libvirt.longlong_to_string <ALL> ]
diff --git a/libvirt-php5.patch b/libvirt-php5.patch
deleted file mode 100644
index 43e718a..0000000
--- a/libvirt-php5.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 1f7882e3476699ed0296095edadd1ed63b0c14b6 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 15 Jun 2022 17:09:04 +0200
-Subject: [PATCH] missing macro for PHP 5.x
-
----
- src/util.h | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/util.h b/src/util.h
-index 237ff43..2261682 100644
---- a/src/util.h
-+++ b/src/util.h
-@@ -215,6 +215,12 @@
- # define VIRT_ADD_ASSOC_STRING(_arg, _key, _str) \
- add_assoc_string(_arg, _key, _str, 1)
-
-+# define VIRT_ADD_ASSOC_STRING_WITH_NULL_POINTER_CHECK(_arg, _key, _str) \
-+ if ((_str)) { \
-+ add_assoc_string(_arg, _key, _str, 1); \
-+ } else { \
-+ add_assoc_null(_arg, _key); \
-+ }
- # define VIRT_ADD_ASSOC_STRING_EX(_arg, _key, _key_len, _value) \
- add_assoc_string_ex(_arg, _key, _key_len, _value, 1)
-
---
-2.35.3
-
diff --git a/php-libvirt.spec b/php-libvirt.spec
index fd1e5fd..68fe4b8 100644
--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -9,7 +9,6 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-libvirt
%endif
@@ -29,8 +28,8 @@
%global ini_name 40-%{extname}.ini
%endif
-Name: %{?sub_prefix}php-libvirt
-Version: 0.5.6
+Name: %{?scl_prefix}php-libvirt
+Version: 0.5.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP language binding for Libvirt
@@ -40,16 +39,12 @@ License: LGPLv2+
URL: http://libvirt.org/php
Source0: http://libvirt.org/sources/php/libvirt-php-%{version}.tar.xz
-Patch0: libvirt-php5.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: libvirt-devel >= %{req_libvirt_version}
BuildRequires: libxml2-devel
BuildRequires: libxslt
-# obviously NOT needed, checked by configure as used by examples :(
-BuildRequires: %{?scl_prefix}php-pecl-imagick
BuildRequires: xhtml1-dtds
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -73,10 +68,6 @@ Summary: Document of php-libvirt
Group: Development/Libraries
BuildArch: noarch
Requires: %{name} = %{version}-%{release}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-libvirt-doc = %{version}-%{release}
-Provides: %{?scl_prefix}php-libvirt-doc%{?_isa} = %{version}-%{release}
-%endif
%description doc
PHP language bindings for Libvirt API.
@@ -87,7 +78,6 @@ This package contain the document for php-libvirt.
%prep
%setup -q -n libvirt-php-%{version}
-%patch0 -p1 -b .php5
%build
@@ -140,6 +130,10 @@ rm %{buildroot}%{php_extdir}/%{extname}.la
%changelog
+* Thu Dec 8 2022 Remi Collet <remi@remirepo.net> - 0.5.7-1
+- Upgrade to 0.5.7
+- raise dependency on PHP 7.0
+
* Wed Jun 15 2022 Remi Collet <remi@remirepo.net> - 0.5.6-1
- Upgrade to 0.5.6
- add patch allowing build with PHP 5