summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-31 14:10:35 +0200
committerRemi Collet <remi@php.net>2022-03-31 14:10:35 +0200
commit3c0d14a63a70cbf22e4b65c4a38035c56e4c6969 (patch)
treefec7d6d15d68172754a445fe61532455d90246be
parent562b82ccb751eacdec14226292757a1a2bc340b3 (diff)
update to 1.8.9
switch to phpunit8
-rw-r--r--composer.json9
-rw-r--r--php-jsonlint.spec25
2 files changed, 19 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index b065d7b..33a6e68 100644
--- a/composer.json
+++ b/composer.json
@@ -15,10 +15,15 @@
"php": "^5.3 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0"
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0 || ^8.5.13",
+ "phpstan/phpstan": "^0.12.59"
},
"autoload": {
"psr-4": { "Seld\\JsonLint\\": "src/Seld/JsonLint/" }
},
- "bin": ["bin/jsonlint"]
+ "bin": ["bin/jsonlint"],
+ "scripts": {
+ "test": "vendor/bin/phpunit",
+ "phpstan": "vendor/bin/phpstan analyse"
+ }
}
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index 3ca6a83..2fc345a 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-jsonlint
#
-# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,8 +13,8 @@
%global github_owner Seldaek
%global github_name jsonlint
-%global github_version 1.8.3
-%global github_commit 9ad6ce79c342fbd44df10ea95511a1b24dee5b57
+%global github_version 1.8.9
+%global github_commit d9a308b84277a7dd651ba89bf5ed37b88497b171
# "php": "^5.3 || ^7.0 || ^8.0"
%global php_min_ver 5.3
@@ -24,7 +24,7 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: JSON Lint for PHP
License: MIT
@@ -40,13 +40,8 @@ BuildArch: noarch
%if %{with tests}
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7
-%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 4.8.35
-%endif
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5.13
# For tests: phpcompatinfo (computed from version 1.8.2)
BuildRequires: php-json
BuildRequires: php-pcre
@@ -106,10 +101,10 @@ install -pm 0755 bin/jsonlint %{buildroot}%{_bindir}/jsonlint-php
%if %{with tests}
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80; do
+for cmd in "php %{phpunit}" php74 php80 php81; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit8} \
--bootstrap %{buildroot}%{_datadir}/php/Seld/JsonLint/autoload.php \
--no-coverage \
--verbose || ret=1
@@ -133,6 +128,10 @@ exit $ret
%changelog
+* Thu Mar 31 2022 Remi Collet <remi@remirepo.net> - 1.8.9-1
+- update to 1.8.9
+- switch to phpunit8
+
* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 1.8.3-3
- switch to phpunit7