summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-24 15:27:31 +0100
committerRemi Collet <remi@remirepo.net>2021-03-24 15:27:31 +0100
commit562b82ccb751eacdec14226292757a1a2bc340b3 (patch)
tree2036d4b0fc35c0e514452b9f8d1b759d36b27855
parentbffb4313494bce47de37d688884fa8d534353af7 (diff)
switch to phpunit7
-rw-r--r--php-jsonlint.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index 7bb6898..3ca6a83 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-jsonlint
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -24,7 +24,7 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: JSON Lint for PHP
License: MIT
@@ -41,8 +41,8 @@ BuildArch: noarch
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7
%else
%global phpunit %{_bindir}/phpunit
BuildRequires: php-phpunit-PHPUnit >= 4.8.35
@@ -106,10 +106,10 @@ install -pm 0755 bin/jsonlint %{buildroot}%{_bindir}/jsonlint-php
%if %{with tests}
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74 php80; do
+for cmd in "php %{phpunit}" php73 php74 php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} \
+ $1 ${2:-%{_bindir}/phpunit7} \
--bootstrap %{buildroot}%{_datadir}/php/Seld/JsonLint/autoload.php \
--no-coverage \
--verbose || ret=1
@@ -133,6 +133,9 @@ exit $ret
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 1.8.3-3
+- switch to phpunit7
+
* Thu Nov 12 2020 Remi Collet <remi@remirepo.net> - 1.8.3-1
- update to 1.8.3
- sources from git snapshot