summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-fedora-autoloader.patch43
-rw-r--r--php-fedora-autoloader.spec18
2 files changed, 9 insertions, 52 deletions
diff --git a/php-fedora-autoloader.patch b/php-fedora-autoloader.patch
deleted file mode 100644
index b711daa..0000000
--- a/php-fedora-autoloader.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/tests/AutoloadTest.php b/tests/AutoloadTest.php
-index c8e53e4..f71f150 100644
---- a/tests/AutoloadTest.php
-+++ b/tests/AutoloadTest.php
-@@ -89,6 +89,7 @@ class AutoloadTest extends \PHPUnit_Framework_TestCase
- **/
- public function testAddClassMapTemplateOrderBis()
- {
-+ $nb = count(Autoload::getClassMap());
- $this->assertFalse(class_exists('Foo\\Bar'));
- require __DIR__.'/fixtures/Foo2/classmap2.php';
- require __DIR__.'/fixtures/Foo/classmap.php';
-@@ -98,7 +99,7 @@ class AutoloadTest extends \PHPUnit_Framework_TestCase
- $this->assertEquals('three', \Foo\Bar::order);
-
- $classmap = Autoload::getClassMap();
-- $this->assertEquals(2, count($classmap));
-+ $this->assertEquals($nb+2, count($classmap));
- $this->assertArrayHasKey(__DIR__.'/fixtures/Foo', $classmap);
- $this->assertArrayHasKey(__DIR__.'/fixtures/Foo2', $classmap);
- }
-diff --git a/src/Autoload.php b/src/Autoload.php
-index 5d08c84..9f85edd 100644
---- a/src/Autoload.php
-+++ b/src/Autoload.php
-@@ -209,7 +209,7 @@ class Autoload
- */
- public static function loadClass($class)
- {
-- if ($file = static::findFile($class)) {
-+ if ($file = static::findFileForClass($class)) {
- includeFile($file);
- }
- }
-@@ -219,7 +219,7 @@ class Autoload
- *
- * Checks for a classmap and then loops through PSR-4 mappings.
- */
-- public static function findFile($class)
-+ public static function findFileForClass($class)
- {
- $class = ltrim($class, '\\');
- $lower = strtolower($class);
diff --git a/php-fedora-autoloader.spec b/php-fedora-autoloader.spec
index d49a048..e5a02a7 100644
--- a/php-fedora-autoloader.spec
+++ b/php-fedora-autoloader.spec
@@ -13,8 +13,8 @@
%global github_owner php-fedora
%global github_name autoloader
-%global github_version 0.1.2
-%global github_commit 35f7b52f4682276620369bc4bc1a3a5fef93faad
+%global github_version 0.2.0
+%global github_commit acadcf9f2511ac7b777117eb66728f95faabbe99
%global composer_vendor fedora
%global composer_project autoloader
@@ -33,7 +33,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Fedora Autoloader
Group: Development/Libraries
@@ -41,8 +41,6 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-Patch0: %{name}.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
@@ -52,13 +50,13 @@ BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(theseer/autoload) >= %{phpab_min_ver}
BuildRequires: php-pear
-## phpcompatinfo (computed from version 0.1.0)
+## phpcompatinfo (computed from version 0.2.0)
BuildRequires: php-spl
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.1.0)
+# phpcompatinfo (computed from version 0.2.0)
Requires: php-spl
# Composer
@@ -94,8 +92,6 @@ Provides needed tools to build other packages:
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1 -b .upstream
-
: Set PHP directory in phpab template
sed "s#___AUTOLOAD_PATH___#'%{phpdir}/Fedora/Autoloader'#" \
-i res/phpab/fedora.php.tpl
@@ -170,6 +166,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Oct 26 2016 Shawn Iwinski <shawn@iwin.ski> - 0.2.0-1
+- Update to 0.2.0
+- Remove applied patches that are included in 0.2.0
+
* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 0.1.2-3
- rename 1 method to avoid conflicts with symfony