summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-25 15:36:33 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-25 15:36:33 +0200
commit854589a6fac819c6a655df6a1b3d84df608d2d3d (patch)
tree578d7e117adf15e6d13d7deb4cd7f74959cd7269
parent8d3f20af561bb6346c9b349fcd40937a5d898987 (diff)
php-fedora-autoloader: rename 1 method to avoid conflicts with symfony
-rw-r--r--php-fedora-autoloader.patch22
-rw-r--r--php-fedora-autoloader.spec5
2 files changed, 26 insertions, 1 deletions
diff --git a/php-fedora-autoloader.patch b/php-fedora-autoloader.patch
index c2406cd..b711daa 100644
--- a/php-fedora-autoloader.patch
+++ b/php-fedora-autoloader.patch
@@ -19,3 +19,25 @@ index c8e53e4..f71f150 100644
$this->assertArrayHasKey(__DIR__.'/fixtures/Foo', $classmap);
$this->assertArrayHasKey(__DIR__.'/fixtures/Foo2', $classmap);
}
+diff --git a/src/Autoload.php b/src/Autoload.php
+index 5d08c84..9f85edd 100644
+--- a/src/Autoload.php
++++ b/src/Autoload.php
+@@ -209,7 +209,7 @@ class Autoload
+ */
+ public static function loadClass($class)
+ {
+- if ($file = static::findFile($class)) {
++ if ($file = static::findFileForClass($class)) {
+ includeFile($file);
+ }
+ }
+@@ -219,7 +219,7 @@ class Autoload
+ *
+ * Checks for a classmap and then loops through PSR-4 mappings.
+ */
+- public static function findFile($class)
++ public static function findFileForClass($class)
+ {
+ $class = ltrim($class, '\\');
+ $lower = strtolower($class);
diff --git a/php-fedora-autoloader.spec b/php-fedora-autoloader.spec
index 2c5c047..d49a048 100644
--- a/php-fedora-autoloader.spec
+++ b/php-fedora-autoloader.spec
@@ -33,7 +33,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 3%{?github_release}%{?dist}
Summary: Fedora Autoloader
Group: Development/Libraries
@@ -170,6 +170,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 0.1.2-3
+- rename 1 method to avoid conflicts with symfony
+
* Sat Oct 22 2016 Remi Collet <remi@fedoraproject.org> - 0.1.2-2
- ensure we use newly installed autoloader in buildroot