summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-11 14:38:13 +0200
committerRemi Collet <remi@php.net>2022-07-11 14:38:13 +0200
commit41cadf320bce4484c979f6a63c01c05dd174b527 (patch)
treeb8e357639e892f846c0bf66f627eac5c09d69cb1 /php-cs-fixer.spec
parent2da37b551b2b7d3b0214efc205478603d4810792 (diff)
update to 3.9.1
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec63
1 files changed, 36 insertions, 27 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 6f9f2c4..02dedc3 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit cbad1115aac4b5c3c5540e7210d3c9fba2f81fa3
+%global gh_commit 94441633b80495464eb34eb3f7d63445221b2585
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.8.0
+Version: 3.9.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -49,34 +49,36 @@ Obsoletes: php-cs-fixer3 < 3.5
Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
+# License BSD-3-Clause
+Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
+# License MIT
Provides: bundled(php-composer-pcre) = 3.0.0
-Provides: bundled(php-composer-semver) = 3.3.1
+Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
-Provides: bundled(php-doctrine-annotations) = 1.13.2
+Provides: bundled(php-doctrine-annotations) = 1.13.3
Provides: bundled(php-doctrine-lexer) = 1.2.3
-Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.5
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
-Provides: bundled(php-symfony-event-dispatcher) = v5.4.3
-Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.6
-Provides: bundled(php-symfony-finder) = v5.4.3
+Provides: bundled(php-symfony-console) = v5.4.10
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
+Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
+Provides: bundled(php-symfony-filesystem) = v5.4.9
+Provides: bundled(php-symfony-finder) = v5.4.8
Provides: bundled(php-symfony-options-resolver) = v5.4.3
-Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.25.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.25.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.25.0
-Provides: bundled(php-symfony-process) = v5.4.5
-Provides: bundled(php-symfony-service-contracts) = v2.5.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
+Provides: bundled(php-symfony-process) = v5.4.8
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.5
-Provides: bundled(php-symfony-string) = v5.4.3
+Provides: bundled(php-symfony-string) = v5.4.10
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -107,14 +109,18 @@ php -r '
echo "cant decode json file\n";
exit(3);
}
- $lic = [];
+ $res = [];
foreach($pkgs["packages"] as $pkg) {
- printf("Provides: bundled(php-%s) = %s\n", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
- $lic = array_merge($lic, $pkg["license"]);
+ $lic = implode(" and ", $pkg["license"]);
+ if (!isset($res[$lic])) $res[$lic] = [];
+ $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
}
- sort($lic);
- printf("\nLicense: %s\n", implode(" and ", array_unique($lic)));'
-
+ ksort($res);
+ foreach($res as $lic => $lib) {
+ sort($lib);
+ printf("# License %s\n%s\n", $lic, implode("\n", $lib));
+ }
+'
%build
# Empty build section, most likely nothing required.
@@ -147,6 +153,9 @@ sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
%changelog
+* Mon Jul 11 2022 Remi Collet <remi@remirepo.net> - 3.9.1-1
+- update to 3.9.1
+
* Mon Mar 21 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
- update to 3.8.0