summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-11 14:38:13 +0200
committerRemi Collet <remi@php.net>2022-07-11 14:38:13 +0200
commit41cadf320bce4484c979f6a63c01c05dd174b527 (patch)
treeb8e357639e892f846c0bf66f627eac5c09d69cb1
parent2da37b551b2b7d3b0214efc205478603d4810792 (diff)
update to 3.9.1
-rw-r--r--composer.json3
-rw-r--r--installed.json273
-rw-r--r--php-cs-fixer.spec63
3 files changed, 176 insertions, 163 deletions
diff --git a/composer.json b/composer.json
index 5cff2a0..ea9d003 100644
--- a/composer.json
+++ b/composer.json
@@ -66,6 +66,9 @@
"php-cs-fixer"
],
"config": {
+ "allow-plugins": {
+ "ergebnis/composer-normalize": true
+ },
"sort-packages": true
}
}
diff --git a/installed.json b/installed.json
index 792764e..b4b7605 100644
--- a/installed.json
+++ b/installed.json
@@ -76,17 +76,17 @@
},
{
"name": "composer/semver",
- "version": "3.3.1",
- "version_normalized": "3.3.1.0",
+ "version": "3.3.2",
+ "version_normalized": "3.3.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71"
+ "reference": "3953f23262f2bff1919fc82183ad9acb13ff62c9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/5d8e574bb0e69188786b8ef77d43341222a41a71",
- "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71",
+ "url": "https://api.github.com/repos/composer/semver/zipball/3953f23262f2bff1919fc82183ad9acb13ff62c9",
+ "reference": "3953f23262f2bff1919fc82183ad9acb13ff62c9",
"shasum": ""
},
"require": {
@@ -96,7 +96,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2022-03-16T11:22:07+00:00",
+ "time": "2022-04-01T19:23:25+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -140,7 +140,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.3.1"
+ "source": "https://github.com/composer/semver/tree/3.3.2"
},
"funding": [
{
@@ -229,17 +229,17 @@
},
{
"name": "doctrine/annotations",
- "version": "1.13.2",
- "version_normalized": "1.13.2.0",
+ "version": "1.13.3",
+ "version_normalized": "1.13.3.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/annotations.git",
- "reference": "5b668aef16090008790395c02c893b1ba13f7e08"
+ "reference": "648b0343343565c4a056bfc8392201385e8d89f0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/annotations/zipball/5b668aef16090008790395c02c893b1ba13f7e08",
- "reference": "5b668aef16090008790395c02c893b1ba13f7e08",
+ "url": "https://api.github.com/repos/doctrine/annotations/zipball/648b0343343565c4a056bfc8392201385e8d89f0",
+ "reference": "648b0343343565c4a056bfc8392201385e8d89f0",
"shasum": ""
},
"require": {
@@ -251,11 +251,12 @@
"require-dev": {
"doctrine/cache": "^1.11 || ^2.0",
"doctrine/coding-standard": "^6.0 || ^8.1",
- "phpstan/phpstan": "^0.12.20",
+ "phpstan/phpstan": "^1.4.10 || ^1.8.0",
"phpunit/phpunit": "^7.5 || ^8.0 || ^9.1.5",
- "symfony/cache": "^4.4 || ^5.2"
+ "symfony/cache": "^4.4 || ^5.2",
+ "vimeo/psalm": "^4.10"
},
- "time": "2021-08-05T19:00:23+00:00",
+ "time": "2022-07-02T10:48:51+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -298,7 +299,7 @@
],
"support": {
"issues": "https://github.com/doctrine/annotations/issues",
- "source": "https://github.com/doctrine/annotations/tree/1.13.2"
+ "source": "https://github.com/doctrine/annotations/tree/1.13.3"
},
"install-path": "../doctrine/annotations"
},
@@ -647,17 +648,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.5",
- "version_normalized": "5.4.5.0",
+ "version": "v5.4.10",
+ "version_normalized": "5.4.10.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad"
+ "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/d8111acc99876953f52fe16d4c50eb60940d49ad",
- "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad",
+ "url": "https://api.github.com/repos/symfony/console/zipball/4d671ab4ddac94ee439ea73649c69d9d200b5000",
+ "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000",
"shasum": ""
},
"require": {
@@ -695,7 +696,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-02-24T12:45:35+00:00",
+ "time": "2022-06-26T13:00:04+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -729,7 +730,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.5"
+ "source": "https://github.com/symfony/console/tree/v5.4.10"
},
"funding": [
{
@@ -749,23 +750,23 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v2.5.0",
- "version_normalized": "2.5.0.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "6f981ee24cf69ee7ce9736146d1c57c2780598a8"
+ "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/6f981ee24cf69ee7ce9736146d1c57c2780598a8",
- "reference": "6f981ee24cf69ee7ce9736146d1c57c2780598a8",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
+ "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-07-12T14:48:14+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -799,7 +800,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.0"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -819,17 +820,17 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.9",
+ "version_normalized": "5.4.9.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "dec8a9f58d20df252b9cd89f1c6c1530f747685d"
+ "reference": "8e6ce1cc0279e3ff3c8ff0f43813bc88d21ca1bc"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/dec8a9f58d20df252b9cd89f1c6c1530f747685d",
- "reference": "dec8a9f58d20df252b9cd89f1c6c1530f747685d",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/8e6ce1cc0279e3ff3c8ff0f43813bc88d21ca1bc",
+ "reference": "8e6ce1cc0279e3ff3c8ff0f43813bc88d21ca1bc",
"shasum": ""
},
"require": {
@@ -859,7 +860,7 @@
"symfony/dependency-injection": "",
"symfony/http-kernel": ""
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-05-05T16:45:39+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -887,7 +888,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.3"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.9"
},
"funding": [
{
@@ -907,17 +908,17 @@
},
{
"name": "symfony/event-dispatcher-contracts",
- "version": "v2.5.0",
- "version_normalized": "2.5.0.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher-contracts.git",
- "reference": "66bea3b09be61613cd3b4043a65a8ec48cfa6d2a"
+ "reference": "f98b54df6ad059855739db6fcbc2d36995283fe1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/66bea3b09be61613cd3b4043a65a8ec48cfa6d2a",
- "reference": "66bea3b09be61613cd3b4043a65a8ec48cfa6d2a",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/f98b54df6ad059855739db6fcbc2d36995283fe1",
+ "reference": "f98b54df6ad059855739db6fcbc2d36995283fe1",
"shasum": ""
},
"require": {
@@ -927,7 +928,7 @@
"suggest": {
"symfony/event-dispatcher-implementation": ""
},
- "time": "2021-07-12T14:48:14+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -969,7 +970,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v2.5.0"
+ "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -989,17 +990,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.6",
- "version_normalized": "5.4.6.0",
+ "version": "v5.4.9",
+ "version_normalized": "5.4.9.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "d53a45039974952af7f7ebc461ccdd4295e29440"
+ "reference": "36a017fa4cce1eff1b8e8129ff53513abcef05ba"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/d53a45039974952af7f7ebc461ccdd4295e29440",
- "reference": "d53a45039974952af7f7ebc461ccdd4295e29440",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/36a017fa4cce1eff1b8e8129ff53513abcef05ba",
+ "reference": "36a017fa4cce1eff1b8e8129ff53513abcef05ba",
"shasum": ""
},
"require": {
@@ -1008,7 +1009,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-03-02T12:42:23+00:00",
+ "time": "2022-05-20T13:55:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1036,7 +1037,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.6"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.9"
},
"funding": [
{
@@ -1056,17 +1057,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.8",
+ "version_normalized": "5.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "231313534dded84c7ecaa79d14bc5da4ccb69b7d"
+ "reference": "9b630f3427f3ebe7cd346c277a1408b00249dad9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/231313534dded84c7ecaa79d14bc5da4ccb69b7d",
- "reference": "231313534dded84c7ecaa79d14bc5da4ccb69b7d",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/9b630f3427f3ebe7cd346c277a1408b00249dad9",
+ "reference": "9b630f3427f3ebe7cd346c277a1408b00249dad9",
"shasum": ""
},
"require": {
@@ -1074,7 +1075,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-26T16:34:36+00:00",
+ "time": "2022-04-15T08:07:45+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1102,7 +1103,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.3"
+ "source": "https://github.com/symfony/finder/tree/v5.4.8"
},
"funding": [
{
@@ -1194,17 +1195,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "30885182c981ab175d4d034db0f6f469898070ab"
+ "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/30885182c981ab175d4d034db0f6f469898070ab",
- "reference": "30885182c981ab175d4d034db0f6f469898070ab",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
+ "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
"shasum": ""
},
"require": {
@@ -1216,11 +1217,11 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2021-10-20T20:35:02+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1259,7 +1260,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.26.0"
},
"funding": [
{
@@ -1279,17 +1280,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "81b86b50cf841a64252b439e738e97f4a34e2783"
+ "reference": "433d05519ce6990bf3530fba6957499d327395c2"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/81b86b50cf841a64252b439e738e97f4a34e2783",
- "reference": "81b86b50cf841a64252b439e738e97f4a34e2783",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/433d05519ce6990bf3530fba6957499d327395c2",
+ "reference": "433d05519ce6990bf3530fba6957499d327395c2",
"shasum": ""
},
"require": {
@@ -1298,11 +1299,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2021-11-23T21:10:46+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1343,7 +1344,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.26.0"
},
"funding": [
{
@@ -1363,17 +1364,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "8590a5f561694770bdcd3f9b5c69dde6945028e8"
+ "reference": "219aa369ceff116e673852dce47c3a41794c14bd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/8590a5f561694770bdcd3f9b5c69dde6945028e8",
- "reference": "8590a5f561694770bdcd3f9b5c69dde6945028e8",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/219aa369ceff116e673852dce47c3a41794c14bd",
+ "reference": "219aa369ceff116e673852dce47c3a41794c14bd",
"shasum": ""
},
"require": {
@@ -1382,11 +1383,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2021-02-19T12:13:01+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1430,7 +1431,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.26.0"
},
"funding": [
{
@@ -1450,17 +1451,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "0abb51d2f102e00a4eefcf46ba7fec406d245825"
+ "reference": "9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/0abb51d2f102e00a4eefcf46ba7fec406d245825",
- "reference": "0abb51d2f102e00a4eefcf46ba7fec406d245825",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e",
+ "reference": "9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e",
"shasum": ""
},
"require": {
@@ -1472,11 +1473,11 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2021-11-30T18:21:41+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1516,7 +1517,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.26.0"
},
"funding": [
{
@@ -1536,27 +1537,27 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
- "reference": "cc5db0e22b3cb4111010e48785a97f670b350ca5"
+ "reference": "e440d35fa0286f77fb45b79a03fedbeda9307e85"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/cc5db0e22b3cb4111010e48785a97f670b350ca5",
- "reference": "cc5db0e22b3cb4111010e48785a97f670b350ca5",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/e440d35fa0286f77fb45b79a03fedbeda9307e85",
+ "reference": "e440d35fa0286f77fb45b79a03fedbeda9307e85",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-06-05T21:20:04+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1598,7 +1599,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.26.0"
},
"funding": [
{
@@ -1618,27 +1619,27 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c"
+ "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/4407588e0d3f1f52efb65fbe92babe41f37fe50c",
- "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/cfa0ae98841b9e461207c13ab093d76b0fa7bace",
+ "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-03-04T08:16:47+00:00",
+ "time": "2022-05-10T07:21:04+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1684,7 +1685,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.26.0"
},
"funding": [
{
@@ -1704,27 +1705,27 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.25.0",
- "version_normalized": "1.25.0.0",
+ "version": "v1.26.0",
+ "version_normalized": "1.26.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "5de4ba2d41b15f9bd0e19b2ab9674135813ec98f"
+ "reference": "13f6d1271c663dc5ae9fb843a8f16521db7687a1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/5de4ba2d41b15f9bd0e19b2ab9674135813ec98f",
- "reference": "5de4ba2d41b15f9bd0e19b2ab9674135813ec98f",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/13f6d1271c663dc5ae9fb843a8f16521db7687a1",
+ "reference": "13f6d1271c663dc5ae9fb843a8f16521db7687a1",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-09-13T13:58:11+00:00",
+ "time": "2022-05-24T11:49:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.23-dev"
+ "dev-main": "1.26-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1766,7 +1767,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.25.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.26.0"
},
"funding": [
{
@@ -1786,24 +1787,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.5",
- "version_normalized": "5.4.5.0",
+ "version": "v5.4.8",
+ "version_normalized": "5.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "95440409896f90a5f85db07a32b517ecec17fa4c"
+ "reference": "597f3fff8e3e91836bb0bd38f5718b56ddbde2f3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/95440409896f90a5f85db07a32b517ecec17fa4c",
- "reference": "95440409896f90a5f85db07a32b517ecec17fa4c",
+ "url": "https://api.github.com/repos/symfony/process/zipball/597f3fff8e3e91836bb0bd38f5718b56ddbde2f3",
+ "reference": "597f3fff8e3e91836bb0bd38f5718b56ddbde2f3",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-30T18:16:22+00:00",
+ "time": "2022-04-08T05:07:18+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1831,7 +1832,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.5"
+ "source": "https://github.com/symfony/process/tree/v5.4.8"
},
"funding": [
{
@@ -1851,23 +1852,23 @@
},
{
"name": "symfony/service-contracts",
- "version": "v2.5.0",
- "version_normalized": "2.5.0.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "1ab11b933cd6bc5464b08e81e2c5b07dec58b0fc"
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/1ab11b933cd6bc5464b08e81e2c5b07dec58b0fc",
- "reference": "1ab11b933cd6bc5464b08e81e2c5b07dec58b0fc",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"psr/container": "^1.1",
- "symfony/deprecation-contracts": "^2.1"
+ "symfony/deprecation-contracts": "^2.1|^3"
},
"conflict": {
"ext-psr": "<1.1|>=2"
@@ -1875,7 +1876,7 @@
"suggest": {
"symfony/service-implementation": ""
},
- "time": "2021-11-04T16:48:04+00:00",
+ "time": "2022-05-30T19:17:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1917,7 +1918,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v2.5.0"
+ "source": "https://github.com/symfony/service-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -2002,17 +2003,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.10",
+ "version_normalized": "5.4.10.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "92043b7d8383e48104e411bc9434b260dbeb5a10"
+ "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/92043b7d8383e48104e411bc9434b260dbeb5a10",
- "reference": "92043b7d8383e48104e411bc9434b260dbeb5a10",
+ "url": "https://api.github.com/repos/symfony/string/zipball/4432bc7df82a554b3e413a8570ce2fea90e94097",
+ "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097",
"shasum": ""
},
"require": {
@@ -2032,7 +2033,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-06-26T15:57:47+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2071,7 +2072,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.3"
+ "source": "https://github.com/symfony/string/tree/v5.4.10"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 6f9f2c4..02dedc3 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit cbad1115aac4b5c3c5540e7210d3c9fba2f81fa3
+%global gh_commit 94441633b80495464eb34eb3f7d63445221b2585
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.8.0
+Version: 3.9.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -49,34 +49,36 @@ Obsoletes: php-cs-fixer3 < 3.5
Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
+# License BSD-3-Clause
+Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
+# License MIT
Provides: bundled(php-composer-pcre) = 3.0.0
-Provides: bundled(php-composer-semver) = 3.3.1
+Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
-Provides: bundled(php-doctrine-annotations) = 1.13.2
+Provides: bundled(php-doctrine-annotations) = 1.13.3
Provides: bundled(php-doctrine-lexer) = 1.2.3
-Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.5
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
-Provides: bundled(php-symfony-event-dispatcher) = v5.4.3
-Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.6
-Provides: bundled(php-symfony-finder) = v5.4.3
+Provides: bundled(php-symfony-console) = v5.4.10
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
+Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
+Provides: bundled(php-symfony-filesystem) = v5.4.9
+Provides: bundled(php-symfony-finder) = v5.4.8
Provides: bundled(php-symfony-options-resolver) = v5.4.3
-Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.25.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.25.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.25.0
-Provides: bundled(php-symfony-process) = v5.4.5
-Provides: bundled(php-symfony-service-contracts) = v2.5.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
+Provides: bundled(php-symfony-process) = v5.4.8
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.5
-Provides: bundled(php-symfony-string) = v5.4.3
+Provides: bundled(php-symfony-string) = v5.4.10
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -107,14 +109,18 @@ php -r '
echo "cant decode json file\n";
exit(3);
}
- $lic = [];
+ $res = [];
foreach($pkgs["packages"] as $pkg) {
- printf("Provides: bundled(php-%s) = %s\n", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
- $lic = array_merge($lic, $pkg["license"]);
+ $lic = implode(" and ", $pkg["license"]);
+ if (!isset($res[$lic])) $res[$lic] = [];
+ $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
}
- sort($lic);
- printf("\nLicense: %s\n", implode(" and ", array_unique($lic)));'
-
+ ksort($res);
+ foreach($res as $lic => $lib) {
+ sort($lib);
+ printf("# License %s\n%s\n", $lic, implode("\n", $lib));
+ }
+'
%build
# Empty build section, most likely nothing required.
@@ -147,6 +153,9 @@ sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
%changelog
+* Mon Jul 11 2022 Remi Collet <remi@remirepo.net> - 3.9.1-1
+- update to 3.9.1
+
* Mon Mar 21 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
- update to 3.8.0