summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-10 08:31:40 +0100
committerRemi Collet <remi@php.net>2023-02-10 08:31:40 +0100
commite23b28dafa1bfe0a49ab7a49b8db17763a6b8106 (patch)
tree6726cef8cf3301705a33f901fd3b7f7d53606a97
parent95dbb0e1a0595708a9a0e97785737581f6fbc48d (diff)
Revert "raise dependency on PHP 8.0 and update bundled libraries"
This reverts commit 95dbb0e1a0595708a9a0e97785737581f6fbc48d.
-rw-r--r--installed.json399
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-cs-fixer.spec38
3 files changed, 264 insertions, 175 deletions
diff --git a/installed.json b/installed.json
index c12c3a1..014fb12 100644
--- a/installed.json
+++ b/installed.json
@@ -435,23 +435,23 @@
},
{
"name": "psr/cache",
- "version": "3.0.0",
- "version_normalized": "3.0.0.0",
+ "version": "1.0.1",
+ "version_normalized": "1.0.1.0",
"source": {
"type": "git",
"url": "https://github.com/php-fig/cache.git",
- "reference": "aa5030cfa5405eccfdcb1083ce040c2cb8d253bf"
+ "reference": "d11b50ad223250cf17b86e38383413f5a6764bf8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/php-fig/cache/zipball/aa5030cfa5405eccfdcb1083ce040c2cb8d253bf",
- "reference": "aa5030cfa5405eccfdcb1083ce040c2cb8d253bf",
+ "url": "https://api.github.com/repos/php-fig/cache/zipball/d11b50ad223250cf17b86e38383413f5a6764bf8",
+ "reference": "d11b50ad223250cf17b86e38383413f5a6764bf8",
"shasum": ""
},
"require": {
- "php": ">=8.0.0"
+ "php": ">=5.3.0"
},
- "time": "2021-02-03T23:26:27+00:00",
+ "time": "2016-08-06T20:24:11+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -471,7 +471,7 @@
"authors": [
{
"name": "PHP-FIG",
- "homepage": "https://www.php-fig.org/"
+ "homepage": "http://www.php-fig.org/"
}
],
"description": "Common interface for caching libraries",
@@ -481,35 +481,30 @@
"psr-6"
],
"support": {
- "source": "https://github.com/php-fig/cache/tree/3.0.0"
+ "source": "https://github.com/php-fig/cache/tree/master"
},
"install-path": "../psr/cache"
},
{
"name": "psr/container",
- "version": "2.0.2",
- "version_normalized": "2.0.2.0",
+ "version": "1.1.2",
+ "version_normalized": "1.1.2.0",
"source": {
"type": "git",
"url": "https://github.com/php-fig/container.git",
- "reference": "c71ecc56dfe541dbd90c5360474fbc405f8d5963"
+ "reference": "513e0666f7216c7459170d56df27dfcefe1689ea"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/php-fig/container/zipball/c71ecc56dfe541dbd90c5360474fbc405f8d5963",
- "reference": "c71ecc56dfe541dbd90c5360474fbc405f8d5963",
+ "url": "https://api.github.com/repos/php-fig/container/zipball/513e0666f7216c7459170d56df27dfcefe1689ea",
+ "reference": "513e0666f7216c7459170d56df27dfcefe1689ea",
"shasum": ""
},
"require": {
"php": ">=7.4.0"
},
- "time": "2021-11-05T16:47:00+00:00",
+ "time": "2021-11-05T16:50:12+00:00",
"type": "library",
- "extra": {
- "branch-alias": {
- "dev-master": "2.0.x-dev"
- }
- },
"installation-source": "dist",
"autoload": {
"psr-4": {
@@ -537,7 +532,7 @@
],
"support": {
"issues": "https://github.com/php-fig/container/issues",
- "source": "https://github.com/php-fig/container/tree/2.0.2"
+ "source": "https://github.com/php-fig/container/tree/1.1.2"
},
"install-path": "../psr/container"
},
@@ -596,33 +591,33 @@
},
{
"name": "psr/log",
- "version": "2.0.0",
- "version_normalized": "2.0.0.0",
+ "version": "1.1.4",
+ "version_normalized": "1.1.4.0",
"source": {
"type": "git",
"url": "https://github.com/php-fig/log.git",
- "reference": "ef29f6d262798707a9edd554e2b82517ef3a9376"
+ "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/php-fig/log/zipball/ef29f6d262798707a9edd554e2b82517ef3a9376",
- "reference": "ef29f6d262798707a9edd554e2b82517ef3a9376",
+ "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
+ "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
"shasum": ""
},
"require": {
- "php": ">=8.0.0"
+ "php": ">=5.3.0"
},
- "time": "2021-07-14T16:41:46+00:00",
+ "time": "2021-05-03T11:20:27+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-master": "2.0.x-dev"
+ "dev-master": "1.1.x-dev"
}
},
"installation-source": "dist",
"autoload": {
"psr-4": {
- "Psr\\Log\\": "src"
+ "Psr\\Log\\": "Psr/Log/"
}
},
"notification-url": "https://packagist.org/downloads/",
@@ -643,7 +638,7 @@
"psr-3"
],
"support": {
- "source": "https://github.com/php-fig/log/tree/2.0.0"
+ "source": "https://github.com/php-fig/log/tree/1.1.4"
},
"install-path": "../psr/log"
},
@@ -718,43 +713,47 @@
},
{
"name": "symfony/console",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "c3ebc83d031b71c39da318ca8b7a07ecc67507ed"
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/c3ebc83d031b71c39da318ca8b7a07ecc67507ed",
- "reference": "c3ebc83d031b71c39da318ca8b7a07ecc67507ed",
+ "url": "https://api.github.com/repos/symfony/console/zipball/dccb8d251a9017d5994c988b034d3e18aaabf740",
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=7.2.5",
+ "symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-mbstring": "~1.0",
+ "symfony/polyfill-php73": "^1.9",
+ "symfony/polyfill-php80": "^1.16",
"symfony/service-contracts": "^1.1|^2|^3",
- "symfony/string": "^5.4|^6.0"
+ "symfony/string": "^5.1|^6.0"
},
"conflict": {
- "symfony/dependency-injection": "<5.4",
- "symfony/dotenv": "<5.4",
- "symfony/event-dispatcher": "<5.4",
- "symfony/lock": "<5.4",
- "symfony/process": "<5.4"
+ "psr/log": ">=3",
+ "symfony/dependency-injection": "<4.4",
+ "symfony/dotenv": "<5.1",
+ "symfony/event-dispatcher": "<4.4",
+ "symfony/lock": "<4.4",
+ "symfony/process": "<4.4"
},
"provide": {
- "psr/log-implementation": "1.0|2.0|3.0"
+ "psr/log-implementation": "1.0|2.0"
},
"require-dev": {
- "psr/log": "^1|^2|^3",
- "symfony/config": "^5.4|^6.0",
- "symfony/dependency-injection": "^5.4|^6.0",
- "symfony/event-dispatcher": "^5.4|^6.0",
- "symfony/lock": "^5.4|^6.0",
- "symfony/process": "^5.4|^6.0",
- "symfony/var-dumper": "^5.4|^6.0"
+ "psr/log": "^1|^2",
+ "symfony/config": "^4.4|^5.0|^6.0",
+ "symfony/dependency-injection": "^4.4|^5.0|^6.0",
+ "symfony/event-dispatcher": "^4.4|^5.0|^6.0",
+ "symfony/lock": "^4.4|^5.0|^6.0",
+ "symfony/process": "^4.4|^5.0|^6.0",
+ "symfony/var-dumper": "^4.4|^5.0|^6.0"
},
"suggest": {
"psr/log": "For using the console logger",
@@ -762,7 +761,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -796,7 +795,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v6.0.19"
+ "source": "https://github.com/symfony/console/tree/v5.4.19"
},
"funding": [
{
@@ -816,27 +815,27 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "26954b3d62a6c5fd0ea8a2a00c0353a14978d05c"
+ "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/26954b3d62a6c5fd0ea8a2a00c0353a14978d05c",
- "reference": "26954b3d62a6c5fd0ea8a2a00c0353a14978d05c",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
+ "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=7.1"
},
- "time": "2022-01-02T09:55:41+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "2.5-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -866,7 +865,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -886,45 +885,47 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "2eaf8e63bc5b8cefabd4a800157f0d0c094f677a"
+ "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/2eaf8e63bc5b8cefabd4a800157f0d0c094f677a",
- "reference": "2eaf8e63bc5b8cefabd4a800157f0d0c094f677a",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/abf49cc084c087d94b4cb939c3f3672971784e0c",
+ "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "symfony/event-dispatcher-contracts": "^2|^3"
+ "php": ">=7.2.5",
+ "symfony/deprecation-contracts": "^2.1|^3",
+ "symfony/event-dispatcher-contracts": "^2|^3",
+ "symfony/polyfill-php80": "^1.16"
},
"conflict": {
- "symfony/dependency-injection": "<5.4"
+ "symfony/dependency-injection": "<4.4"
},
"provide": {
"psr/event-dispatcher-implementation": "1.0",
- "symfony/event-dispatcher-implementation": "2.0|3.0"
+ "symfony/event-dispatcher-implementation": "2.0"
},
"require-dev": {
"psr/log": "^1|^2|^3",
- "symfony/config": "^5.4|^6.0",
- "symfony/dependency-injection": "^5.4|^6.0",
- "symfony/error-handler": "^5.4|^6.0",
- "symfony/expression-language": "^5.4|^6.0",
- "symfony/http-foundation": "^5.4|^6.0",
+ "symfony/config": "^4.4|^5.0|^6.0",
+ "symfony/dependency-injection": "^4.4|^5.0|^6.0",
+ "symfony/error-handler": "^4.4|^5.0|^6.0",
+ "symfony/expression-language": "^4.4|^5.0|^6.0",
+ "symfony/http-foundation": "^4.4|^5.0|^6.0",
"symfony/service-contracts": "^1.1|^2|^3",
- "symfony/stopwatch": "^5.4|^6.0"
+ "symfony/stopwatch": "^4.4|^5.0|^6.0"
},
"suggest": {
"symfony/dependency-injection": "",
"symfony/http-kernel": ""
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -952,7 +953,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v6.0.19"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.19"
},
"funding": [
{
@@ -972,31 +973,31 @@
},
{
"name": "symfony/event-dispatcher-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher-contracts.git",
- "reference": "7bc61cc2db649b4637d331240c5346dcc7708051"
+ "reference": "f98b54df6ad059855739db6fcbc2d36995283fe1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/7bc61cc2db649b4637d331240c5346dcc7708051",
- "reference": "7bc61cc2db649b4637d331240c5346dcc7708051",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/f98b54df6ad059855739db6fcbc2d36995283fe1",
+ "reference": "f98b54df6ad059855739db6fcbc2d36995283fe1",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=7.2.5",
"psr/event-dispatcher": "^1"
},
"suggest": {
"symfony/event-dispatcher-implementation": ""
},
- "time": "2022-01-02T09:55:41+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "2.5-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -1034,7 +1035,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -1054,25 +1055,26 @@
},
{
"name": "symfony/filesystem",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "3d49eec03fda1f0fc19b7349fbbe55ebc1004214"
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/3d49eec03fda1f0fc19b7349fbbe55ebc1004214",
- "reference": "3d49eec03fda1f0fc19b7349fbbe55ebc1004214",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/648bfaca6a494f3e22378123bcee2894045dc9d8",
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=7.2.5",
"symfony/polyfill-ctype": "~1.8",
- "symfony/polyfill-mbstring": "~1.8"
+ "symfony/polyfill-mbstring": "~1.8",
+ "symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-20T17:44:14+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1100,7 +1102,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v6.0.19"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.19"
},
"funding": [
{
@@ -1120,23 +1122,25 @@
},
{
"name": "symfony/finder",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "5cc9cac6586fc0c28cd173780ca696e419fefa11"
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/5cc9cac6586fc0c28cd173780ca696e419fefa11",
- "reference": "5cc9cac6586fc0c28cd173780ca696e419fefa11",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/6071aebf810ad13fe8200c224f36103abb37cf1f",
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=7.2.5",
+ "symfony/deprecation-contracts": "^2.1|^3",
+ "symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-20T17:44:14+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1164,7 +1168,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v6.0.19"
+ "source": "https://github.com/symfony/finder/tree/v5.4.19"
},
"funding": [
{
@@ -1184,24 +1188,26 @@
},
{
"name": "symfony/options-resolver",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "6a180d1c45e0d9797470ca9eb46215692de00fa3"
+ "reference": "b03c99236445492f20c61666e8f7e5d388b078e5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/6a180d1c45e0d9797470ca9eb46215692de00fa3",
- "reference": "6a180d1c45e0d9797470ca9eb46215692de00fa3",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/b03c99236445492f20c61666e8f7e5d388b078e5",
+ "reference": "b03c99236445492f20c61666e8f7e5d388b078e5",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "symfony/deprecation-contracts": "^2.1|^3"
+ "php": ">=7.2.5",
+ "symfony/deprecation-contracts": "^2.1|^3",
+ "symfony/polyfill-php73": "~1.0",
+ "symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1234,7 +1240,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v6.0.19"
+ "source": "https://github.com/symfony/options-resolver/tree/v5.4.19"
},
"funding": [
{
@@ -1595,6 +1601,88 @@
"install-path": "../symfony/polyfill-mbstring"
},
{
+ "name": "symfony/polyfill-php73",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/symfony/polyfill-php73.git",
+ "reference": "9e8ecb5f92152187c4799efd3c96b78ccab18ff9"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/9e8ecb5f92152187c4799efd3c96b78ccab18ff9",
+ "reference": "9e8ecb5f92152187c4799efd3c96b78ccab18ff9",
+ "shasum": ""
+ },
+ "require": {
+ "php": ">=7.1"
+ },
+ "time": "2022-11-03T14:55:06+00:00",
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-main": "1.27-dev"
+ },
+ "thanks": {
+ "name": "symfony/polyfill",
+ "url": "https://github.com/symfony/polyfill"
+ }
+ },
+ "installation-source": "dist",
+ "autoload": {
+ "files": [
+ "bootstrap.php"
+ ],
+ "psr-4": {
+ "Symfony\\Polyfill\\Php73\\": ""
+ },
+ "classmap": [
+ "Resources/stubs"
+ ]
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Nicolas Grekas",
+ "email": "p@tchwork.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "https://symfony.com/contributors"
+ }
+ ],
+ "description": "Symfony polyfill backporting some PHP 7.3+ features to lower PHP versions",
+ "homepage": "https://symfony.com",
+ "keywords": [
+ "compatibility",
+ "polyfill",
+ "portable",
+ "shim"
+ ],
+ "support": {
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.27.0"
+ },
+ "funding": [
+ {
+ "url": "https://symfony.com/sponsor",
+ "type": "custom"
+ },
+ {
+ "url": "https://github.com/fabpot",
+ "type": "github"
+ },
+ {
+ "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
+ "type": "tidelift"
+ }
+ ],
+ "install-path": "../symfony/polyfill-php73"
+ },
+ {
"name": "symfony/polyfill-php80",
"version": "v1.27.0",
"version_normalized": "1.27.0.0",
@@ -1764,23 +1852,24 @@
},
{
"name": "symfony/process",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "2114fd60f26a296cc403a7939ab91478475a33d4"
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/2114fd60f26a296cc403a7939ab91478475a33d4",
- "reference": "2114fd60f26a296cc403a7939ab91478475a33d4",
+ "url": "https://api.github.com/repos/symfony/process/zipball/c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=7.2.5",
+ "symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1808,7 +1897,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v6.0.19"
+ "source": "https://github.com/symfony/process/tree/v5.4.19"
},
"funding": [
{
@@ -1828,22 +1917,23 @@
},
{
"name": "symfony/service-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "d78d39c1599bd1188b8e26bb341da52c3c6d8a66"
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/d78d39c1599bd1188b8e26bb341da52c3c6d8a66",
- "reference": "d78d39c1599bd1188b8e26bb341da52c3c6d8a66",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "psr/container": "^2.0"
+ "php": ">=7.2.5",
+ "psr/container": "^1.1",
+ "symfony/deprecation-contracts": "^2.1|^3"
},
"conflict": {
"ext-psr": "<1.1|>=2"
@@ -1851,11 +1941,11 @@
"suggest": {
"symfony/service-implementation": ""
},
- "time": "2022-05-30T19:17:58+00:00",
+ "time": "2022-05-30T19:17:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "2.5-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -1893,7 +1983,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/service-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -1913,24 +2003,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "011e781839dd1d2eb8119f65ac516a530f60226d"
+ "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/011e781839dd1d2eb8119f65ac516a530f60226d",
- "reference": "011e781839dd1d2eb8119f65ac516a530f60226d",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/bd2b066090fd6a67039371098fa25a84cb2679ec",
+ "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=7.2.5",
"symfony/service-contracts": "^1|^2|^3"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1958,7 +2048,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v6.0.19"
+ "source": "https://github.com/symfony/stopwatch/tree/v5.4.19"
},
"funding": [
{
@@ -1978,36 +2068,37 @@
},
{
"name": "symfony/string",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "d9e72497367c23e08bf94176d2be45b00a9d232a"
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/d9e72497367c23e08bf94176d2be45b00a9d232a",
- "reference": "d9e72497367c23e08bf94176d2be45b00a9d232a",
+ "url": "https://api.github.com/repos/symfony/string/zipball/0a01071610fd861cc160dfb7e2682ceec66064cb",
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=7.2.5",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-intl-grapheme": "~1.0",
"symfony/polyfill-intl-normalizer": "~1.0",
- "symfony/polyfill-mbstring": "~1.0"
+ "symfony/polyfill-mbstring": "~1.0",
+ "symfony/polyfill-php80": "~1.15"
},
"conflict": {
- "symfony/translation-contracts": "<2.0"
+ "symfony/translation-contracts": ">=3.0"
},
"require-dev": {
- "symfony/error-handler": "^5.4|^6.0",
- "symfony/http-client": "^5.4|^6.0",
- "symfony/translation-contracts": "^2.0|^3.0",
- "symfony/var-exporter": "^5.4|^6.0"
+ "symfony/error-handler": "^4.4|^5.0|^6.0",
+ "symfony/http-client": "^4.4|^5.0|^6.0",
+ "symfony/translation-contracts": "^1.1|^2",
+ "symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2046,7 +2137,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.0.19"
+ "source": "https://github.com/symfony/string/tree/v5.4.19"
},
"funding": [
{
diff --git a/makesrc.sh b/makesrc.sh
index ef1af4d..a9ba49b 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -20,7 +20,7 @@ else
git checkout $COMMIT || exit1
cp composer.json ../
- composer config platform.php 8.0.99
+ composer config platform.php 7.4
composer install --no-interaction --no-progress --no-dev --optimize-autoloader
cp vendor/composer/installed.json ../
popd
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index ac3f57c..dbc490c 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -18,7 +18,7 @@
Name: php-cs-fixer
Version: 3.14.4
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
# see bundled list below, SPDX
@@ -32,12 +32,12 @@ Source2: makesrc.sh
Patch0: %{name}-autoload.patch
BuildArch: noarch
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 7.4
BuildRequires: php-cli
BuildRequires: php-json
# see composer.json and makesrc.sh
-Requires: php(language) >= 8.0
+Requires: php(language) >= 7.4
Requires: php-json
Requires: php-tokenizer
# From phpcompatinfo report for version 3.5.0
@@ -59,27 +59,28 @@ Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-doctrine-annotations) = 2.0.1
Provides: bundled(php-doctrine-deprecations) = v1.0.0
Provides: bundled(php-doctrine-lexer) = 2.1.0
-Provides: bundled(php-psr-cache) = 3.0.0
-Provides: bundled(php-psr-container) = 2.0.2
+Provides: bundled(php-psr-cache) = 1.0.1
+Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
-Provides: bundled(php-psr-log) = 2.0.0
-Provides: bundled(php-symfony-console) = v6.0.19
-Provides: bundled(php-symfony-deprecation-contracts) = v3.0.2
-Provides: bundled(php-symfony-event-dispatcher) = v6.0.19
-Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.2
-Provides: bundled(php-symfony-filesystem) = v6.0.19
-Provides: bundled(php-symfony-finder) = v6.0.19
-Provides: bundled(php-symfony-options-resolver) = v6.0.19
+Provides: bundled(php-psr-log) = 1.1.4
+Provides: bundled(php-symfony-console) = v5.4.19
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.19
+Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-finder) = v5.4.19
+Provides: bundled(php-symfony-options-resolver) = v5.4.19
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v6.0.19
-Provides: bundled(php-symfony-service-contracts) = v3.0.2
-Provides: bundled(php-symfony-stopwatch) = v6.0.19
-Provides: bundled(php-symfony-string) = v6.0.19
+Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-stopwatch) = v5.4.19
+Provides: bundled(php-symfony-string) = v5.4.19
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -154,9 +155,6 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
-* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 3.14.4-2
-- raise dependency on PHP 8.0 and update bundled libraries
-
* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 3.14.4-1
- update to 3.14.4