summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec38
1 files changed, 18 insertions, 20 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index ac3f57c..dbc490c 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -18,7 +18,7 @@
Name: php-cs-fixer
Version: 3.14.4
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
# see bundled list below, SPDX
@@ -32,12 +32,12 @@ Source2: makesrc.sh
Patch0: %{name}-autoload.patch
BuildArch: noarch
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 7.4
BuildRequires: php-cli
BuildRequires: php-json
# see composer.json and makesrc.sh
-Requires: php(language) >= 8.0
+Requires: php(language) >= 7.4
Requires: php-json
Requires: php-tokenizer
# From phpcompatinfo report for version 3.5.0
@@ -59,27 +59,28 @@ Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-doctrine-annotations) = 2.0.1
Provides: bundled(php-doctrine-deprecations) = v1.0.0
Provides: bundled(php-doctrine-lexer) = 2.1.0
-Provides: bundled(php-psr-cache) = 3.0.0
-Provides: bundled(php-psr-container) = 2.0.2
+Provides: bundled(php-psr-cache) = 1.0.1
+Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
-Provides: bundled(php-psr-log) = 2.0.0
-Provides: bundled(php-symfony-console) = v6.0.19
-Provides: bundled(php-symfony-deprecation-contracts) = v3.0.2
-Provides: bundled(php-symfony-event-dispatcher) = v6.0.19
-Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.2
-Provides: bundled(php-symfony-filesystem) = v6.0.19
-Provides: bundled(php-symfony-finder) = v6.0.19
-Provides: bundled(php-symfony-options-resolver) = v6.0.19
+Provides: bundled(php-psr-log) = 1.1.4
+Provides: bundled(php-symfony-console) = v5.4.19
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.19
+Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-finder) = v5.4.19
+Provides: bundled(php-symfony-options-resolver) = v5.4.19
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v6.0.19
-Provides: bundled(php-symfony-service-contracts) = v3.0.2
-Provides: bundled(php-symfony-stopwatch) = v6.0.19
-Provides: bundled(php-symfony-string) = v6.0.19
+Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-stopwatch) = v5.4.19
+Provides: bundled(php-symfony-string) = v5.4.19
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -154,9 +155,6 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
-* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 3.14.4-2
-- raise dependency on PHP 8.0 and update bundled libraries
-
* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 3.14.4-1
- update to 3.14.4