summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-27 12:06:37 +0100
committerRemi Collet <remi@php.net>2023-11-27 12:06:37 +0100
commitc4e5ee77887fc5a6b3bc63b0822fb325aa8d129a (patch)
tree9abbdba7dcb83b74b8d5a0df533d931fa1806752
parent4b243a5f1876939882b687e85513c03b48204b60 (diff)
update to 3.40.0
-rw-r--r--composer.json22
-rw-r--r--php-cs-fixer.spec7
2 files changed, 16 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 8524053..dd90058 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
"php": "^7.4 || ^8.0",
"ext-json": "*",
"ext-tokenizer": "*",
- "composer/semver": "^3.3",
+ "composer/semver": "^3.4",
"composer/xdebug-handler": "^3.0.3",
"sebastian/diff": "^4.0 || ^5.0",
"symfony/console": "^5.4 || ^6.0 || ^7.0",
@@ -31,25 +31,25 @@
"symfony/filesystem": "^5.4 || ^6.0 || ^7.0",
"symfony/finder": "^5.4 || ^6.0 || ^7.0",
"symfony/options-resolver": "^5.4 || ^6.0 || ^7.0",
- "symfony/polyfill-mbstring": "^1.27",
- "symfony/polyfill-php80": "^1.27",
- "symfony/polyfill-php81": "^1.27",
+ "symfony/polyfill-mbstring": "^1.28",
+ "symfony/polyfill-php80": "^1.28",
+ "symfony/polyfill-php81": "^1.28",
"symfony/process": "^5.4 || ^6.0 || ^7.0",
"symfony/stopwatch": "^5.4 || ^6.0 || ^7.0"
},
"require-dev": {
"facile-it/paraunit": "^1.3 || ^2.0",
"justinrainbow/json-schema": "^5.2",
- "keradus/cli-executor": "^2.0",
+ "keradus/cli-executor": "^2.1",
"mikey179/vfsstream": "^1.6.11",
- "php-coveralls/php-coveralls": "^2.5.3",
+ "php-coveralls/php-coveralls": "^2.7",
"php-cs-fixer/accessible-object": "^1.1",
- "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
- "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
- "phpspec/prophecy": "^1.16",
+ "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
+ "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
+ "phpspec/prophecy": "^1.17",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5",
- "symfony/phpunit-bridge": "^6.2.3 || ^7.0",
+ "phpunit/phpunit": "^9.6",
+ "symfony/phpunit-bridge": "^6.3.8 || ^7.0",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
"suggest": {
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 61c5a3d..5329629 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 04bf7b28fc847185b247d112cab617da941e3cca
+%global gh_commit 27d2b3265b5d550ec411b4319967ae7cfddfb2e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.39.0
+Version: 3.40.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Nov 27 2023 Remi Collet <remi@remirepo.net> - 3.40.0-1
+- update to 3.40.0
+
* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 3.39.0-1
- update to 3.39.0