summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:17:12 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:17:12 +0100
commit4b243a5f1876939882b687e85513c03b48204b60 (patch)
tree3734b8b9097f5c4cfc2c1f5f0b2bcc27c97fe2e5
parentb44a97a435840c91aa2d4d07171680521e036f0c (diff)
update to 3.39.0
-rw-r--r--composer.json18
-rw-r--r--php-cs-fixer.spec7
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index ec122c6..8524053 100644
--- a/composer.json
+++ b/composer.json
@@ -26,16 +26,16 @@
"composer/semver": "^3.3",
"composer/xdebug-handler": "^3.0.3",
"sebastian/diff": "^4.0 || ^5.0",
- "symfony/console": "^5.4 || ^6.0",
- "symfony/event-dispatcher": "^5.4 || ^6.0",
- "symfony/filesystem": "^5.4 || ^6.0",
- "symfony/finder": "^5.4 || ^6.0",
- "symfony/options-resolver": "^5.4 || ^6.0",
+ "symfony/console": "^5.4 || ^6.0 || ^7.0",
+ "symfony/event-dispatcher": "^5.4 || ^6.0 || ^7.0",
+ "symfony/filesystem": "^5.4 || ^6.0 || ^7.0",
+ "symfony/finder": "^5.4 || ^6.0 || ^7.0",
+ "symfony/options-resolver": "^5.4 || ^6.0 || ^7.0",
"symfony/polyfill-mbstring": "^1.27",
"symfony/polyfill-php80": "^1.27",
"symfony/polyfill-php81": "^1.27",
- "symfony/process": "^5.4 || ^6.0",
- "symfony/stopwatch": "^5.4 || ^6.0"
+ "symfony/process": "^5.4 || ^6.0 || ^7.0",
+ "symfony/stopwatch": "^5.4 || ^6.0 || ^7.0"
},
"require-dev": {
"facile-it/paraunit": "^1.3 || ^2.0",
@@ -49,8 +49,8 @@
"phpspec/prophecy": "^1.16",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5",
- "symfony/phpunit-bridge": "^6.2.3",
- "symfony/yaml": "^5.4 || ^6.0"
+ "symfony/phpunit-bridge": "^6.2.3 || ^7.0",
+ "symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
"suggest": {
"ext-dom": "For handling output formats in XML",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 6d5b8b8..61c5a3d 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d872cdd543797ade030aaa307c0a4954a712e081
+%global gh_commit 04bf7b28fc847185b247d112cab617da941e3cca
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.38.2
+Version: 3.39.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 3.39.0-1
+- update to 3.39.0
+
* Tue Nov 14 2023 Remi Collet <remi@remirepo.net> - 3.38.2-1
- update to 3.38.2