summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-30 09:02:10 +0100
committerRemi Collet <remi@php.net>2023-12-30 09:02:10 +0100
commitc2591f43666c8c0d9f218758efc279447f7180ca (patch)
treeb0afdf0b8d6169c8a53c959e0016fdd292f764ce
parent9f7ee1b5d645178bbaaf13f8e0d07ac209a23be4 (diff)
update to 3.45.0
-rw-r--r--composer.json5
-rw-r--r--php-cs-fixer.spec7
2 files changed, 10 insertions, 2 deletions
diff --git a/composer.json b/composer.json
index 4f93cd1..7d4e843 100644
--- a/composer.json
+++ b/composer.json
@@ -130,6 +130,10 @@
"Composer\\Config::disableProcessTimeout",
"paraunit run --testsuite integration"
],
+ "test:short-open-tag": [
+ "Composer\\Config::disableProcessTimeout",
+ "@php -d short_open_tag=1 ./vendor/bin/phpunit --do-not-cache-result --testsuite short-open-tag"
+ ],
"test:smoke": [
"Composer\\Config::disableProcessTimeout",
"paraunit run --testsuite smoke"
@@ -162,6 +166,7 @@
"test:all": "Run Unit and Integration tests (but *NOT* Smoke tests)",
"test:coverage": "Run tests that provide code coverage",
"test:integration": "Run Integration tests",
+ "test:short-open-tag": "Run tests with \"short_open_tag\" enabled",
"test:smoke": "Run Smoke tests",
"test:unit": "Run Unit tests",
"unused-deps": "Verifies if app has dependencies that are not used"
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index f91ca57..abe9210 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 39b5632c39ca9deb4eb7e670ba96fcf5c3a72e3c
+%global gh_commit c0daa33cb2533cd73f48dde1c70c2afa3e7953b5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.43.0
+Version: 3.45.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Sat Dec 30 2023 Remi Collet <remi@remirepo.net> - 3.45.0-1
+- update to 3.45.0
+
* Fri Dec 29 2023 Remi Collet <remi@remirepo.net> - 3.43.0-1
- update to 3.43.0