summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-29 08:44:41 +0100
committerRemi Collet <remi@php.net>2023-12-29 08:44:41 +0100
commit9f7ee1b5d645178bbaaf13f8e0d07ac209a23be4 (patch)
treea4d45e359c6cfc779801475a482d21a0751afd1d
parent64d00023857a9b044830e09367c0038cf9a5194c (diff)
update to 3.43.0
-rw-r--r--composer.json4
-rw-r--r--php-cs-fixer.spec7
2 files changed, 7 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index 989f20f..4f93cd1 100644
--- a/composer.json
+++ b/composer.json
@@ -46,7 +46,7 @@
"php-cs-fixer/accessible-object": "^1.1",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
- "phpunit/phpunit": "^9.6",
+ "phpunit/phpunit": "^9.6 || ^10.5.5",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
"suggest": {
@@ -124,7 +124,7 @@
],
"test:coverage": [
"Composer\\Config::disableProcessTimeout",
- "paraunit coverage --testsuite unit --exclude-group covers-nothing"
+ "@composer show facile-it/paraunit ^2 && (paraunit coverage --testsuite unit --pass-through=--exclude-group=covers-nothing) || (paraunit coverage --testsuite unit --exclude-group covers-nothing)"
],
"test:integration": [
"Composer\\Config::disableProcessTimeout",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 46ba49f..f91ca57 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 632ef1be3447a9b890bef06147475facee535d0f
+%global gh_commit 39b5632c39ca9deb4eb7e670ba96fcf5c3a72e3c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.42.0
+Version: 3.43.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Fri Dec 29 2023 Remi Collet <remi@remirepo.net> - 3.43.0-1
+- update to 3.43.0
+
* Wed Dec 27 2023 Remi Collet <remi@remirepo.net> - 3.42.0-1
- update to 3.42.0