summaryrefslogtreecommitdiffstats
path: root/php-brotli.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-brotli.spec')
-rw-r--r--php-brotli.spec227
1 files changed, 127 insertions, 100 deletions
diff --git a/php-brotli.spec b/php-brotli.spec
index eac95bf..68b6d80 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -1,111 +1,69 @@
# remirepo spec file for php-brotli
#
-# Copyright (c) 2017-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-brotli}
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-brotli
-%else
-%global pkg_name %{name}
-%endif
+%bcond_without apcu
+%bcond_without libbrotli
+%bcond_without tests
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-%global with_libbrotli 1
-%else
-%global with_libbrotli 0
-%endif
-
-%global gh_commit 942eadcd2d81db045a7721cfff37f070e54dfe66
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner kjdev
-%global gh_project php-ext-brotli
-#global gh_date 20160608
%global pecl_name brotli
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Brotli Extension for PHP
-Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.7.0
-%if 0%{?gh_date:1}
-Release: 2%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
+Name: %{?scl_prefix}php-%{pecl_name}
+Version: 0.15.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
-# retrieve a recursive git snapshot with submodule
-Source1: makesrc.sh
-
-Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-brotli/pull/23.patch
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
-%if %{?with_libbrotli}
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
+BuildRequires: %{?scl_prefix}php-pear
+%if %{with libbrotli}
BuildRequires: brotli-devel >= 0.6.0
%else
-Provides: bundled(brotli) = 1.0.7
+Provides: bundled(brotli) = 1.1.0
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-%{pecl_name} <= %{version}
-Obsoletes: php71w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-%{pecl_name} <= %{version}
-Obsoletes: php72w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-%{pecl_name} <= %{version}
-Obsoletes: php73w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-%{pecl_name} <= %{version}
-Obsoletes: php74w-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
-This extension allows Brotli compression.
+PHP extension for compression and decompression with Brotli library.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-cd NTS
-%patch0 -p1
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-# replace symlink
-rm LICENSE
-mv brotli/LICENSE .
-
-%if %{?with_libbrotli}
+cd %{sources}
+%if %{with libbrotli}
# Use the system library
-mv brotli tests
+rm -r brotli
+sed -e '\:"brotli/:d' -i ../package.xml
+%else
+cp brotli/LICENSE LICENSE-brotli
%endif
# Sanity check, really often broken
@@ -116,9 +74,9 @@ if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Drop in the bit of configuration
@@ -135,14 +93,13 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%if %{?with_libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config \
-%if %{?with_libbrotli}
+ --with-php-config=%{__phpconfig} \
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -151,13 +108,9 @@ make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%if %{?with_libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config \
-%if %{?with_libbrotli}
+ --with-php-config=%{__ztsphpconfig} \
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -173,50 +126,72 @@ make %{?_smp_mflags}
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
%if %{with_zts}
# Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
%check
-cd NTS
+cd %{sources}
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+%if %{with apcu}
+: Check that apcu is aware of brotli serializer
+%{__php} --no-php-ini \
+ --define extension=apcu.so \
+ --define apc.enabled=1 \
+ --define apc.enable_cli=1 \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --ri apcu | grep '%{pecl_name}'
+%endif
+
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --offline --show-diff || : ignore
+%{__php} -n run-tests.php -q --offline --show-diff
+%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-# TODO: need investigation
-# EL6 / i386 /ZTS only
-rm tests/streams_003.phpt
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q --offline --show-diff
%endif
+%endif
%files
-%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/README.md
+%{?_licensedir:%license %{sources}/LICENSE}
+%if %{without libbrotli}
+%{?_licensedir:%license %{sources}/LICENSE-brotli}
+%endif
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -228,6 +203,58 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Feb 1 2024 Remi Collet <remi@remirepo.net> - 0.15.0-1
+- update to 0.15.0
+
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.14.2-1
+- update to 0.14.2 (no change)
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 0.14.0-2
+- rebuild for PHP 8.3.0RC1
+
+* Fri Aug 4 2023 Remi Collet <remi@remirepo.net> - 0.14.0-1
+- update to 0.14.0
+- build out of sources tree
+- sources from pecl
+
+* Sat Jan 23 2021 Remi Collet <remi@remirepo.net> - 0.13.1-1
+- update to 0.13.1
+
+* Fri Jan 22 2021 Remi Collet <remi@remirepo.net> - 0.13.0-1
+- update to 0.13.0
+
+* Fri Jan 15 2021 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+- enable apcu serializer with PHP 7+
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 0.11.1-3
+- rebuild for PHP 8.0.0RC1
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 0.11.1-2
+- rebuild for PHP 8.0.0beta3
+
+* Fri Aug 28 2020 Remi Collet <remi@remirepo.net> - 0.11.1-1
+- update to 0.11.1
+
+* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 0.11.0-2
+- rebuild for 8.0.0beta1
+
+* Tue Aug 4 2020 Remi Collet <remi@remirepo.net> - 0.11.0-1
+- update to 0.11.0
+
+* Mon Jul 27 2020 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+
+* Sat Jun 27 2020 Remi Collet <remi@remirepo.net> - 0.9.0-1
+- update to 0.9.0
+
+* Fri Jun 5 2020 Remi Collet <remi@remirepo.net> - 0.8.0-1
+- update to 0.8.0
+- drop patch merged upstream
+
+* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.7.0-4
+- rebuild for 7.4.0RC1
+
* Wed Jul 24 2019 Remi Collet <remi@remirepo.net> - 0.7.0-3
- add patch for 7.4.0beta1 from
https://github.com/kjdev/php-ext-brotli/pull/23