summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--23.patch68
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION91
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-brotli.spec227
5 files changed, 207 insertions, 211 deletions
diff --git a/23.patch b/23.patch
deleted file mode 100644
index 52af90b..0000000
--- a/23.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From ebd41e895b08445275bef0befeadb2eeba156835 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 24 Jul 2019 07:58:34 +0200
-Subject: [PATCH] fix for stream change in 7.4.0beta1
-
----
- brotli.c | 23 +++++++++++++++++++++--
- 1 file changed, 21 insertions(+), 2 deletions(-)
-
-diff --git a/brotli.c b/brotli.c
-index 891f706..87f8d2f 100644
---- a/brotli.c
-+++ b/brotli.c
-@@ -470,11 +470,19 @@ static int php_brotli_decompress_close(php_stream *stream,
- return EOF;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_brotli_decompress_read(php_stream *stream,
- char *buf,
- size_t count TSRMLS_DC)
- {
- size_t ret = 0;
-+#else
-+static ssize_t php_brotli_decompress_read(php_stream *stream,
-+ char *buf,
-+ size_t count TSRMLS_DC)
-+{
-+ ssize_t ret = 0;
-+#endif
- STREAM_DATA_FROM_STREAM();
-
- /* input */
-@@ -485,7 +493,11 @@ static size_t php_brotli_decompress_read(php_stream *stream,
- if (input) {
- efree(input);
- }
-+#if PHP_VERSION_ID < 70400
- return 0;
-+#else
-+ return -1;
-+#endif
- }
- self->available_in = php_stream_read(self->stream, input,
- brotli_buffer_size );
-@@ -592,13 +604,20 @@ static int php_brotli_compress_close(php_stream *stream,
- return EOF;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_brotli_compress_write(php_stream *stream,
- const char *buf,
- size_t count TSRMLS_DC)
- {
-- STREAM_DATA_FROM_STREAM();
--
- size_t ret = 0;
-+#else
-+static ssize_t php_brotli_compress_write(php_stream *stream,
-+ const char *buf,
-+ size_t count TSRMLS_DC)
-+{
-+ ssize_t ret = 0;
-+#endif
-+ STREAM_DATA_FROM_STREAM();
-
- size_t available_in = count;
- const uint8_t *next_in = (uint8_t *)buf;
diff --git a/PHPINFO b/PHPINFO
index 4507757..1742d1a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,6 @@
brotli
Brotli support => enabled
-Extension Version => 0.7.0
-Library Version => 1.0.5
+Extension Version => 0.15.0
+Library Version => 1.1.0
+APCu serializer ABI => 0
diff --git a/REFLECTION b/REFLECTION
index 4673319..4991f7b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,8 @@
-Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
+Extension [ <persistent> extension #63 brotli version 0.15.0 ] {
+
+ - Dependencies {
+ Dependency [ apcu (Optional) ]
+ }
- INI {
Entry [ brotli.output_compression <ALL> ]
@@ -9,13 +13,16 @@ Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
}
}
- - Constants [6] {
- Constant [ integer BROTLI_GENERIC ] { 0 }
- Constant [ integer BROTLI_TEXT ] { 1 }
- Constant [ integer BROTLI_FONT ] { 2 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_MIN ] { 0 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_MAX ] { 11 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_DEFAULT ] { 11 }
+ - Constants [9] {
+ Constant [ int BROTLI_GENERIC ] { 0 }
+ Constant [ int BROTLI_TEXT ] { 1 }
+ Constant [ int BROTLI_FONT ] { 2 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_MIN ] { 0 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_MAX ] { 11 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_DEFAULT ] { 11 }
+ Constant [ int BROTLI_PROCESS ] { 0 }
+ Constant [ int BROTLI_FLUSH ] { 1 }
+ Constant [ int BROTLI_FINISH ] { 2 }
}
- Functions {
@@ -23,30 +30,86 @@ Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $quality ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #1 [ <optional> $quality = <default> ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function brotli_uncompress ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $max ]
+ Parameter #1 [ <optional> $max = <default> ]
}
}
Function [ <internal:brotli> function Brotli\compress ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $quality ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #1 [ <optional> $quality = <default> ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function Brotli\uncompress ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $max ]
+ Parameter #1 [ <optional> $max = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function brotli_compress_init ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $quality = <default> ]
+ Parameter #1 [ <optional> $mode = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function brotli_compress_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $context ]
+ Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $mode = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function brotli_uncompress_init ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:brotli> function brotli_uncompress_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $context ]
+ Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $mode = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function Brotli\compress_init ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $quality = <default> ]
+ Parameter #1 [ <optional> $mode = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function Brotli\compress_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $context ]
+ Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $mode = <default> ]
+ }
+ }
+ Function [ <internal:brotli> function Brotli\uncompress_init ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:brotli> function Brotli\uncompress_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $context ]
+ Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
}
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index ea1e7e8..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-SHORT=${COMMIT:0:7}
-
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
-echo "Cloning..."
-rm -rf $PROJECT-$COMMIT
-git clone --recursive https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-git checkout $COMMIT
-popd
-
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
-
-echo "Done."
diff --git a/php-brotli.spec b/php-brotli.spec
index eac95bf..68b6d80 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -1,111 +1,69 @@
# remirepo spec file for php-brotli
#
-# Copyright (c) 2017-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-brotli}
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-brotli
-%else
-%global pkg_name %{name}
-%endif
+%bcond_without apcu
+%bcond_without libbrotli
+%bcond_without tests
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-%global with_libbrotli 1
-%else
-%global with_libbrotli 0
-%endif
-
-%global gh_commit 942eadcd2d81db045a7721cfff37f070e54dfe66
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner kjdev
-%global gh_project php-ext-brotli
-#global gh_date 20160608
%global pecl_name brotli
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Brotli Extension for PHP
-Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.7.0
-%if 0%{?gh_date:1}
-Release: 2%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
+Name: %{?scl_prefix}php-%{pecl_name}
+Version: 0.15.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
-# retrieve a recursive git snapshot with submodule
-Source1: makesrc.sh
-
-Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-brotli/pull/23.patch
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
-%if %{?with_libbrotli}
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
+BuildRequires: %{?scl_prefix}php-pear
+%if %{with libbrotli}
BuildRequires: brotli-devel >= 0.6.0
%else
-Provides: bundled(brotli) = 1.0.7
+Provides: bundled(brotli) = 1.1.0
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-%{pecl_name} <= %{version}
-Obsoletes: php71w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-%{pecl_name} <= %{version}
-Obsoletes: php72w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-%{pecl_name} <= %{version}
-Obsoletes: php73w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-%{pecl_name} <= %{version}
-Obsoletes: php74w-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
-This extension allows Brotli compression.
+PHP extension for compression and decompression with Brotli library.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-cd NTS
-%patch0 -p1
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-# replace symlink
-rm LICENSE
-mv brotli/LICENSE .
-
-%if %{?with_libbrotli}
+cd %{sources}
+%if %{with libbrotli}
# Use the system library
-mv brotli tests
+rm -r brotli
+sed -e '\:"brotli/:d' -i ../package.xml
+%else
+cp brotli/LICENSE LICENSE-brotli
%endif
# Sanity check, really often broken
@@ -116,9 +74,9 @@ if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Drop in the bit of configuration
@@ -135,14 +93,13 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%if %{?with_libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config \
-%if %{?with_libbrotli}
+ --with-php-config=%{__phpconfig} \
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -151,13 +108,9 @@ make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%if %{?with_libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config \
-%if %{?with_libbrotli}
+ --with-php-config=%{__ztsphpconfig} \
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -173,50 +126,72 @@ make %{?_smp_mflags}
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
%if %{with_zts}
# Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
%check
-cd NTS
+cd %{sources}
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+%if %{with apcu}
+: Check that apcu is aware of brotli serializer
+%{__php} --no-php-ini \
+ --define extension=apcu.so \
+ --define apc.enabled=1 \
+ --define apc.enable_cli=1 \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --ri apcu | grep '%{pecl_name}'
+%endif
+
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --offline --show-diff || : ignore
+%{__php} -n run-tests.php -q --offline --show-diff
+%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-# TODO: need investigation
-# EL6 / i386 /ZTS only
-rm tests/streams_003.phpt
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q --offline --show-diff
%endif
+%endif
%files
-%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/README.md
+%{?_licensedir:%license %{sources}/LICENSE}
+%if %{without libbrotli}
+%{?_licensedir:%license %{sources}/LICENSE-brotli}
+%endif
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -228,6 +203,58 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Feb 1 2024 Remi Collet <remi@remirepo.net> - 0.15.0-1
+- update to 0.15.0
+
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.14.2-1
+- update to 0.14.2 (no change)
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 0.14.0-2
+- rebuild for PHP 8.3.0RC1
+
+* Fri Aug 4 2023 Remi Collet <remi@remirepo.net> - 0.14.0-1
+- update to 0.14.0
+- build out of sources tree
+- sources from pecl
+
+* Sat Jan 23 2021 Remi Collet <remi@remirepo.net> - 0.13.1-1
+- update to 0.13.1
+
+* Fri Jan 22 2021 Remi Collet <remi@remirepo.net> - 0.13.0-1
+- update to 0.13.0
+
+* Fri Jan 15 2021 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+- enable apcu serializer with PHP 7+
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 0.11.1-3
+- rebuild for PHP 8.0.0RC1
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 0.11.1-2
+- rebuild for PHP 8.0.0beta3
+
+* Fri Aug 28 2020 Remi Collet <remi@remirepo.net> - 0.11.1-1
+- update to 0.11.1
+
+* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 0.11.0-2
+- rebuild for 8.0.0beta1
+
+* Tue Aug 4 2020 Remi Collet <remi@remirepo.net> - 0.11.0-1
+- update to 0.11.0
+
+* Mon Jul 27 2020 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+
+* Sat Jun 27 2020 Remi Collet <remi@remirepo.net> - 0.9.0-1
+- update to 0.9.0
+
+* Fri Jun 5 2020 Remi Collet <remi@remirepo.net> - 0.8.0-1
+- update to 0.8.0
+- drop patch merged upstream
+
+* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.7.0-4
+- rebuild for 7.4.0RC1
+
* Wed Jul 24 2019 Remi Collet <remi@remirepo.net> - 0.7.0-3
- add patch for 7.4.0beta1 from
https://github.com/kjdev/php-ext-brotli/pull/23