diff options
author | Remi Collet <remi@remirepo.net> | 2022-08-10 07:12:44 +0200 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2022-08-10 07:12:44 +0200 |
commit | efa0f18d4fc47b7cd81372384ab494504eb42ad1 (patch) | |
tree | ed99db879f5482b68c57e5be80ee779033f1bcd5 | |
parent | b52570a9771c606428d9ff10a3535fe366f823ba (diff) |
update to 1.1.0
raise dependency on PHP 7.2
-rw-r--r-- | PHPINFO | 2 | ||||
-rw-r--r-- | REFLECTION | 8 | ||||
-rw-r--r-- | php-ast.spec | 10 |
3 files changed, 14 insertions, 6 deletions
@@ -2,5 +2,5 @@ ast ast support => enabled -extension version => 1.0.16 +extension version => 1.1.0 AST version => Current version is 90. All versions (including experimental): {50, 60, 70, 80, 85, 90} @@ -1,6 +1,6 @@ -Extension [ <persistent> extension #69 ast version 1.0.16 ] { +Extension [ <persistent> extension #69 ast version 1.1.0 ] { - - Constants [199] { + - Constants [203] { Constant [ int ast\AST_ARG_LIST ] { 128 } Constant [ int ast\AST_LIST ] { 255 } Constant [ int ast\AST_ARRAY ] { 129 } @@ -133,10 +133,12 @@ Extension [ <persistent> extension #69 ast version 1.0.16 ] { Constant [ int ast\flags\CLASS_INTERFACE ] { 1 } Constant [ int ast\flags\CLASS_ANONYMOUS ] { 4 } Constant [ int ast\flags\CLASS_ENUM ] { 4194304 } + Constant [ int ast\flags\CLASS_READONLY ] { 8388608 } Constant [ int ast\flags\PARAM_REF ] { 8 } Constant [ int ast\flags\PARAM_VARIADIC ] { 16 } Constant [ int ast\flags\TYPE_NULL ] { 1 } Constant [ int ast\flags\TYPE_FALSE ] { 2 } + Constant [ int ast\flags\TYPE_TRUE ] { 3 } Constant [ int ast\flags\TYPE_BOOL ] { 17 } Constant [ int ast\flags\TYPE_LONG ] { 4 } Constant [ int ast\flags\TYPE_DOUBLE ] { 5 } @@ -200,6 +202,8 @@ Extension [ <persistent> extension #69 ast version 1.0.16 ] { Constant [ int ast\flags\ARRAY_SYNTAX_SHORT ] { 3 } Constant [ int ast\flags\DIM_ALTERNATIVE_SYNTAX ] { 2 } Constant [ int ast\flags\PARENTHESIZED_CONDITIONAL ] { 1 } + Constant [ int ast\flags\ENCAPS_VAR_DOLLAR_CURLY ] { 1 } + Constant [ int ast\flags\ENCAPS_VAR_DOLLAR_CURLY_VAR_VAR ] { 2 } } - Functions { diff --git a/php-ast.spec b/php-ast.spec index 9684129..30d72fc 100644 --- a/php-ast.spec +++ b/php-ast.spec @@ -1,6 +1,6 @@ # remirepo spec file for php-ast # -# Copyright (c) 2015-2021 Remi Collet +# Copyright (c) 2015-2022 Remi Collet # License: CC-BY-SA # http://creativecommons.org/licenses/by-sa/4.0/ # @@ -21,7 +21,7 @@ Summary: Abstract Syntax Tree Name: %{?scl_prefix}php-ast -Version: 1.0.16 +Version: 1.1.0 %if 0%{?gh_date:1} Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}} %else @@ -37,7 +37,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz BuildRequires: make BuildRequires: %{?dtsprefix}gcc -BuildRequires: %{?scl_prefix}php-devel >= 7.0 +BuildRequires: %{?scl_prefix}php-devel >= 7.2 BuildRequires: %{?scl_prefix}php-pear BuildRequires: %{?scl_prefix}php-tokenizer @@ -222,6 +222,10 @@ fi %changelog +* Wed Aug 10 2022 Remi Collet <remi@remirepo.net> - 1.1.0-1 +- update to 1.1.0 +- raise dependency on PHP 7.2 + * Sun Nov 28 2021 Remi Collet <remi@remirepo.net> - 1.0.16-1 - update to 1.0.16 |