summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-28 07:53:54 +0100
committerRemi Collet <remi@php.net>2021-11-28 07:53:54 +0100
commitb52570a9771c606428d9ff10a3535fe366f823ba (patch)
tree677e94892b71d26e255f61bd6041029c5544d76a
parentc8106c2c33fe92d150326c5d65d1e5e40990a687 (diff)
update to 1.0.16
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION156
-rw-r--r--php-ast.spec13
3 files changed, 86 insertions, 85 deletions
diff --git a/PHPINFO b/PHPINFO
index 888c86c..e24f6b2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.0.14
+extension version => 1.0.16
AST version => Current version is 90. All versions (including experimental): {50, 60, 70, 80, 85, 90}
diff --git a/REFLECTION b/REFLECTION
index fb55a5e..631dca4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #67 ast version 1.0.14 ] {
+Extension [ <persistent> extension #69 ast version 1.0.16 ] {
- Constants [199] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
@@ -18,11 +18,11 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Constant [ int ast\AST_NAME_LIST ] { 141 }
Constant [ int ast\AST_TRAIT_ADAPTATIONS ] { 142 }
Constant [ int ast\AST_USE ] { 143 }
- Constant [ int ast\AST_TYPE_UNION ] { 254 }
+ Constant [ int ast\AST_TYPE_UNION ] { 144 }
Constant [ int ast\AST_TYPE_INTERSECTION ] { 250 }
- Constant [ int ast\AST_ATTRIBUTE_LIST ] { 253 }
- Constant [ int ast\AST_ATTRIBUTE_GROUP ] { 251 }
- Constant [ int ast\AST_MATCH_ARM_LIST ] { 252 }
+ Constant [ int ast\AST_ATTRIBUTE_LIST ] { 145 }
+ Constant [ int ast\AST_ATTRIBUTE_GROUP ] { 146 }
+ Constant [ int ast\AST_MATCH_ARM_LIST ] { 147 }
Constant [ int ast\AST_NAME ] { 2048 }
Constant [ int ast\AST_CLOSURE_VAR ] { 2049 }
Constant [ int ast\AST_NULLABLE_TYPE ] { 2050 }
@@ -63,52 +63,52 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Constant [ int ast\AST_BREAK ] { 286 }
Constant [ int ast\AST_CONTINUE ] { 287 }
Constant [ int ast\AST_CLASS_NAME ] { 276 }
- Constant [ int ast\AST_CLASS_CONST_GROUP ] { 766 }
+ Constant [ int ast\AST_CLASS_CONST_GROUP ] { 546 }
Constant [ int ast\AST_DIM ] { 512 }
Constant [ int ast\AST_PROP ] { 513 }
- Constant [ int ast\AST_NULLSAFE_PROP ] { 761 }
- Constant [ int ast\AST_STATIC_PROP ] { 514 }
- Constant [ int ast\AST_CALL ] { 515 }
- Constant [ int ast\AST_CLASS_CONST ] { 516 }
- Constant [ int ast\AST_ASSIGN ] { 517 }
- Constant [ int ast\AST_ASSIGN_REF ] { 518 }
- Constant [ int ast\AST_ASSIGN_OP ] { 519 }
- Constant [ int ast\AST_BINARY_OP ] { 520 }
- Constant [ int ast\AST_ARRAY_ELEM ] { 525 }
- Constant [ int ast\AST_NEW ] { 526 }
- Constant [ int ast\AST_INSTANCEOF ] { 527 }
- Constant [ int ast\AST_YIELD ] { 528 }
- Constant [ int ast\AST_STATIC ] { 531 }
- Constant [ int ast\AST_WHILE ] { 532 }
- Constant [ int ast\AST_DO_WHILE ] { 533 }
- Constant [ int ast\AST_IF_ELEM ] { 534 }
- Constant [ int ast\AST_SWITCH ] { 535 }
- Constant [ int ast\AST_SWITCH_CASE ] { 536 }
- Constant [ int ast\AST_DECLARE ] { 537 }
- Constant [ int ast\AST_PROP_ELEM ] { 774 }
- Constant [ int ast\AST_PROP_GROUP ] { 545 }
- Constant [ int ast\AST_CONST_ELEM ] { 775 }
- Constant [ int ast\AST_USE_TRAIT ] { 538 }
- Constant [ int ast\AST_TRAIT_PRECEDENCE ] { 539 }
- Constant [ int ast\AST_METHOD_REFERENCE ] { 540 }
- Constant [ int ast\AST_NAMESPACE ] { 541 }
- Constant [ int ast\AST_USE_ELEM ] { 542 }
- Constant [ int ast\AST_TRAIT_ALIAS ] { 543 }
- Constant [ int ast\AST_GROUP_USE ] { 544 }
- Constant [ int ast\AST_ATTRIBUTE ] { 765 }
- Constant [ int ast\AST_MATCH ] { 764 }
- Constant [ int ast\AST_MATCH_ARM ] { 763 }
- Constant [ int ast\AST_NAMED_ARG ] { 762 }
+ Constant [ int ast\AST_NULLSAFE_PROP ] { 514 }
+ Constant [ int ast\AST_STATIC_PROP ] { 515 }
+ Constant [ int ast\AST_CALL ] { 516 }
+ Constant [ int ast\AST_CLASS_CONST ] { 517 }
+ Constant [ int ast\AST_ASSIGN ] { 518 }
+ Constant [ int ast\AST_ASSIGN_REF ] { 519 }
+ Constant [ int ast\AST_ASSIGN_OP ] { 520 }
+ Constant [ int ast\AST_BINARY_OP ] { 521 }
+ Constant [ int ast\AST_ARRAY_ELEM ] { 526 }
+ Constant [ int ast\AST_NEW ] { 527 }
+ Constant [ int ast\AST_INSTANCEOF ] { 528 }
+ Constant [ int ast\AST_YIELD ] { 529 }
+ Constant [ int ast\AST_STATIC ] { 532 }
+ Constant [ int ast\AST_WHILE ] { 533 }
+ Constant [ int ast\AST_DO_WHILE ] { 534 }
+ Constant [ int ast\AST_IF_ELEM ] { 535 }
+ Constant [ int ast\AST_SWITCH ] { 536 }
+ Constant [ int ast\AST_SWITCH_CASE ] { 537 }
+ Constant [ int ast\AST_DECLARE ] { 538 }
+ Constant [ int ast\AST_PROP_ELEM ] { 775 }
+ Constant [ int ast\AST_PROP_GROUP ] { 774 }
+ Constant [ int ast\AST_CONST_ELEM ] { 776 }
+ Constant [ int ast\AST_USE_TRAIT ] { 539 }
+ Constant [ int ast\AST_TRAIT_PRECEDENCE ] { 540 }
+ Constant [ int ast\AST_METHOD_REFERENCE ] { 541 }
+ Constant [ int ast\AST_NAMESPACE ] { 542 }
+ Constant [ int ast\AST_USE_ELEM ] { 543 }
+ Constant [ int ast\AST_TRAIT_ALIAS ] { 544 }
+ Constant [ int ast\AST_GROUP_USE ] { 545 }
+ Constant [ int ast\AST_ATTRIBUTE ] { 547 }
+ Constant [ int ast\AST_MATCH ] { 548 }
+ Constant [ int ast\AST_MATCH_ARM ] { 549 }
+ Constant [ int ast\AST_NAMED_ARG ] { 550 }
Constant [ int ast\AST_METHOD_CALL ] { 768 }
- Constant [ int ast\AST_NULLSAFE_METHOD_CALL ] { 1023 }
- Constant [ int ast\AST_STATIC_CALL ] { 769 }
- Constant [ int ast\AST_CONDITIONAL ] { 770 }
- Constant [ int ast\AST_TRY ] { 771 }
- Constant [ int ast\AST_CATCH ] { 772 }
+ Constant [ int ast\AST_NULLSAFE_METHOD_CALL ] { 769 }
+ Constant [ int ast\AST_STATIC_CALL ] { 770 }
+ Constant [ int ast\AST_CONDITIONAL ] { 771 }
+ Constant [ int ast\AST_TRY ] { 772 }
+ Constant [ int ast\AST_CATCH ] { 773 }
Constant [ int ast\AST_FOR ] { 1024 }
Constant [ int ast\AST_FOREACH ] { 1025 }
Constant [ int ast\AST_ENUM_CASE ] { 1022 }
- Constant [ int ast\AST_PARAM ] { 773 }
+ Constant [ int ast\AST_PARAM ] { 1280 }
Constant [ int ast\flags\NAME_FQ ] { 0 }
Constant [ int ast\flags\NAME_NOT_FQ ] { 1 }
Constant [ int ast\flags\NAME_RELATIVE ] { 2 }
@@ -119,9 +119,9 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Constant [ int ast\flags\MODIFIER_ABSTRACT ] { 64 }
Constant [ int ast\flags\MODIFIER_FINAL ] { 32 }
Constant [ int ast\flags\MODIFIER_READONLY ] { 128 }
- Constant [ int ast\flags\PARAM_MODIFIER_PUBLIC ] { 4 }
- Constant [ int ast\flags\PARAM_MODIFIER_PROTECTED ] { 8 }
- Constant [ int ast\flags\PARAM_MODIFIER_PRIVATE ] { 16 }
+ Constant [ int ast\flags\PARAM_MODIFIER_PUBLIC ] { 1 }
+ Constant [ int ast\flags\PARAM_MODIFIER_PROTECTED ] { 2 }
+ Constant [ int ast\flags\PARAM_MODIFIER_PRIVATE ] { 4 }
Constant [ int ast\flags\RETURNS_REF ] { 4096 }
Constant [ int ast\flags\FUNC_RETURNS_REF ] { 4096 }
Constant [ int ast\flags\FUNC_GENERATOR ] { 16777216 }
@@ -133,21 +133,21 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Constant [ int ast\flags\CLASS_INTERFACE ] { 1 }
Constant [ int ast\flags\CLASS_ANONYMOUS ] { 4 }
Constant [ int ast\flags\CLASS_ENUM ] { 4194304 }
- Constant [ int ast\flags\PARAM_REF ] { 1 }
- Constant [ int ast\flags\PARAM_VARIADIC ] { 2 }
+ Constant [ int ast\flags\PARAM_REF ] { 8 }
+ Constant [ int ast\flags\PARAM_VARIADIC ] { 16 }
Constant [ int ast\flags\TYPE_NULL ] { 1 }
Constant [ int ast\flags\TYPE_FALSE ] { 2 }
- Constant [ int ast\flags\TYPE_BOOL ] { 16 }
+ Constant [ int ast\flags\TYPE_BOOL ] { 17 }
Constant [ int ast\flags\TYPE_LONG ] { 4 }
Constant [ int ast\flags\TYPE_DOUBLE ] { 5 }
Constant [ int ast\flags\TYPE_STRING ] { 6 }
Constant [ int ast\flags\TYPE_ARRAY ] { 7 }
Constant [ int ast\flags\TYPE_OBJECT ] { 8 }
- Constant [ int ast\flags\TYPE_CALLABLE ] { 17 }
- Constant [ int ast\flags\TYPE_VOID ] { 19 }
- Constant [ int ast\flags\TYPE_ITERABLE ] { 18 }
- Constant [ int ast\flags\TYPE_STATIC ] { 20 }
- Constant [ int ast\flags\TYPE_MIXED ] { 21 }
+ Constant [ int ast\flags\TYPE_CALLABLE ] { 12 }
+ Constant [ int ast\flags\TYPE_VOID ] { 14 }
+ Constant [ int ast\flags\TYPE_ITERABLE ] { 13 }
+ Constant [ int ast\flags\TYPE_STATIC ] { 15 }
+ Constant [ int ast\flags\TYPE_MIXED ] { 16 }
Constant [ int ast\flags\TYPE_NEVER ] { 22 }
Constant [ int ast\flags\UNARY_BOOL_NOT ] { 14 }
Constant [ int ast\flags\UNARY_BITWISE_NOT ] { 13 }
@@ -187,14 +187,14 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Constant [ int ast\flags\USE_NORMAL ] { 1 }
Constant [ int ast\flags\USE_FUNCTION ] { 2 }
Constant [ int ast\flags\USE_CONST ] { 4 }
- Constant [ int ast\flags\MAGIC_LINE ] { 373 }
- Constant [ int ast\flags\MAGIC_FILE ] { 374 }
- Constant [ int ast\flags\MAGIC_DIR ] { 375 }
- Constant [ int ast\flags\MAGIC_NAMESPACE ] { 392 }
- Constant [ int ast\flags\MAGIC_FUNCTION ] { 379 }
- Constant [ int ast\flags\MAGIC_METHOD ] { 378 }
- Constant [ int ast\flags\MAGIC_CLASS ] { 376 }
- Constant [ int ast\flags\MAGIC_TRAIT ] { 377 }
+ Constant [ int ast\flags\MAGIC_LINE ] { 375 }
+ Constant [ int ast\flags\MAGIC_FILE ] { 376 }
+ Constant [ int ast\flags\MAGIC_DIR ] { 377 }
+ Constant [ int ast\flags\MAGIC_NAMESPACE ] { 382 }
+ Constant [ int ast\flags\MAGIC_FUNCTION ] { 381 }
+ Constant [ int ast\flags\MAGIC_METHOD ] { 380 }
+ Constant [ int ast\flags\MAGIC_CLASS ] { 378 }
+ Constant [ int ast\flags\MAGIC_TRAIT ] { 379 }
Constant [ int ast\flags\ARRAY_SYNTAX_LIST ] { 1 }
Constant [ int ast\flags\ARRAY_SYNTAX_LONG ] { 2 }
Constant [ int ast\flags\ARRAY_SYNTAX_SHORT ] { 3 }
@@ -208,7 +208,7 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
- Parameters [3] {
Parameter #0 [ <required> string $code ]
Parameter #1 [ <required> int $version ]
- Parameter #2 [ <optional> string $filename ]
+ Parameter #2 [ <optional> string $filename = 'string code' ]
}
- Return [ ast\Node ]
}
@@ -243,7 +243,7 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
Function [ <internal:ast> function ast\get_supported_versions ] {
- Parameters [1] {
- Parameter #0 [ <optional> bool $exclude_deprecated ]
+ Parameter #0 [ <optional> bool $exclude_deprecated = false ]
}
- Return [ array ]
}
@@ -262,20 +262,20 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
}
- Properties [4] {
- Property [ <default> public $kind ]
- Property [ <default> public $flags ]
- Property [ <default> public $lineno ]
- Property [ <default> public $children ]
+ Property [ public $kind = NULL ]
+ Property [ public $flags = NULL ]
+ Property [ public $lineno = NULL ]
+ Property [ public $children = NULL ]
}
- Methods [1] {
Method [ <internal:ast, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <optional> int or NULL $kind ]
- Parameter #1 [ <optional> int or NULL $flags ]
- Parameter #2 [ <optional> array or NULL $children ]
- Parameter #3 [ <optional> int or NULL $lineno ]
+ Parameter #0 [ <optional> ?int $kind = null ]
+ Parameter #1 [ <optional> ?int $flags = null ]
+ Parameter #2 [ <optional> ?array $children = null ]
+ Parameter #3 [ <optional> ?int $lineno = null ]
}
}
}
@@ -293,10 +293,10 @@ Extension [ <persistent> extension #67 ast version 1.0.14 ] {
}
- Properties [4] {
- Property [ <default> public $kind ]
- Property [ <default> public $name ]
- Property [ <default> public $flags ]
- Property [ <default> public $flagsCombinable ]
+ Property [ public $kind = NULL ]
+ Property [ public $name = NULL ]
+ Property [ public $flags = NULL ]
+ Property [ public $flagsCombinable = NULL ]
}
- Methods [0] {
diff --git a/php-ast.spec b/php-ast.spec
index f7a1990..9684129 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -21,11 +21,11 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.0.14
+Version: 1.0.16
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: BSD
URL: https://pecl.php.net/package/ast
@@ -169,9 +169,8 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=tokenizer.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -183,9 +182,8 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=tokenizer.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -224,6 +222,9 @@ fi
%changelog
+* Sun Nov 28 2021 Remi Collet <remi@remirepo.net> - 1.0.16-1
+- update to 1.0.16
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.14-2
- rebuild for 8.1.0RC1