summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-13 10:04:41 +0200
committerRemi Collet <remi@remirepo.net>2020-07-13 10:04:41 +0200
commit53c92f26b7a26e43c3b1d148a2ebdaa8f7db6fcd (patch)
treea4fd55db0993b0f01c02191d45535a6ce8a17718
parent124b2d81df0aca9ee453b0a133d581d5fbfd9258 (diff)
v1.0.7
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION13
-rw-r--r--php-ast.spec7
3 files changed, 17 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 4c46777..5dd8733 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.0.6
-AST version => Current version is 70. All versions (including experimental): {50, 60, 70}
+extension version => 1.0.7
+AST version => Current version is 70. All versions (including experimental): {50, 60, 70, 80}
diff --git a/REFLECTION b/REFLECTION
index 78c3a3b..0916af0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #71 ast version 1.0.6 ] {
+Extension [ <persistent> extension #71 ast version 1.0.7 ] {
- - Constants [179] {
+ - Constants [186] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
Constant [ int ast\AST_LIST ] { 255 }
Constant [ int ast\AST_ARRAY ] { 129 }
@@ -19,6 +19,8 @@ Extension [ <persistent> extension #71 ast version 1.0.6 ] {
Constant [ int ast\AST_TRAIT_ADAPTATIONS ] { 142 }
Constant [ int ast\AST_USE ] { 143 }
Constant [ int ast\AST_TYPE_UNION ] { 254 }
+ Constant [ int ast\AST_ATTRIBUTE_LIST ] { 253 }
+ Constant [ int ast\AST_MATCH_ARM_LIST ] { 252 }
Constant [ int ast\AST_NAME ] { 2048 }
Constant [ int ast\AST_CLOSURE_VAR ] { 2049 }
Constant [ int ast\AST_NULLABLE_TYPE ] { 2050 }
@@ -58,6 +60,7 @@ Extension [ <persistent> extension #71 ast version 1.0.6 ] {
Constant [ int ast\AST_BREAK ] { 285 }
Constant [ int ast\AST_CONTINUE ] { 286 }
Constant [ int ast\AST_CLASS_NAME ] { 511 }
+ Constant [ int ast\AST_CLASS_CONST_GROUP ] { 766 }
Constant [ int ast\AST_DIM ] { 512 }
Constant [ int ast\AST_PROP ] { 513 }
Constant [ int ast\AST_STATIC_PROP ] { 514 }
@@ -88,14 +91,17 @@ Extension [ <persistent> extension #71 ast version 1.0.6 ] {
Constant [ int ast\AST_USE_ELEM ] { 541 }
Constant [ int ast\AST_TRAIT_ALIAS ] { 542 }
Constant [ int ast\AST_GROUP_USE ] { 543 }
+ Constant [ int ast\AST_ATTRIBUTE ] { 765 }
+ Constant [ int ast\AST_MATCH ] { 764 }
+ Constant [ int ast\AST_MATCH_ARM ] { 763 }
Constant [ int ast\AST_METHOD_CALL ] { 768 }
Constant [ int ast\AST_STATIC_CALL ] { 769 }
Constant [ int ast\AST_CONDITIONAL ] { 770 }
Constant [ int ast\AST_TRY ] { 771 }
Constant [ int ast\AST_CATCH ] { 772 }
- Constant [ int ast\AST_PARAM ] { 773 }
Constant [ int ast\AST_FOR ] { 1024 }
Constant [ int ast\AST_FOREACH ] { 1025 }
+ Constant [ int ast\AST_PARAM ] { 773 }
Constant [ int ast\flags\NAME_FQ ] { 0 }
Constant [ int ast\flags\NAME_NOT_FQ ] { 1 }
Constant [ int ast\flags\NAME_RELATIVE ] { 2 }
@@ -129,6 +135,7 @@ Extension [ <persistent> extension #71 ast version 1.0.6 ] {
Constant [ int ast\flags\TYPE_VOID ] { 19 }
Constant [ int ast\flags\TYPE_ITERABLE ] { 18 }
Constant [ int ast\flags\TYPE_STATIC ] { 20 }
+ Constant [ int ast\flags\TYPE_MIXED ] { 21 }
Constant [ int ast\flags\UNARY_BOOL_NOT ] { 13 }
Constant [ int ast\flags\UNARY_BITWISE_NOT ] { 12 }
Constant [ int ast\flags\UNARY_SILENCE ] { 260 }
diff --git a/php-ast.spec b/php-ast.spec
index 6604885..20ec01b 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -20,7 +20,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.0.6
+Version: 1.0.7
%if 0%{?gh_date:1}
Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -54,7 +54,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
%if "%{php_version}" > "7.2"
Obsoletes: php72u-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
@@ -232,6 +232,9 @@ fi
%changelog
+* Sun Jul 12 2020 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- update to 1.0.7
+
* Sun Feb 23 2020 Remi Collet <remi@remirepo.net> - 1.0.6-1
- update to 1.0.6