summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-23 08:19:09 +0100
committerRemi Collet <remi@remirepo.net>2020-02-23 08:19:09 +0100
commit124b2d81df0aca9ee453b0a133d581d5fbfd9258 (patch)
tree6237253ca5335f650b4833750ef9d102dc88bbba
parentd4ebab12e1f9f92d3ea255a87e0ff41e7164e40a (diff)
v1.0.6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION5
-rw-r--r--php-ast.spec13
3 files changed, 9 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index 63d245a..4c46777 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.0.5
+extension version => 1.0.6
AST version => Current version is 70. All versions (including experimental): {50, 60, 70}
diff --git a/REFLECTION b/REFLECTION
index 87500f6..78c3a3b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #76 ast version 1.0.5 ] {
+Extension [ <persistent> extension #71 ast version 1.0.6 ] {
- - Constants [178] {
+ - Constants [179] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
Constant [ int ast\AST_LIST ] { 255 }
Constant [ int ast\AST_ARRAY ] { 129 }
@@ -128,6 +128,7 @@ Extension [ <persistent> extension #76 ast version 1.0.5 ] {
Constant [ int ast\flags\TYPE_CALLABLE ] { 17 }
Constant [ int ast\flags\TYPE_VOID ] { 19 }
Constant [ int ast\flags\TYPE_ITERABLE ] { 18 }
+ Constant [ int ast\flags\TYPE_STATIC ] { 20 }
Constant [ int ast\flags\UNARY_BOOL_NOT ] { 13 }
Constant [ int ast\flags\UNARY_BITWISE_NOT ] { 12 }
Constant [ int ast\flags\UNARY_SILENCE ] { 260 }
diff --git a/php-ast.spec b/php-ast.spec
index 20719ec..6604885 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-ast
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,7 +20,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.0.5
+Version: 1.0.6
%if 0%{?gh_date:1}
Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -55,12 +55,6 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-%{pecl_name} <= %{version}
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
@@ -238,6 +232,9 @@ fi
%changelog
+* Sun Feb 23 2020 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6
+
* Wed Nov 27 2019 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5