summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-22 07:26:06 +0200
committerRemi Collet <remi@remirepo.net>2018-10-22 07:26:06 +0200
commit4984645821e41486d26f10533fe40ea3ecc9dc1e (patch)
treed6a3cef40cfd377705bddd74368d133e6213abd7
parentfee377c117272471ad980f57bb9512f664b6260d (diff)
v1.0.0
-rw-r--r--REFLECTION60
-rw-r--r--php-ast.spec5
2 files changed, 7 insertions, 58 deletions
diff --git a/REFLECTION b/REFLECTION
index 38bd048..50825ba 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #74 ast version 0.1.7 ] {
+Extension [ <persistent> extension #73 ast version 1.0.0 ] {
- - Constants [191] {
+ - Constants [171] {
Constant [ integer ast\AST_ARG_LIST ] { 128 }
Constant [ integer ast\AST_LIST ] { 255 }
Constant [ integer ast\AST_ARRAY ] { 129 }
@@ -30,12 +30,9 @@ Extension [ <persistent> extension #74 ast version 0.1.7 ] {
Constant [ integer ast\AST_VAR ] { 256 }
Constant [ integer ast\AST_CONST ] { 257 }
Constant [ integer ast\AST_UNPACK ] { 258 }
- Constant [ integer ast\AST_UNARY_PLUS ] { 259 }
- Constant [ integer ast\AST_UNARY_MINUS ] { 260 }
Constant [ integer ast\AST_CAST ] { 261 }
Constant [ integer ast\AST_EMPTY ] { 262 }
Constant [ integer ast\AST_ISSET ] { 263 }
- Constant [ integer ast\AST_SILENCE ] { 264 }
Constant [ integer ast\AST_SHELL_EXEC ] { 265 }
Constant [ integer ast\AST_CLONE ] { 266 }
Constant [ integer ast\AST_EXIT ] { 267 }
@@ -67,15 +64,10 @@ Extension [ <persistent> extension #74 ast version 0.1.7 ] {
Constant [ integer ast\AST_ASSIGN_REF ] { 518 }
Constant [ integer ast\AST_ASSIGN_OP ] { 519 }
Constant [ integer ast\AST_BINARY_OP ] { 520 }
- Constant [ integer ast\AST_GREATER ] { 521 }
- Constant [ integer ast\AST_GREATER_EQUAL ] { 522 }
- Constant [ integer ast\AST_AND ] { 523 }
- Constant [ integer ast\AST_OR ] { 524 }
Constant [ integer ast\AST_ARRAY_ELEM ] { 525 }
Constant [ integer ast\AST_NEW ] { 526 }
Constant [ integer ast\AST_INSTANCEOF ] { 527 }
Constant [ integer ast\AST_YIELD ] { 528 }
- Constant [ integer ast\AST_COALESCE ] { 529 }
Constant [ integer ast\AST_STATIC ] { 530 }
Constant [ integer ast\AST_WHILE ] { 531 }
Constant [ integer ast\AST_DO_WHILE ] { 532 }
@@ -161,18 +153,6 @@ Extension [ <persistent> extension #74 ast version 0.1.7 ] {
Constant [ integer ast\flags\BINARY_IS_GREATER_OR_EQUAL ] { 257 }
Constant [ integer ast\flags\BINARY_SPACESHIP ] { 170 }
Constant [ integer ast\flags\BINARY_COALESCE ] { 260 }
- Constant [ integer ast\flags\ASSIGN_BITWISE_OR ] { 31 }
- Constant [ integer ast\flags\ASSIGN_BITWISE_AND ] { 32 }
- Constant [ integer ast\flags\ASSIGN_BITWISE_XOR ] { 33 }
- Constant [ integer ast\flags\ASSIGN_CONCAT ] { 30 }
- Constant [ integer ast\flags\ASSIGN_ADD ] { 23 }
- Constant [ integer ast\flags\ASSIGN_SUB ] { 24 }
- Constant [ integer ast\flags\ASSIGN_MUL ] { 25 }
- Constant [ integer ast\flags\ASSIGN_DIV ] { 26 }
- Constant [ integer ast\flags\ASSIGN_MOD ] { 27 }
- Constant [ integer ast\flags\ASSIGN_POW ] { 167 }
- Constant [ integer ast\flags\ASSIGN_SHIFT_LEFT ] { 28 }
- Constant [ integer ast\flags\ASSIGN_SHIFT_RIGHT ] { 29 }
Constant [ integer ast\flags\EXEC_EVAL ] { 1 }
Constant [ integer ast\flags\EXEC_INCLUDE ] { 2 }
Constant [ integer ast\flags\EXEC_INCLUDE_ONCE ] { 4 }
@@ -235,7 +215,7 @@ Extension [ <persistent> extension #74 ast version 0.1.7 ] {
}
}
- - Classes [3] {
+ - Classes [2] {
Class [ <internal:ast> class ast\Node ] {
- Constants [0] {
@@ -267,40 +247,6 @@ Extension [ <persistent> extension #74 ast version 0.1.7 ] {
}
}
- Class [ <internal:ast> class ast\Node\Decl extends ast\Node ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [7] {
- Property [ <default> public $kind ]
- Property [ <default> public $flags ]
- Property [ <default> public $lineno ]
- Property [ <default> public $children ]
- Property [ <default> public $endLineno ]
- Property [ <default> public $name ]
- Property [ <default> public $docComment ]
- }
-
- - Methods [1] {
- Method [ <internal:ast, inherits ast\Node, ctor> public method __construct ] {
-
- - Parameters [4] {
- Parameter #0 [ <optional> $kind ]
- Parameter #1 [ <optional> $flags ]
- Parameter #2 [ <optional> array or NULL $children ]
- Parameter #3 [ <optional> $lineno ]
- }
- }
- }
- }
-
Class [ <internal:ast> class ast\Metadata ] {
- Constants [0] {
diff --git a/php-ast.spec b/php-ast.spec
index a7f6303..b09dee4 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -20,7 +20,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 0.1.7
+Version: 1.0.0
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -217,6 +217,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Oct 22 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+
* Sun Oct 7 2018 Remi Collet <remi@remirepo.net> - 0.1.7-1
- update to 0.1.7