summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-07 07:28:06 +0200
committerRemi Collet <remi@remirepo.net>2018-10-07 07:28:06 +0200
commitfee377c117272471ad980f57bb9512f664b6260d (patch)
treecd3e6000367279b661b3b7adc070ba28dafe1b9a
parent62bb66f21e9c340f7a4fd657e77e1271d77347b4 (diff)
v0.1.7
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION53
-rw-r--r--php-ast.spec11
3 files changed, 36 insertions, 32 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..155ddb9
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+ast
+
+ast support => enabled
diff --git a/REFLECTION b/REFLECTION
index 119516a..38bd048 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,23 +1,23 @@
-Extension [ <persistent> extension #75 ast version 0.1.6 ] {
+Extension [ <persistent> extension #74 ast version 0.1.7 ] {
- - Constants [190] {
+ - Constants [191] {
Constant [ integer ast\AST_ARG_LIST ] { 128 }
- Constant [ integer ast\AST_LIST ] { 129 }
- Constant [ integer ast\AST_ARRAY ] { 130 }
- Constant [ integer ast\AST_ENCAPS_LIST ] { 131 }
- Constant [ integer ast\AST_EXPR_LIST ] { 132 }
- Constant [ integer ast\AST_STMT_LIST ] { 133 }
- Constant [ integer ast\AST_IF ] { 134 }
- Constant [ integer ast\AST_SWITCH_LIST ] { 135 }
- Constant [ integer ast\AST_CATCH_LIST ] { 136 }
- Constant [ integer ast\AST_PARAM_LIST ] { 137 }
- Constant [ integer ast\AST_CLOSURE_USES ] { 138 }
- Constant [ integer ast\AST_PROP_DECL ] { 139 }
- Constant [ integer ast\AST_CONST_DECL ] { 140 }
- Constant [ integer ast\AST_CLASS_CONST_DECL ] { 141 }
- Constant [ integer ast\AST_NAME_LIST ] { 142 }
- Constant [ integer ast\AST_TRAIT_ADAPTATIONS ] { 143 }
- Constant [ integer ast\AST_USE ] { 144 }
+ Constant [ integer ast\AST_LIST ] { 255 }
+ Constant [ integer ast\AST_ARRAY ] { 129 }
+ Constant [ integer ast\AST_ENCAPS_LIST ] { 130 }
+ Constant [ integer ast\AST_EXPR_LIST ] { 131 }
+ Constant [ integer ast\AST_STMT_LIST ] { 132 }
+ Constant [ integer ast\AST_IF ] { 133 }
+ Constant [ integer ast\AST_SWITCH_LIST ] { 134 }
+ Constant [ integer ast\AST_CATCH_LIST ] { 135 }
+ Constant [ integer ast\AST_PARAM_LIST ] { 136 }
+ Constant [ integer ast\AST_CLOSURE_USES ] { 137 }
+ Constant [ integer ast\AST_PROP_DECL ] { 138 }
+ Constant [ integer ast\AST_CONST_DECL ] { 139 }
+ Constant [ integer ast\AST_CLASS_CONST_DECL ] { 140 }
+ Constant [ integer ast\AST_NAME_LIST ] { 141 }
+ Constant [ integer ast\AST_TRAIT_ADAPTATIONS ] { 142 }
+ Constant [ integer ast\AST_USE ] { 143 }
Constant [ integer ast\AST_NAME ] { 2048 }
Constant [ integer ast\AST_CLOSURE_VAR ] { 2049 }
Constant [ integer ast\AST_NULLABLE_TYPE ] { 2050 }
@@ -84,14 +84,14 @@ Extension [ <persistent> extension #75 ast version 0.1.6 ] {
Constant [ integer ast\AST_SWITCH_CASE ] { 535 }
Constant [ integer ast\AST_DECLARE ] { 536 }
Constant [ integer ast\AST_PROP_ELEM ] { 774 }
- Constant [ integer ast\AST_CONST_ELEM ] { 537 }
- Constant [ integer ast\AST_USE_TRAIT ] { 538 }
- Constant [ integer ast\AST_TRAIT_PRECEDENCE ] { 539 }
- Constant [ integer ast\AST_METHOD_REFERENCE ] { 540 }
- Constant [ integer ast\AST_NAMESPACE ] { 541 }
- Constant [ integer ast\AST_USE_ELEM ] { 542 }
- Constant [ integer ast\AST_TRAIT_ALIAS ] { 543 }
- Constant [ integer ast\AST_GROUP_USE ] { 544 }
+ Constant [ integer ast\AST_CONST_ELEM ] { 775 }
+ Constant [ integer ast\AST_USE_TRAIT ] { 537 }
+ Constant [ integer ast\AST_TRAIT_PRECEDENCE ] { 538 }
+ Constant [ integer ast\AST_METHOD_REFERENCE ] { 539 }
+ Constant [ integer ast\AST_NAMESPACE ] { 540 }
+ Constant [ integer ast\AST_USE_ELEM ] { 541 }
+ Constant [ integer ast\AST_TRAIT_ALIAS ] { 542 }
+ Constant [ integer ast\AST_GROUP_USE ] { 543 }
Constant [ integer ast\AST_METHOD_CALL ] { 768 }
Constant [ integer ast\AST_STATIC_CALL ] { 769 }
Constant [ integer ast\AST_CONDITIONAL ] { 770 }
@@ -112,6 +112,7 @@ Extension [ <persistent> extension #75 ast version 0.1.6 ] {
Constant [ integer ast\flags\RETURNS_REF ] { 67108864 }
Constant [ integer ast\flags\FUNC_RETURNS_REF ] { 67108864 }
Constant [ integer ast\flags\FUNC_GENERATOR ] { 8388608 }
+ Constant [ integer ast\flags\ARRAY_ELEM_REF ] { 1 }
Constant [ integer ast\flags\CLOSURE_USE_REF ] { 1 }
Constant [ integer ast\flags\CLASS_ABSTRACT ] { 32 }
Constant [ integer ast\flags\CLASS_FINAL ] { 4 }
diff --git a/php-ast.spec b/php-ast.spec
index 69d2420..a7f6303 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -20,11 +20,11 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 0.1.6
+Version: 0.1.7
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: BSD
Group: Development/Languages
@@ -173,10 +173,6 @@ done
%check
-%if "%{php_version}" > "7.3"
-rm ?TS/tests/type_hints.phpt
-%endif
-
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -221,6 +217,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Sun Oct 7 2018 Remi Collet <remi@remirepo.net> - 0.1.7-1
+- update to 0.1.7
+
* Tue Aug 21 2018 Remi Collet <remi@remirepo.net> - 0.1.6-4
- ignore 1 failed test with 7.3