summaryrefslogtreecommitdiffstats
path: root/php-Faker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-Faker.spec')
-rw-r--r--php-Faker.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-Faker.spec b/php-Faker.spec
index 9837e87..d71f8f4 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-Faker
#
-# Copyright (c) 2012-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner fzaninotto
%global github_name Faker
-%global github_version 1.9.0
-%global github_commit 27a216cbe72327b2d6369fab721a5843be71e57d
+%global github_version 1.9.2
+%global github_commit 848d8125239d7dbf8ab25cb7f054f1a630e68c2e
%global composer_vendor fzaninotto
%global composer_project faker
@@ -39,6 +39,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# For PHP 8, not submitted upstream as dead project
+Patch0: %{name}-php8.patch
+
# remirepo:3
# For test build on all available arch
#global debug_package %%{nil}
@@ -108,13 +111,7 @@ Optional:
%prep
%setup -qn %{github_name}-%{github_commit}
-
-%if 0%{?el6}
-# For old PHPUnit
-for test in $(find test -name \*Test.php); do
- sed -e '/assertNotFalse/s/);/, false);/;s/assertNotFalse/assertNotSame/' -i $test
-done
-%endif
+%patch0 -p1 -b .php8
: Create autoloader
cat <<'AUTOLOAD' | tee src/Faker/autoload.php
@@ -158,7 +155,7 @@ sed 's/function testFixedSeedWithMaximumTimestamp/function SKIP_testFixedSeedWit
-i test/Faker/Provider/DateTimeTest.php
ret=0
-for cmd in php php70 php71 php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit --verbose || ret=1
fi
@@ -178,6 +175,10 @@ exit $ret
%changelog
+* Fri Mar 26 2021 Remi Collet <remi@remirepo.net> - 1.9.2-1
+- update to 1.9.2
+- add minimal test for PHP 8
+
* Sun Nov 17 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.9.0-1
- Update to 1.9.0 (RHBZ #1772493)