summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-Faker-php8.patch51
-rw-r--r--php-Faker.spec23
3 files changed, 64 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 2fd657b..acf673e 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.9"
+ "dev-master": "1.9-dev"
}
},
"config": {
diff --git a/php-Faker-php8.patch b/php-Faker-php8.patch
new file mode 100644
index 0000000..7c591a0
--- /dev/null
+++ b/php-Faker-php8.patch
@@ -0,0 +1,51 @@
+From c351d8ff9cf1962b1f16d4d4a148722411c86956 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 26 Mar 2021 15:48:03 +0100
+Subject: [PATCH 1/2] fix Deprecated: Required parameter $isInFuture follows
+ optional parameter $interval
+
+---
+ test/Faker/Provider/DateTimeTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/Faker/Provider/DateTimeTest.php b/test/Faker/Provider/DateTimeTest.php
+index 30386f3c..da72984e 100644
+--- a/test/Faker/Provider/DateTimeTest.php
++++ b/test/Faker/Provider/DateTimeTest.php
+@@ -209,7 +209,7 @@ final class DateTimeTest extends TestCase
+ *
+ * @dataProvider providerDateTimeInInterval
+ */
+- public function testDateTimeInInterval($start, $interval = "+5 days", $isInFuture)
++ public function testDateTimeInInterval($start, $interval, $isInFuture)
+ {
+ $date = DateTimeProvider::dateTimeInInterval($start, $interval);
+ $this->assertInstanceOf('\DateTime', $date);
+--
+2.30.2
+
+From e9b8e6e9304333d8d578b06766c4d36b82a04428 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 26 Mar 2021 15:49:50 +0100
+Subject: [PATCH 2/2] fix tests expectation
+
+---
+ test/Faker/Provider/TextTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/Faker/Provider/TextTest.php b/test/Faker/Provider/TextTest.php
+index b817b6d4..aa7bd2da 100644
+--- a/test/Faker/Provider/TextTest.php
++++ b/test/Faker/Provider/TextTest.php
+@@ -37,7 +37,7 @@ final class TextTest extends TestCase
+ */
+ public function testTextMaxLength($length)
+ {
+- $this->assertLessThan($length, $this->generator->realText($length));
++ $this->assertLessThan($length, strlen($this->generator->realText($length)));
+ }
+
+ public function testTextMaxIndex()
+--
+2.30.2
+
diff --git a/php-Faker.spec b/php-Faker.spec
index 9837e87..d71f8f4 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-Faker
#
-# Copyright (c) 2012-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner fzaninotto
%global github_name Faker
-%global github_version 1.9.0
-%global github_commit 27a216cbe72327b2d6369fab721a5843be71e57d
+%global github_version 1.9.2
+%global github_commit 848d8125239d7dbf8ab25cb7f054f1a630e68c2e
%global composer_vendor fzaninotto
%global composer_project faker
@@ -39,6 +39,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# For PHP 8, not submitted upstream as dead project
+Patch0: %{name}-php8.patch
+
# remirepo:3
# For test build on all available arch
#global debug_package %%{nil}
@@ -108,13 +111,7 @@ Optional:
%prep
%setup -qn %{github_name}-%{github_commit}
-
-%if 0%{?el6}
-# For old PHPUnit
-for test in $(find test -name \*Test.php); do
- sed -e '/assertNotFalse/s/);/, false);/;s/assertNotFalse/assertNotSame/' -i $test
-done
-%endif
+%patch0 -p1 -b .php8
: Create autoloader
cat <<'AUTOLOAD' | tee src/Faker/autoload.php
@@ -158,7 +155,7 @@ sed 's/function testFixedSeedWithMaximumTimestamp/function SKIP_testFixedSeedWit
-i test/Faker/Provider/DateTimeTest.php
ret=0
-for cmd in php php70 php71 php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit --verbose || ret=1
fi
@@ -178,6 +175,10 @@ exit $ret
%changelog
+* Fri Mar 26 2021 Remi Collet <remi@remirepo.net> - 1.9.2-1
+- update to 1.9.2
+- add minimal test for PHP 8
+
* Sun Nov 17 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.9.0-1
- Update to 1.9.0 (RHBZ #1772493)