summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-28 15:25:55 +0200
committerRemi Collet <remi@remirepo.net>2019-06-28 15:25:55 +0200
commitec3e518185c5abfbaf0ee5ba0eea057c1c5f9201 (patch)
tree003d262673b3cd50d3d45f820facf594b9b50d5f
parentab54d02c3c96e3261d16b17cd2b2788c7089ebf8 (diff)
- update to 1.0.13HEADmaster
- use PHPUnit 6
-rw-r--r--composer.json5
-rw-r--r--php-Analog.spec26
2 files changed, 22 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 0e8beee..2acbbd9 100644
--- a/composer.json
+++ b/composer.json
@@ -13,9 +13,12 @@
}
],
"require": {
- "psr/log": "1.*",
+ "psr/log": "1.*",
"php": ">=5.3.2"
},
+ "require-dev": {
+ "phpunit/phpunit": "^4.8.36 || ^5.7 || ^6.5"
+ },
"autoload": {
"psr-0": {
"Analog": "lib/"
diff --git a/php-Analog.spec b/php-Analog.spec
index daf8ee6..1bd20c1 100644
--- a/php-Analog.spec
+++ b/php-Analog.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global commit 65dce6b5aff8c77307c783e607c04a35df8259d6
+%global commit 718ac1dad4577a15cadadab01b79d1923f5a9c6d
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global real_name Analog
%global minus_name analog
@@ -16,21 +16,26 @@
Name: php-Analog
Summary: PHP micro logging package
-Version: 1.0.10
+Version: 1.0.13
%if %{devver}
-Release: 9.git%{shortcommit}%{?dist}
+Release: 1git%{shortcommit}%{?dist}
%else
Release: 1%{?dist}
%endif
Source0: https://github.com/jbroadway/%{real_name}/archive/%{commit}/%{minus_name}-%{version}-%{shortcommit}.tar.gz
URL: https://github.com/jbroadway/analog
License: MIT
-Group: Development/Libraries
BuildArch: noarch
BuildRequires: php-composer(fedora/autoloader)
# For tests
-BuildRequires: %{_bindir}/phpunit
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: %{phpunit}
+%endif
BuildRequires: php-composer(psr/log)
# from composer.json, "require": {
@@ -123,9 +128,10 @@ EOF
: Upstream test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -142,6 +148,10 @@ exit $ret
%changelog
+* Fri Jun 28 2019 Remi Collet <remi@remirepo.net> - 1.0.13-1
+- update to 1.0.13
+- use PHPUnit 6
+
* Tue Nov 14 2017 Remi Collet <remi@remirepo.net> - 1.0.10-1
- update to 1.0.10