summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-14 14:53:40 +0100
committerRemi Collet <remi@remirepo.net>2017-11-14 14:53:40 +0100
commitab54d02c3c96e3261d16b17cd2b2788c7089ebf8 (patch)
treee95b1a4c3ac1d9bef9f9cecaee51113bd538a93f
parentc797dee38c13b0f9902274119d648f9e9634fc1b (diff)
v1.0.10
-rw-r--r--.gitignore8
-rw-r--r--composer.json2
-rw-r--r--php-Analog.spec36
3 files changed, 27 insertions, 19 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 36ebe48..0e8beee 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,7 @@
{
"name": "analog/analog",
"type": "library",
- "description": "PHP 5.3+ micro logging class that can be extended via closures. Includes several pre-built handlers including file, mail, syslog, HTTP post, and MongoDB.",
+ "description": "PHP logging class that can be extended via closures. Includes several pre-built handlers including file, mail, syslog, HTTP post, and MongoDB.",
"keywords": ["log", "logging", "logger", "syslog", "error", "debug", "debugging", "alerts"],
"homepage": "https://github.com/jbroadway/analog",
"license": "MIT",
diff --git a/php-Analog.spec b/php-Analog.spec
index f6d8582..daf8ee6 100644
--- a/php-Analog.spec
+++ b/php-Analog.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global commit 9e02358735912ed203c073d192b5e07cb6b663dd
+%global commit 65dce6b5aff8c77307c783e607c04a35df8259d6
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global real_name Analog
%global minus_name analog
@@ -16,18 +16,17 @@
Name: php-Analog
Summary: PHP micro logging package
-Version: 1.0.9
+Version: 1.0.10
%if %{devver}
Release: 9.git%{shortcommit}%{?dist}
%else
-Release: 3%{?dist}
+Release: 1%{?dist}
%endif
Source0: https://github.com/jbroadway/%{real_name}/archive/%{commit}/%{minus_name}-%{version}-%{shortcommit}.tar.gz
URL: https://github.com/jbroadway/analog
License: MIT
Group: Development/Libraries
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(fedora/autoloader)
# For tests
@@ -71,13 +70,16 @@ with examples for each in the examples folder. These include:
- Ignore - Do nothing
- LevelBuffer - Buffer messages and send only if sufficient error
level reached
+- LevelName - Convert log level numbers to names in log output
- Mail - Send email notices
-- Mongo - Save to MongoDB collection, requires php-pecl(mongo)
+- Mongo - Save to MongoDB collection, requires php-pecl-mongodb
package to be installed
- Multi - Send different log levels to different handlers
- Post - Send messages over HTTP POST to another machine
+- Slackbot - Post messages to Slack via Slackbot
- Stderr - Send messages to STDERR
- Syslog - Send messages to syslog
+- Threshold - Only writes log messages above a certain threshold
- Variable - Buffer messages to a variable reference.
So while it's a micro class, it's highly extensible and very capable
@@ -113,28 +115,23 @@ cp -a lib/%{real_name} %{buildroot}%{_datadir}/php/
%check
-: Relax 1 test
-sed -e 's/0600/%%d/' -i tests/AnalogTest.php
-
: Use and test our autoloader
cat <<EOF | tee tests/bootstrap.php
<?php
require '%{buildroot}%{_datadir}/php/%{real_name}/autoload.php';
EOF
-: Upstream test suite
-%{_bindir}/phpunit --include-path=%{buildroot}%{_datadir}/php
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{_datadir}/php
-fi
-
-%clean
-rm -rf %{buildroot}
+: Upstream test suite
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md
@@ -145,6 +142,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Nov 14 2017 Remi Collet <remi@remirepo.net> - 1.0.10-1
+- update to 1.0.10
+
* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 1.0.9-2
- update to 1.0.9
- switch to fedora/autoloader