summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-11 16:11:23 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-11 16:11:23 +0200
commit002eee2a226099e5c8c2f5130b049bd8e4c5091e (patch)
treea6baeb956517cae201a326cd93515c0875af2a7a
parent4cb760a3ce770ed4a627716de3b12dfca868d612 (diff)
php-pecl-yp: 1.0.0 (stable)
-rw-r--r--REFLECTION45
-rw-r--r--php-pecl-yp.spec16
2 files changed, 56 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..2299fd5
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,45 @@
+Extension [ <persistent> extension #150 yp version 1.0.0 ] {
+
+ - Constants [16] {
+ Constant [ integer YPERR_ACCESS ] { 15 }
+ Constant [ integer YPERR_BADARGS ] { 1 }
+ Constant [ integer YPERR_BADDB ] { 13 }
+ Constant [ integer YPERR_BUSY ] { 16 }
+ Constant [ integer YPERR_DOMAIN ] { 3 }
+ Constant [ integer YPERR_KEY ] { 5 }
+ Constant [ integer YPERR_MAP ] { 4 }
+ Constant [ integer YPERR_NODOM ] { 12 }
+ Constant [ integer YPERR_NOMORE ] { 8 }
+ Constant [ integer YPERR_PMAP ] { 9 }
+ Constant [ integer YPERR_RESRC ] { 7 }
+ Constant [ integer YPERR_RPC ] { 2 }
+ Constant [ integer YPERR_YPBIND ] { 10 }
+ Constant [ integer YPERR_YPERR ] { 6 }
+ Constant [ integer YPERR_YPSERV ] { 11 }
+ Constant [ integer YPERR_VERS ] { 14 }
+ }
+
+ - Functions {
+ Function [ <internal:yp> function yp_get_default_domain ] {
+ }
+ Function [ <internal:yp> function yp_order ] {
+ }
+ Function [ <internal:yp> function yp_master ] {
+ }
+ Function [ <internal:yp> function yp_match ] {
+ }
+ Function [ <internal:yp> function yp_first ] {
+ }
+ Function [ <internal:yp> function yp_next ] {
+ }
+ Function [ <internal:yp> function yp_all ] {
+ }
+ Function [ <internal:yp> function yp_cat ] {
+ }
+ Function [ <internal:yp> function yp_errno ] {
+ }
+ Function [ <internal:yp> function yp_err_string ] {
+ }
+ }
+}
+
diff --git a/php-pecl-yp.spec b/php-pecl-yp.spec
index 7e10814..496e731 100644
--- a/php-pecl-yp.spec
+++ b/php-pecl-yp.spec
@@ -13,7 +13,6 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yp
-%global prever RC1
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -23,7 +22,7 @@
Summary: YP/NIS functions
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.3.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -43,16 +42,17 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{!?scl:1}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
-%if "%{php_version}" > "5.4"
Obsoletes: php53-pecl-%{pecl_name}
Obsoletes: php53u-pecl-%{pecl_name}
Obsoletes: php54-pecl-%{pecl_name}
-%endif
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -72,6 +72,9 @@ of important administrative files (e.g. the password file).
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
+# Fix version
+sed -e '/PHP_YP_VERSION/s/1.0.0RC1/%{version}/' -i php_yp.h
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YP_VERSION/{s/.* "//;s/".*$//;p}' php_yp.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -181,6 +184,9 @@ rm -rf %{buildroot}
%changelog
+* Sun May 11 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- update to 1.0.0 (stable)
+
* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3.RC1
- add numerical prefix to extension configuration file (php 5.6)