summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit4cb760a3ce770ed4a627716de3b12dfca868d612 (patch)
tree7ab3c645f115001e20d4081b27b6921944ae42c0
parentbcaa17cd545f7dcecbf215d995b4a6fc8a11a665 (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
-rw-r--r--php-pecl-yp.spec26
1 files changed, 17 insertions, 9 deletions
diff --git a/php-pecl-yp.spec b/php-pecl-yp.spec
index 2327665..7e10814 100644
--- a/php-pecl-yp.spec
+++ b/php-pecl-yp.spec
@@ -11,14 +11,19 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
-%global pecl_name yp
-%global prever RC1
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name yp
+%global prever RC1
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: YP/NIS functions
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -81,7 +86,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; Enable '%{summary}' extension module
extension=%{pecl_name}.so
EOF
@@ -110,7 +115,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -119,7 +124,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -166,16 +171,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3.RC1
+- add numerical prefix to extension configuration file (php 5.6)
+
* Sat Feb 22 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.2.RC1
- Fix License