summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-13 12:15:51 +0200
committerRemi Collet <remi@remirepo.net>2020-10-13 12:15:51 +0200
commit7dd4d82a76b2c3ea7ed6975bba009b86b83dcfdf (patch)
treebd33336160ede671fba9c464d8fe84247e33124d /php-pecl-xdebug3.spec
parentd23c908bcc470f17a3960841a64aa3cdfae1c4fc (diff)
update to 3.0.0-dev
debugclient dropped upstream raise dependency on PHP 7.2
Diffstat (limited to 'php-pecl-xdebug3.spec')
-rw-r--r--php-pecl-xdebug3.spec45
1 files changed, 24 insertions, 21 deletions
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index e4caecc..3827c96 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -19,22 +19,22 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 3e09864af111d63b7eb486d88bfc6eb7d6429b85
+%global gh_commit a5b668e29143716b73b6b649a6ab95489286d8f4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20190614
+%global gh_date 20201011
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.9.8
+%global upstream_version 3.0.0
#global upstream_prever beta2
-#global upstream_lower beta2
+%global upstream_lower DEV
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
-Name: %{?scl_prefix}php-pecl-xdebug
+Name: %{?scl_prefix}php-pecl-xdebug3
Summary: PECL package for debugging PHP scripts
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -46,7 +46,7 @@ URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel > 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libedit-devel
@@ -67,6 +67,15 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
+%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9 || "%{php_version}" > "8.0"
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%else
+# A single version can be installed
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+%endif
+
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
@@ -184,14 +193,6 @@ cd NTS
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
-# Build debugclient
-pushd debugclient
-# buildconf required for aarch64 support
-./buildconf
-%configure --with-libedit
-make %{?_smp_mflags}
-popd
-
%if %{with_zts}
cd ../ZTS
%{_bindir}/zts-phpize
@@ -208,10 +209,6 @@ make %{?_smp_mflags}
# install NTS extension
make -C NTS install INSTALL_ROOT=%{buildroot}
-# install debugclient
-install -Dpm 755 NTS/debugclient/debugclient \
- %{buildroot}%{_bindir}/debugclient
-
# install package registration file
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -259,11 +256,13 @@ done
cd NTS
: Upstream test suite NTS extension
+sed -e '/var_display_max_data/s/2048/3075/' -i tests/develop/error_collection-003.phpt
+
# bug00886 is marked as slow as it uses a lot of disk space
TEST_OPTS="-q -x --show-diff"
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0 -d foo=yes" \
+TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-xdebug-tests.php $TEST_OPTS
%else
@@ -294,7 +293,6 @@ fi
%files
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
-%{_bindir}/debugclient
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -307,6 +305,11 @@ fi
%changelog
+* Tue Oct 13 2020 Remi Collet <remi@remirepo.net> - 3.0.0~DEV-1.20201011
+- update to 3.0.0-dev
+- debugclient dropped upstream
+- raise dependency on PHP 7.2
+
* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.9.8-1
- update to 2.9.8