summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-13 12:15:51 +0200
committerRemi Collet <remi@remirepo.net>2020-10-13 12:15:51 +0200
commit7dd4d82a76b2c3ea7ed6975bba009b86b83dcfdf (patch)
treebd33336160ede671fba9c464d8fe84247e33124d
parentd23c908bcc470f17a3960841a64aa3cdfae1c4fc (diff)
update to 3.0.0-dev
debugclient dropped upstream raise dependency on PHP 7.2
-rw-r--r--Makefile4
-rw-r--r--PHPINFO104
-rw-r--r--REFLECTION385
-rw-r--r--php-pecl-xdebug3.spec45
4 files changed, 300 insertions, 238 deletions
diff --git a/Makefile b/Makefile
index 13af741..ee211f7 100644
--- a/Makefile
+++ b/Makefile
@@ -2,3 +2,7 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+refl: $(NAME).spec
+ php -n -d zend_extension=xdebug --ri xdebug >PHPINFO
+ php -n -d zend_extension=xdebug --re xdebug >REFLECTION
+
diff --git a/PHPINFO b/PHPINFO
index facb1ef..57e3699 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,33 +1,48 @@
xdebug
-xdebug support => enabled
-Version => 2.9.8
+__ __ _ _
+\ \ / / | | | |
+ \ V / __| | ___| |__ _ _ __ _
+ > < / _` |/ _ \ '_ \| | | |/ _` |
+ / . \ (_| | __/ |_) | |_| | (_| |
+/_/ \_\__,_|\___|_.__/ \__,_|\__, |
+ __/ |
+ |___/
+
+Version => 3.0.0-dev
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
-Debugger => enabled
-IDE Key => remi
+Feature => Enabled/Disabled
+Development Aids => ✔ enabled
+Coverage => ✘ disabled
+GC Stats => ✘ disabled
+Profiler => ✘ disabled
+Step Debugger => ✘ disabled
+Tracing => ✘ disabled
Directive => Local Value => Master Value
-xdebug.coverage_enable => On => On
-xdebug.collect_includes => On => On
-xdebug.collect_params => 0 => 0
-xdebug.collect_return => Off => Off
-xdebug.collect_vars => Off => Off
-xdebug.collect_assignments => Off => Off
-xdebug.default_enable => On => On
+xdebug.mode => develop => develop
+xdebug.start_with_request => default => default
+xdebug.start_upon_error => default => default
+xdebug.output_dir => /tmp => /tmp
+xdebug.trigger_value => no value => no value
xdebug.file_link_format => no value => no value
xdebug.filename_format => no value => no value
+xdebug.log => no value => no value
+xdebug.log_level => 7 => 7
+xdebug.var_display_max_children => 128 => 128
+xdebug.var_display_max_data => 512 => 512
+xdebug.var_display_max_depth => 3 => 3
+xdebug.max_nesting_level => 256 => 256
+xdebug.cli_color => 0 => 0
xdebug.force_display_errors => Off => Off
xdebug.force_error_reporting => 0 => 0
xdebug.halt_level => 0 => 0
-xdebug.max_nesting_level => 256 => 256
xdebug.max_stack_frames => -1 => -1
-xdebug.overload_var_dump => 2 => 2
xdebug.show_error_trace => Off => Off
xdebug.show_exception_trace => Off => Off
xdebug.show_local_vars => Off => Off
-xdebug.show_mem_delta => Off => Off
xdebug.dump.COOKIE => no value => no value
xdebug.dump.ENV => no value => no value
xdebug.dump.FILES => no value => no value
@@ -39,36 +54,47 @@ xdebug.dump.SESSION => no value => no value
xdebug.dump_globals => On => On
xdebug.dump_once => On => On
xdebug.dump_undefined => Off => Off
-xdebug.profiler_enable => Off => Off
-xdebug.profiler_output_dir => /tmp => /tmp
xdebug.profiler_output_name => cachegrind.out.%p => cachegrind.out.%p
-xdebug.profiler_enable_trigger => Off => Off
-xdebug.profiler_enable_trigger_value => no value => no value
xdebug.profiler_append => Off => Off
-xdebug.remote_enable => Off => Off
-xdebug.remote_host => localhost => localhost
-xdebug.remote_mode => req => req
-xdebug.remote_port => 9000 => 9000
-xdebug.remote_autostart => Off => Off
-xdebug.remote_connect_back => Off => Off
-xdebug.remote_log => no value => no value
-xdebug.remote_log_level => 7 => 7
+xdebug.cloud_id => no value => no value
+xdebug.client_host => localhost => localhost
+xdebug.client_port => 9003 => 9003
+xdebug.discover_client_host => Off => Off
+xdebug.client_discovery_header => no value => no value
xdebug.idekey => no value => no value
-xdebug.remote_cookie_expire_time => 3600 => 3600
-xdebug.remote_addr_header => no value => no value
-xdebug.remote_timeout => 200 => 200
-xdebug.var_display_max_children => 128 => 128
-xdebug.var_display_max_data => 512 => 512
-xdebug.var_display_max_depth => 3 => 3
-xdebug.cli_color => 0 => 0
+xdebug.connect_timeout_ms => 200 => 200
xdebug.scream => Off => Off
-xdebug.gc_stats_enable => Off => Off
-xdebug.gc_stats_output_dir => /tmp => /tmp
xdebug.gc_stats_output_name => gcstats.%p => gcstats.%p
-xdebug.auto_trace => Off => Off
-xdebug.trace_enable_trigger => Off => Off
-xdebug.trace_enable_trigger_value => no value => no value
-xdebug.trace_output_dir => /tmp => /tmp
xdebug.trace_output_name => trace.%c => trace.%c
xdebug.trace_format => 0 => 0
xdebug.trace_options => 0 => 0
+xdebug.collect_assignments => Off => Off
+xdebug.collect_return => Off => Off
+xdebug.auto_trace => no value => no value
+xdebug.collect_includes => no value => no value
+xdebug.collect_params => no value => no value
+xdebug.collect_vars => no value => no value
+xdebug.coverage_enable => no value => no value
+xdebug.default_enable => no value => no value
+xdebug.extended_info => no value => no value
+xdebug.gc_stats_enable => no value => no value
+xdebug.gc_stats_output_dir => no value => no value
+xdebug.overload_var_dump => no value => no value
+xdebug.profiler_enable => no value => no value
+xdebug.profiler_enable_trigger => no value => no value
+xdebug.profiler_enable_trigger_value => no value => no value
+xdebug.profiler_output_dir => no value => no value
+xdebug.remote_autostart => no value => no value
+xdebug.remote_connect_back => no value => no value
+xdebug.remote_enable => no value => no value
+xdebug.remote_handler => no value => no value
+xdebug.remote_host => no value => no value
+xdebug.remote_log => no value => no value
+xdebug.remote_log_level => no value => no value
+xdebug.remote_mode => no value => no value
+xdebug.remote_port => no value => no value
+xdebug.remote_timeout => no value => no value
+xdebug.show_mem_delta => no value => no value
+xdebug.trace_output_dir => no value => no value
+xdebug.trace_enable_trigger => no value => no value
+xdebug.trace_enable_trigger_value => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 54a00b8..a2b3f99 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,26 +1,20 @@
-Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
+Extension [ <persistent> extension #15 xdebug version 3.0.0-dev ] {
- INI {
- Entry [ xdebug.coverage_enable <SYSTEM> ]
- Current = '1'
- }
- Entry [ xdebug.collect_includes <ALL> ]
- Current = '1'
+ Entry [ xdebug.mode <SYSTEM> ]
+ Current = 'develop'
}
- Entry [ xdebug.collect_params <ALL> ]
- Current = '0'
+ Entry [ xdebug.start_with_request <SYSTEM> ]
+ Current = 'default'
}
- Entry [ xdebug.collect_return <ALL> ]
- Current = '0'
+ Entry [ xdebug.start_upon_error <SYSTEM> ]
+ Current = 'default'
}
- Entry [ xdebug.collect_vars <ALL> ]
- Current = '0'
- }
- Entry [ xdebug.collect_assignments <ALL> ]
- Current = '0'
+ Entry [ xdebug.output_dir <ALL> ]
+ Current = '/tmp'
}
- Entry [ xdebug.default_enable <ALL> ]
- Current = '1'
+ Entry [ xdebug.trigger_value <PERDIR,SYSTEM> ]
+ Current = ''
}
Entry [ xdebug.file_link_format <ALL> ]
Current = ''
@@ -28,6 +22,27 @@ Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
Entry [ xdebug.filename_format <ALL> ]
Current = ''
}
+ Entry [ xdebug.log <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.log_level <ALL> ]
+ Current = '7'
+ }
+ Entry [ xdebug.var_display_max_children <ALL> ]
+ Current = '128'
+ }
+ Entry [ xdebug.var_display_max_data <ALL> ]
+ Current = '512'
+ }
+ Entry [ xdebug.var_display_max_depth <ALL> ]
+ Current = '3'
+ }
+ Entry [ xdebug.max_nesting_level <ALL> ]
+ Current = '256'
+ }
+ Entry [ xdebug.cli_color <ALL> ]
+ Current = '0'
+ }
Entry [ xdebug.force_display_errors <SYSTEM> ]
Current = '0'
}
@@ -37,15 +52,9 @@ Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
Entry [ xdebug.halt_level <ALL> ]
Current = '0'
}
- Entry [ xdebug.max_nesting_level <ALL> ]
- Current = '256'
- }
Entry [ xdebug.max_stack_frames <ALL> ]
Current = '-1'
}
- Entry [ xdebug.overload_var_dump <ALL> ]
- Current = '2'
- }
Entry [ xdebug.show_error_trace <ALL> ]
Current = '0'
}
@@ -55,9 +64,6 @@ Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
Entry [ xdebug.show_local_vars <ALL> ]
Current = '0'
}
- Entry [ xdebug.show_mem_delta <ALL> ]
- Current = '0'
- }
Entry [ xdebug.dump.COOKIE <ALL> ]
Current = ''
}
@@ -91,359 +97,382 @@ Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
Entry [ xdebug.dump_undefined <ALL> ]
Current = '0'
}
- Entry [ xdebug.profiler_enable <PERDIR,SYSTEM> ]
- Current = '0'
- }
- Entry [ xdebug.profiler_output_dir <PERDIR,SYSTEM> ]
- Current = '/tmp'
- }
Entry [ xdebug.profiler_output_name <PERDIR,SYSTEM> ]
Current = 'cachegrind.out.%p'
}
- Entry [ xdebug.profiler_enable_trigger <PERDIR,SYSTEM> ]
+ Entry [ xdebug.profiler_append <PERDIR,SYSTEM> ]
Current = '0'
}
- Entry [ xdebug.profiler_enable_trigger_value <PERDIR,SYSTEM> ]
+ Entry [ xdebug.cloud_id <SYSTEM> ]
Current = ''
}
- Entry [ xdebug.profiler_append <PERDIR,SYSTEM> ]
+ Entry [ xdebug.client_host <ALL> ]
+ Current = 'localhost'
+ }
+ Entry [ xdebug.client_port <ALL> ]
+ Current = '9003'
+ }
+ Entry [ xdebug.discover_client_host <ALL> ]
Current = '0'
}
- Entry [ xdebug.remote_enable <PERDIR,SYSTEM> ]
+ Entry [ xdebug.client_discovery_header <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.idekey <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.connect_timeout_ms <ALL> ]
+ Current = '200'
+ }
+ Entry [ xdebug.scream <ALL> ]
Current = '0'
}
- Entry [ xdebug.remote_host <ALL> ]
- Current = 'localhost'
+ Entry [ xdebug.gc_stats_output_name <PERDIR,SYSTEM> ]
+ Current = 'gcstats.%p'
}
- Entry [ xdebug.remote_mode <ALL> ]
- Current = 'req'
+ Entry [ xdebug.trace_output_name <ALL> ]
+ Current = 'trace.%c'
}
- Entry [ xdebug.remote_port <ALL> ]
- Current = '9000'
+ Entry [ xdebug.trace_format <ALL> ]
+ Current = '0'
}
- Entry [ xdebug.remote_autostart <ALL> ]
+ Entry [ xdebug.trace_options <ALL> ]
Current = '0'
}
- Entry [ xdebug.remote_connect_back <ALL> ]
+ Entry [ xdebug.collect_assignments <ALL> ]
Current = '0'
}
- Entry [ xdebug.remote_log <ALL> ]
+ Entry [ xdebug.collect_return <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.auto_trace <SYSTEM> ]
Current = ''
}
- Entry [ xdebug.remote_log_level <ALL> ]
- Current = '7'
+ Entry [ xdebug.collect_includes <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.idekey <ALL> ]
+ Entry [ xdebug.collect_params <SYSTEM> ]
Current = ''
}
- Entry [ xdebug.remote_cookie_expire_time <ALL> ]
- Current = '3600'
+ Entry [ xdebug.collect_vars <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.remote_addr_header <ALL> ]
+ Entry [ xdebug.coverage_enable <SYSTEM> ]
Current = ''
}
- Entry [ xdebug.remote_timeout <ALL> ]
- Current = '200'
+ Entry [ xdebug.default_enable <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.var_display_max_children <ALL> ]
- Current = '128'
+ Entry [ xdebug.extended_info <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.var_display_max_data <ALL> ]
- Current = '512'
+ Entry [ xdebug.gc_stats_enable <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.var_display_max_depth <ALL> ]
- Current = '3'
+ Entry [ xdebug.gc_stats_output_dir <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.cli_color <ALL> ]
- Current = '0'
+ Entry [ xdebug.overload_var_dump <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.scream <ALL> ]
- Current = '0'
+ Entry [ xdebug.profiler_enable <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.gc_stats_enable <PERDIR,SYSTEM> ]
- Current = '0'
+ Entry [ xdebug.profiler_enable_trigger <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.gc_stats_output_dir <PERDIR,SYSTEM> ]
- Current = '/tmp'
+ Entry [ xdebug.profiler_enable_trigger_value <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.gc_stats_output_name <PERDIR,SYSTEM> ]
- Current = 'gcstats.%p'
+ Entry [ xdebug.profiler_output_dir <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.auto_trace <ALL> ]
- Current = '0'
+ Entry [ xdebug.remote_autostart <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.trace_enable_trigger <PERDIR,SYSTEM> ]
- Current = '0'
+ Entry [ xdebug.remote_connect_back <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.trace_enable_trigger_value <PERDIR,SYSTEM> ]
+ Entry [ xdebug.remote_enable <SYSTEM> ]
Current = ''
}
- Entry [ xdebug.trace_output_dir <ALL> ]
- Current = '/tmp'
+ Entry [ xdebug.remote_handler <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.trace_output_name <ALL> ]
- Current = 'trace.%c'
+ Entry [ xdebug.remote_host <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.trace_format <ALL> ]
- Current = '0'
+ Entry [ xdebug.remote_log <SYSTEM> ]
+ Current = ''
}
- Entry [ xdebug.trace_options <ALL> ]
- Current = '0'
+ Entry [ xdebug.remote_log_level <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_mode <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_port <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_timeout <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.show_mem_delta <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.trace_output_dir <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.trace_enable_trigger <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.trace_enable_trigger_value <SYSTEM> ]
+ Current = ''
}
}
- - Constants [15] {
+ - Constants [8] {
Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
- Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
- Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
- Constant [ int XDEBUG_TRACE_HTML ] { 4 }
- Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
- Constant [ int XDEBUG_CC_UNUSED ] { 1 }
- Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
- Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
Constant [ int XDEBUG_FILTER_NONE ] { 0 }
- Constant [ int XDEBUG_PATH_WHITELIST ] { 1 }
- Constant [ int XDEBUG_PATH_BLACKLIST ] { 2 }
- Constant [ int XDEBUG_NAMESPACE_WHITELIST ] { 17 }
- Constant [ int XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
+ Constant [ int XDEBUG_PATH_INCLUDE ] { 1 }
+ Constant [ int XDEBUG_PATH_EXCLUDE ] { 2 }
+ Constant [ int XDEBUG_NAMESPACE_INCLUDE ] { 17 }
+ Constant [ int XDEBUG_NAMESPACE_EXCLUDE ] { 18 }
}
- Functions {
- Function [ <internal:xdebug> function xdebug_get_stack_depth ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:xdebug> function xdebug_get_function_stack ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:xdebug> function xdebug_get_formatted_function_stack ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:xdebug> function xdebug_print_function_stack ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $options ]
- }
- }
- Function [ <internal:xdebug> function xdebug_get_declared_vars ] {
+ Function [ <internal:xdebug> function xdebug_break ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Function [ <internal:xdebug> function xdebug_call_class ] {
- Parameters [1] {
- Parameter #0 [ <optional> $depth ]
+ Parameter #0 [ <optional> int $depth ]
}
}
- Function [ <internal:xdebug> function xdebug_call_function ] {
+ Function [ <internal:xdebug> function xdebug_call_file ] {
- Parameters [1] {
- Parameter #0 [ <optional> $depth ]
+ Parameter #0 [ <optional> int $depth ]
}
}
- Function [ <internal:xdebug> function xdebug_call_file ] {
+ Function [ <internal:xdebug> function xdebug_call_function ] {
- Parameters [1] {
- Parameter #0 [ <optional> $depth ]
+ Parameter #0 [ <optional> int $depth ]
}
}
Function [ <internal:xdebug> function xdebug_call_line ] {
- Parameters [1] {
- Parameter #0 [ <optional> $depth ]
+ Parameter #0 [ <optional> int $depth ]
}
}
- Function [ <internal:xdebug> function xdebug_var_dump ] {
+ Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
- - Parameters [1] {
- Parameter #0 [ <required> $var ]
+ - Parameters [0] {
}
+ - Return [ bool ]
}
Function [ <internal:xdebug> function xdebug_debug_zval ] {
- Parameters [1] {
- Parameter #0 [ <required> $var ]
+ Parameter #0 [ <optional> string ...$varname ]
}
}
Function [ <internal:xdebug> function xdebug_debug_zval_stdout ] {
- Parameters [1] {
- Parameter #0 [ <required> $var ]
+ Parameter #0 [ <optional> string ...$varname ]
}
}
- Function [ <internal:xdebug> function xdebug_enable ] {
+ Function [ <internal:xdebug> function xdebug_dump_superglobals ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_disable ] {
+ Function [ <internal:xdebug> function xdebug_get_code_coverage ] {
- Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:xdebug> function xdebug_is_enabled ] {
+ Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> bool $emptyList ]
}
+ - Return [ array ]
}
- Function [ <internal:xdebug> function xdebug_is_debugger_active ] {
+ Function [ <internal:xdebug> function xdebug_get_function_count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_break ] {
+ Function [ <internal:xdebug> function xdebug_get_function_stack ] {
- Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:xdebug> function xdebug_start_trace ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $fname ]
- Parameter #1 [ <optional> $options ]
- }
- }
- Function [ <internal:xdebug> function xdebug_stop_trace ] {
+ Function [ <internal:xdebug> function xdebug_get_gc_run_count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_get_tracefile_name ] {
+ Function [ <internal:xdebug> function xdebug_get_gc_total_collected_roots ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_get_profiler_filename ] {
+ Function [ <internal:xdebug> function xdebug_get_gcstats_filename ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_start_gcstats ] {
+ Function [ <internal:xdebug> function xdebug_get_headers ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $fname ]
+ - Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:xdebug> function xdebug_stop_gcstats ] {
+ Function [ <internal:xdebug> function xdebug_get_monitored_functions ] {
- Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:xdebug> function xdebug_get_gcstats_filename ] {
+ Function [ <internal:xdebug> function xdebug_get_profiler_filename ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_get_gc_run_count ] {
+ Function [ <internal:xdebug> function xdebug_get_stack_depth ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_get_gc_total_collected_roots ] {
+ Function [ <internal:xdebug> function xdebug_get_tracefile_name ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_memory_usage ] {
+ Function [ <internal:xdebug> function xdebug_info ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_peak_memory_usage ] {
+ Function [ <internal:xdebug> function xdebug_is_debugger_active ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Function [ <internal:xdebug> function xdebug_time_index ] {
+ Function [ <internal:xdebug> function xdebug_memory_usage ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_start_error_collection ] {
+ Function [ <internal:xdebug> function xdebug_peak_memory_usage ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:xdebug> function xdebug_stop_error_collection ] {
+ Function [ <internal:xdebug> function xdebug_print_function_stack ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <optional> string $message ]
+ Parameter #1 [ <optional> int $options ]
}
}
- Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
+ Function [ <internal:xdebug> function xdebug_set_filter ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $clear ]
+ - Parameters [3] {
+ Parameter #0 [ <required> int $group ]
+ Parameter #1 [ <required> int $listType ]
+ Parameter #2 [ <required> array $configuration ]
}
}
- Function [ <internal:xdebug> function xdebug_start_function_monitor ] {
+ Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
- Parameters [1] {
- Parameter #0 [ <required> $functions_to_monitor ]
+ Parameter #0 [ <optional> int $options ]
}
}
- Function [ <internal:xdebug> function xdebug_stop_function_monitor ] {
+ Function [ <internal:xdebug> function xdebug_start_error_collection ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_get_monitored_functions ] {
+ Function [ <internal:xdebug> function xdebug_start_function_monitor ] {
- Parameters [1] {
- Parameter #0 [ <optional> $clear ]
+ Parameter #0 [ <required> array $listOfFunctionsToMonitor ]
}
}
- Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
+ Function [ <internal:xdebug> function xdebug_start_gcstats ] {
- Parameters [1] {
- Parameter #0 [ <optional> $options ]
+ Parameter #0 [ <optional> string or NULL $gcstatsFile ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_trace ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> string or NULL $traceFile ]
+ Parameter #1 [ <optional> int $options ]
}
+ - Return [ string ]
}
Function [ <internal:xdebug> function xdebug_stop_code_coverage ] {
- Parameters [1] {
- Parameter #0 [ <optional> $cleanup ]
+ Parameter #0 [ <optional> bool $cleanUp ]
}
}
- Function [ <internal:xdebug> function xdebug_get_code_coverage ] {
+ Function [ <internal:xdebug> function xdebug_stop_error_collection ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
+ Function [ <internal:xdebug> function xdebug_stop_function_monitor ] {
- Parameters [0] {
}
}
- Function [ <internal:xdebug> function xdebug_get_function_count ] {
+ Function [ <internal:xdebug> function xdebug_stop_gcstats ] {
- Parameters [0] {
}
+ - Return [ string ]
}
- Function [ <internal:xdebug> function xdebug_dump_superglobals ] {
+ Function [ <internal:xdebug> function xdebug_stop_trace ] {
- Parameters [0] {
}
+ - Return [ string ]
}
- Function [ <internal:xdebug> function xdebug_get_headers ] {
+ Function [ <internal:xdebug> function xdebug_time_index ] {
- Parameters [0] {
}
+ - Return [ float ]
}
- Function [ <internal:xdebug> function xdebug_set_filter ] {
+ Function [ <internal:xdebug> function xdebug_var_dump ] {
- - Parameters [3] {
- Parameter #0 [ <required> $filter_group ]
- Parameter #1 [ <required> $filter_type ]
- Parameter #2 [ <required> $array_of_filters ]
+ - Parameters [1] {
+ Parameter #0 [ <optional> ...$variable ]
}
}
}
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index e4caecc..3827c96 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -19,22 +19,22 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 3e09864af111d63b7eb486d88bfc6eb7d6429b85
+%global gh_commit a5b668e29143716b73b6b649a6ab95489286d8f4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20190614
+%global gh_date 20201011
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.9.8
+%global upstream_version 3.0.0
#global upstream_prever beta2
-#global upstream_lower beta2
+%global upstream_lower DEV
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
-Name: %{?scl_prefix}php-pecl-xdebug
+Name: %{?scl_prefix}php-pecl-xdebug3
Summary: PECL package for debugging PHP scripts
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -46,7 +46,7 @@ URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel > 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libedit-devel
@@ -67,6 +67,15 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
+%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9 || "%{php_version}" > "8.0"
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%else
+# A single version can be installed
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+%endif
+
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
@@ -184,14 +193,6 @@ cd NTS
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
-# Build debugclient
-pushd debugclient
-# buildconf required for aarch64 support
-./buildconf
-%configure --with-libedit
-make %{?_smp_mflags}
-popd
-
%if %{with_zts}
cd ../ZTS
%{_bindir}/zts-phpize
@@ -208,10 +209,6 @@ make %{?_smp_mflags}
# install NTS extension
make -C NTS install INSTALL_ROOT=%{buildroot}
-# install debugclient
-install -Dpm 755 NTS/debugclient/debugclient \
- %{buildroot}%{_bindir}/debugclient
-
# install package registration file
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -259,11 +256,13 @@ done
cd NTS
: Upstream test suite NTS extension
+sed -e '/var_display_max_data/s/2048/3075/' -i tests/develop/error_collection-003.phpt
+
# bug00886 is marked as slow as it uses a lot of disk space
TEST_OPTS="-q -x --show-diff"
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0 -d foo=yes" \
+TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-xdebug-tests.php $TEST_OPTS
%else
@@ -294,7 +293,6 @@ fi
%files
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
-%{_bindir}/debugclient
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -307,6 +305,11 @@ fi
%changelog
+* Tue Oct 13 2020 Remi Collet <remi@remirepo.net> - 3.0.0~DEV-1.20201011
+- update to 3.0.0-dev
+- debugclient dropped upstream
+- raise dependency on PHP 7.2
+
* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.9.8-1
- update to 2.9.8