summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-13 14:47:00 +0200
committerRemi Collet <remi@remirepo.net>2019-06-13 14:47:00 +0200
commit03aa2d69800f3bfec6b0f03975ef367e4c547ac2 (patch)
treee16e9ba3c17b0f6c99f3cc80bd342df46d73302c /php-pecl-xdebug.spec
parentc16275abd90d56c803a205bd822d00d40a96485a (diff)
update to 2.8.0-dev for PHP 7.4
Diffstat (limited to 'php-pecl-xdebug.spec')
-rw-r--r--php-pecl-xdebug.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index cbfb55f..58585dd 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,24 +19,24 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit e4de4be71911ba933e4f9240dbcc3f45af53c6da
+%global gh_commit 4ae1efe757e42f2e1f27ab643de497ed0d1a4b92
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20171202
+%global gh_date 20190613
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.7.2
-#global upstream_prever RC2
-#global upstream_lower rc2
+%global upstream_version 2.8.0
+#global upstream_prever dev
+%global upstream_lower DEV
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
+Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 2%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -45,6 +45,8 @@ License: BSD
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+Patch0: https://patch-diff.githubusercontent.com/raw/xdebug/xdebug/pull/480.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -132,7 +134,7 @@ mv %{pecl_name}-%{gh_commit} NTS
%{__php} -r '
$pkg = simplexml_load_file("NTS/package.xml");
$pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
- $pkg->version->release = "%{version}dev";
+ $pkg->version->release = "%{upstream_version}dev";
$pkg->stability->release = "devel";
$pkg->asXML("package.xml");
'
@@ -143,6 +145,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -300,6 +304,9 @@ fi
%changelog
+* Thu Jun 13 2019 Remi Collet <remi@remirepo.net> - 2.8.0~DEV-1.20190613.4ae1efe
+- update to 2.8.0-dev for PHP 7.4
+
* Wed May 29 2019 Remi Collet <remi@remirepo.net> - 2.7.2-2
- rebuild