summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--480.patch92
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION38
-rw-r--r--php-pecl-xdebug.spec25
4 files changed, 129 insertions, 30 deletions
diff --git a/480.patch b/480.patch
new file mode 100644
index 0000000..e7edfb6
--- /dev/null
+++ b/480.patch
@@ -0,0 +1,92 @@
+From 7cc30505aa9dea878526b3bc9cb9ffd6e2db1354 Mon Sep 17 00:00:00 2001
+From: Derick Rethans <github@derickrethans.nl>
+Date: Wed, 12 Jun 2019 19:57:49 +0100
+Subject: [PATCH 1/2] Remove overload for removed
+ ZEND_DECLARE_INHERITED_CLASS_DELAYED opcode
+
+---
+ xdebug.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/xdebug.c b/xdebug.c
+index d3d2621dc..544e162a5 100644
+--- a/xdebug.c
++++ b/xdebug.c
+@@ -854,7 +854,6 @@ PHP_MINIT_FUNCTION(xdebug)
+ #endif
+ #if PHP_VERSION_ID >= 70400
+ XDEBUG_SET_OPCODE_OVERRIDE_COMMON(ZEND_DECLARE_CLASS);
+- XDEBUG_SET_OPCODE_OVERRIDE_COMMON(ZEND_DECLARE_INHERITED_CLASS_DELAYED);
+ #endif
+ #if PHP_VERSION_ID >= 70200
+ zend_set_user_opcode_handler(ZEND_SWITCH_STRING, xdebug_switch_handler);
+@@ -1038,7 +1037,6 @@ PHP_MSHUTDOWN_FUNCTION(xdebug)
+ #endif
+ #if PHP_VERSION_ID >= 70400
+ zend_set_user_opcode_handler(ZEND_DECLARE_CLASS, NULL);
+- zend_set_user_opcode_handler(ZEND_DECLARE_INHERITED_CLASS_DELAYED, NULL);
+ #endif
+ #ifndef ZTS
+ }
+
+From c84ba23a50b1c9a4929a6ce9416280173d7f3662 Mon Sep 17 00:00:00 2001
+From: Derick Rethans <github@derickrethans.nl>
+Date: Thu, 13 Jun 2019 00:15:58 +0100
+Subject: [PATCH 2/2] Fixed latest resolved breakpoints test
+
+---
+ tests/bug01388-19.phpt | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/tests/bug01388-19.phpt b/tests/bug01388-19.phpt
+index 7cd4c35b8..785889387 100644
+--- a/tests/bug01388-19.phpt
++++ b/tests/bug01388-19.phpt
+@@ -13,10 +13,10 @@ $filename = dirname(__FILE__) . '/bug01388-19.inc';
+ $commands = array(
+ 'feature_set -n resolved_breakpoints -v 1',
+ 'step_into',
+- "breakpoint_set -t line -f file://{{$filename} -n 2",
+- "breakpoint_set -t line -f file://{{$filename} -n 4",
+- "breakpoint_set -t line -f file://{{$filename} -n 8",
+- "breakpoint_set -t line -f file://{{$filename} -n 9",
++ "breakpoint_set -t line -f file://{$filename} -n 2",
++ "breakpoint_set -t line -f file://{$filename} -n 4",
++ "breakpoint_set -t line -f file://{$filename} -n 8",
++ "breakpoint_set -t line -f file://{$filename} -n 9",
+ 'run',
+ 'run',
+ 'run',
+@@ -38,28 +38,28 @@ dbgpRunFile( $filename, $commands );
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="2" status="break" reason="ok"><xdebug:message filename="file://bug01388-19.inc" lineno="2"></xdebug:message></response>
+
+--> breakpoint_set -i 3 -t line -f /home/derick/dev/php/derickr-xdebug/tests/bug01388-19.inc -n 2
++-> breakpoint_set -i 3 -t line -f file://bug01388-19.inc -n 2
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <notify xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" name="breakpoint_resolved"><breakpoint type="line" resolved="resolved" filename="file://bug01388-19.inc" lineno="2" state="enabled" hit_count="0" hit_value="0" id=""></breakpoint></notify>
+
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="3" id="" resolved="resolved"></response>
+
+--> breakpoint_set -i 4 -t line -f /home/derick/dev/php/derickr-xdebug/tests/bug01388-19.inc -n 4
++-> breakpoint_set -i 4 -t line -f file://bug01388-19.inc -n 4
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <notify xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" name="breakpoint_resolved"><breakpoint type="line" resolved="resolved" filename="file://bug01388-19.inc" lineno="5" state="enabled" hit_count="0" hit_value="0" id=""></breakpoint></notify>
+
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" id="" resolved="resolved"></response>
+
+--> breakpoint_set -i 5 -t line -f /home/derick/dev/php/derickr-xdebug/tests/bug01388-19.inc -n 8
++-> breakpoint_set -i 5 -t line -f file://bug01388-19.inc -n 8
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <notify xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" name="breakpoint_resolved"><breakpoint type="line" resolved="resolved" filename="file://bug01388-19.inc" lineno="8" state="enabled" hit_count="0" hit_value="0" id=""></breakpoint></notify>
+
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="5" id="" resolved="resolved"></response>
+
+--> breakpoint_set -i 6 -t line -f /home/derick/dev/php/derickr-xdebug/tests/bug01388-19.inc -n 9
++-> breakpoint_set -i 6 -t line -f file://bug01388-19.inc -n 9
+ <?xml version="1.0" encoding="iso-8859-1"?>
+ <notify xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" name="breakpoint_resolved"><breakpoint type="line" resolved="resolved" filename="file://bug01388-19.inc" lineno="9" state="enabled" hit_count="0" hit_value="0" id=""></breakpoint></notify>
+
diff --git a/PHPINFO b/PHPINFO
index 37057e4..fc24857 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.7.2
+Version => 2.8.0-dev
IDE Key => remi
Support Xdebug on Patreon: https://www.patreon.com/bePatron?u=7864328
@@ -25,7 +25,6 @@ xdebug.collect_return => Off => Off
xdebug.collect_vars => Off => Off
xdebug.collect_assignments => Off => Off
xdebug.default_enable => On => On
-xdebug.extended_info => On => On
xdebug.file_link_format => no value => no value
xdebug.filename_format => no value => no value
xdebug.force_display_errors => Off => Off
@@ -64,6 +63,7 @@ xdebug.remote_port => 9000 => 9000
xdebug.remote_autostart => Off => Off
xdebug.remote_connect_back => Off => Off
xdebug.remote_log => no value => no value
+xdebug.remote_log_level => 7 => 7
xdebug.idekey => no value => no value
xdebug.remote_cookie_expire_time => 3600 => 3600
xdebug.remote_addr_header => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 6cb29c5..16ad1f6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #204 xdebug version 2.7.2 ] {
+Extension [ <persistent> extension #97 xdebug version 2.8.0-dev ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -43,9 +43,6 @@ Extension [ <persistent> extension #204 xdebug version 2.7.2 ] {
Entry [ xdebug.default_enable <ALL> ]
Current = '1'
}
- Entry [ xdebug.extended_info <SYSTEM> ]
- Current = '1'
- }
Entry [ xdebug.file_link_format <ALL> ]
Current = ''
}
@@ -160,6 +157,9 @@ Extension [ <persistent> extension #204 xdebug version 2.7.2 ] {
Entry [ xdebug.remote_log <ALL> ]
Current = ''
}
+ Entry [ xdebug.remote_log_level <ALL> ]
+ Current = '7'
+ }
Entry [ xdebug.idekey <ALL> ]
Current = ''
}
@@ -199,21 +199,21 @@ Extension [ <persistent> extension #204 xdebug version 2.7.2 ] {
}
- Constants [15] {
- Constant [ integer XDEBUG_TRACE_APPEND ] { 1 }
- Constant [ integer XDEBUG_TRACE_COMPUTERIZED ] { 2 }
- Constant [ integer XDEBUG_TRACE_HTML ] { 4 }
- Constant [ integer XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
- Constant [ integer XDEBUG_CC_UNUSED ] { 1 }
- Constant [ integer XDEBUG_CC_DEAD_CODE ] { 2 }
- Constant [ integer XDEBUG_CC_BRANCH_CHECK ] { 4 }
- Constant [ integer XDEBUG_STACK_NO_DESC ] { 1 }
- Constant [ integer XDEBUG_FILTER_TRACING ] { 256 }
- Constant [ integer XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
- Constant [ integer XDEBUG_FILTER_NONE ] { 0 }
- Constant [ integer XDEBUG_PATH_WHITELIST ] { 1 }
- Constant [ integer XDEBUG_PATH_BLACKLIST ] { 2 }
- Constant [ integer XDEBUG_NAMESPACE_WHITELIST ] { 17 }
- Constant [ integer XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
+ Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
+ Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
+ Constant [ int XDEBUG_TRACE_HTML ] { 4 }
+ Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
+ Constant [ int XDEBUG_CC_UNUSED ] { 1 }
+ Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
+ Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
+ Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
+ Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
+ Constant [ int XDEBUG_FILTER_NONE ] { 0 }
+ Constant [ int XDEBUG_PATH_WHITELIST ] { 1 }
+ Constant [ int XDEBUG_PATH_BLACKLIST ] { 2 }
+ Constant [ int XDEBUG_NAMESPACE_WHITELIST ] { 17 }
+ Constant [ int XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
}
- Functions {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index cbfb55f..58585dd 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,24 +19,24 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit e4de4be71911ba933e4f9240dbcc3f45af53c6da
+%global gh_commit 4ae1efe757e42f2e1f27ab643de497ed0d1a4b92
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20171202
+%global gh_date 20190613
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.7.2
-#global upstream_prever RC2
-#global upstream_lower rc2
+%global upstream_version 2.8.0
+#global upstream_prever dev
+%global upstream_lower DEV
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
+Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 2%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -45,6 +45,8 @@ License: BSD
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+Patch0: https://patch-diff.githubusercontent.com/raw/xdebug/xdebug/pull/480.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -132,7 +134,7 @@ mv %{pecl_name}-%{gh_commit} NTS
%{__php} -r '
$pkg = simplexml_load_file("NTS/package.xml");
$pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
- $pkg->version->release = "%{version}dev";
+ $pkg->version->release = "%{upstream_version}dev";
$pkg->stability->release = "devel";
$pkg->asXML("package.xml");
'
@@ -143,6 +145,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -300,6 +304,9 @@ fi
%changelog
+* Thu Jun 13 2019 Remi Collet <remi@remirepo.net> - 2.8.0~DEV-1.20190613.4ae1efe
+- update to 2.8.0-dev for PHP 7.4
+
* Wed May 29 2019 Remi Collet <remi@remirepo.net> - 2.7.2-2
- rebuild