summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-13 14:57:25 +0200
committerRemi Collet <remi@remirepo.net>2019-06-13 14:57:25 +0200
commit01456b337dc78718cc323073d23daba414b6362e (patch)
tree3f91de0b83ef4f6ff3bd2247a2620e5f76f500af /php-pecl-xdebug.spec
parent03aa2d69800f3bfec6b0f03975ef367e4c547ac2 (diff)
run tests in parallel
Diffstat (limited to 'php-pecl-xdebug.spec')
-rw-r--r--php-pecl-xdebug.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 58585dd..537b4e3 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -256,13 +256,17 @@ done
%if %{with_tests}
cd NTS
: Upstream test suite NTS extension
+%if "%{php_version}" > "7.4"
+TEST_OPTS="-q --show-diff %{?_smp_mflags}"
+%else
+TEST_OPTS="-q --show-diff"
+%endif
# bug00886 is marked as slow as it uses a lot of disk space
SKIP_SLOW_TESTS=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php $TEST_OPTS
%else
: Test suite disabled
%endif