summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-24 11:48:53 +0200
committerRemi Collet <remi@remirepo.net>2019-04-24 11:48:53 +0200
commitddca36526d4f1dc4efff8147ca4f3d0e70141cdc (patch)
tree0b5fd2904612d38ff951316ab4052cbcf054a8f9
parent8b5c7e75c70d3437123093dfe1226383e62840cb (diff)
switch from v8-devel to nodejs-devel
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-v8js.spec23
3 files changed, 17 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 8223a4a..b7b280d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
v8js
V8 Javascript Engine => enabled
-V8 Engine Compiled Version => 6.2.91
-V8 Engine Linked Version => 6.2.91
+V8 Engine Compiled Version => 6.8.275.32-node.51
+V8 Engine Linked Version => 6.8.275.32-node.51
Version => 2.1.0
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 34f622f..52e6e4f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #157 v8js version 2.1.0 ] {
+Extension [ <persistent> extension #168 v8js version 2.1.0 ] {
- INI {
Entry [ v8js.flags <ALL> ]
@@ -19,7 +19,7 @@ Extension [ <persistent> extension #157 v8js version 2.1.0 ] {
Class [ <internal:v8js> class V8Js ] {
- Constants [4] {
- Constant [ public string V8_VERSION ] { 6.2.91 }
+ Constant [ public string V8_VERSION ] { 6.8.275.32-node.51 }
Constant [ public integer FLAG_NONE ] { 1 }
Constant [ public integer FLAG_FORCE_ARRAY ] { 2 }
Constant [ public integer FLAG_PROPAGATE_PHP_EXCEPTIONS ] { 4 }
diff --git a/php-pecl-v8js.spec b/php-pecl-v8js.spec
index 892069e..d747007 100644
--- a/php-pecl-v8js.spec
+++ b/php-pecl-v8js.spec
@@ -1,6 +1,6 @@
# spec file for php-pecl-v8js
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,12 +20,14 @@
Summary: V8 Javascript Engine for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.1.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: %{pecl_name}-upstream.patch
+# Use libnode instead of libv8
+Patch1: %{pecl_name}-hack.patch
# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n74
ExclusiveArch: %{ix86} x86_64 %{arm} ppc mipsel mips64el
@@ -35,7 +37,8 @@ BuildRequires: %{?scl_prefix}php-pear
# because of https://bugzilla.redhat.com/1378889
# upstream minimal 4.6.76
# upstream recommended 6.5.143
-BuildRequires: v8-devel >= 1:5.2.258-7
+BuildRequires: nodejs-devel
+BuildRequires: nodejs(v8-abi) >= 6.5
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -52,8 +55,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -94,6 +95,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
%patch0 -p1 -b .upstream
+%patch1 -p1 -b .hack
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_V8JS_VERSION/{s/.* "//;s/".*$//;p}' php_v8js_macros.h)
@@ -129,11 +131,6 @@ EOF
%build
%{?dtsenable}
-# Hack for https://bugzilla.redhat.com/show_bug.cgi?id=1517657
-ln -s %{_root_libdir}/libv8_libbase.so.? libv8_libbase.so
-ln -s %{_root_libdir}/libv8_libplatform.so.? libv8_libplatform.so
-export LDFLAGS="%{__global_ldflags} -L$PWD"
-
cd NTS
%{_bindir}/phpize
%configure \
@@ -202,6 +199,9 @@ fi
%check
+: Ignore TZ dependent tests
+rm -f ?TS/tests/timezones.phpt
+
: Minimal load test for NTS extension
cd NTS
%{_bindir}/php --no-php-ini \
@@ -246,6 +246,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 2.1.0-4
+- switch from v8-devel to nodejs-devel
+
* Thu Oct 25 2018 Remi Collet <remi@remirepo.net> - 2.1.0-3
- add upstream patches for PHP 7.3