summaryrefslogtreecommitdiffstats
path: root/php-pecl-v8js.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-v8js.spec')
-rw-r--r--php-pecl-v8js.spec23
1 files changed, 13 insertions, 10 deletions
diff --git a/php-pecl-v8js.spec b/php-pecl-v8js.spec
index 892069e..d747007 100644
--- a/php-pecl-v8js.spec
+++ b/php-pecl-v8js.spec
@@ -1,6 +1,6 @@
# spec file for php-pecl-v8js
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,12 +20,14 @@
Summary: V8 Javascript Engine for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.1.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: %{pecl_name}-upstream.patch
+# Use libnode instead of libv8
+Patch1: %{pecl_name}-hack.patch
# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n74
ExclusiveArch: %{ix86} x86_64 %{arm} ppc mipsel mips64el
@@ -35,7 +37,8 @@ BuildRequires: %{?scl_prefix}php-pear
# because of https://bugzilla.redhat.com/1378889
# upstream minimal 4.6.76
# upstream recommended 6.5.143
-BuildRequires: v8-devel >= 1:5.2.258-7
+BuildRequires: nodejs-devel
+BuildRequires: nodejs(v8-abi) >= 6.5
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -52,8 +55,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -94,6 +95,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
%patch0 -p1 -b .upstream
+%patch1 -p1 -b .hack
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_V8JS_VERSION/{s/.* "//;s/".*$//;p}' php_v8js_macros.h)
@@ -129,11 +131,6 @@ EOF
%build
%{?dtsenable}
-# Hack for https://bugzilla.redhat.com/show_bug.cgi?id=1517657
-ln -s %{_root_libdir}/libv8_libbase.so.? libv8_libbase.so
-ln -s %{_root_libdir}/libv8_libplatform.so.? libv8_libplatform.so
-export LDFLAGS="%{__global_ldflags} -L$PWD"
-
cd NTS
%{_bindir}/phpize
%configure \
@@ -202,6 +199,9 @@ fi
%check
+: Ignore TZ dependent tests
+rm -f ?TS/tests/timezones.phpt
+
: Minimal load test for NTS extension
cd NTS
%{_bindir}/php --no-php-ini \
@@ -246,6 +246,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 2.1.0-4
+- switch from v8-devel to nodejs-devel
+
* Thu Oct 25 2018 Remi Collet <remi@remirepo.net> - 2.1.0-3
- add upstream patches for PHP 7.3