summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-27 09:37:24 +0100
committerRemi Collet <remi@remirepo.net>2017-11-27 09:37:24 +0100
commit9305a3bc21ba110cc521b880cdb63ec5c7ee22de (patch)
treee9920b816094d9730fba4e06e5cc6958eb32a400
parentb0f2984c52a3d74ddcfc7f0188fb8258b02bd000 (diff)
Update to 2.0.0
add workaround for missing symlinks in v8-devel rhbz#1517657
-rw-r--r--53533cd4dd972087da705550eeb3e41485d9c5be.patch54
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-v8js.spec27
3 files changed, 23 insertions, 71 deletions
diff --git a/53533cd4dd972087da705550eeb3e41485d9c5be.patch b/53533cd4dd972087da705550eeb3e41485d9c5be.patch
deleted file mode 100644
index cb83258..0000000
--- a/53533cd4dd972087da705550eeb3e41485d9c5be.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 53533cd4dd972087da705550eeb3e41485d9c5be Mon Sep 17 00:00:00 2001
-From: Jan-E <github@ehrhardt.nl>
-Date: Tue, 13 Jun 2017 18:14:12 +0200
-Subject: [PATCH] remove ZEND_ACC_CLONE
-
----
- v8js_class.cc | 2 +-
- v8js_object_export.cc | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/v8js_class.cc b/v8js_class.cc
-index 4c27783..c424f32 100644
---- a/v8js_class.cc
-+++ b/v8js_class.cc
-@@ -537,7 +537,7 @@ static PHP_METHOD(V8Js, __construct)
- continue;
- }
-
-- if ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR|ZEND_ACC_CLONE)) != 0) {
-+ if ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR)) != 0) {
- /* no __construct, __destruct(), or __clone() functions */
- continue;
- }
-diff --git a/v8js_object_export.cc b/v8js_object_export.cc
-index 254e0ed..d733ae2 100644
---- a/v8js_object_export.cc
-+++ b/v8js_object_export.cc
-@@ -336,7 +336,7 @@ static void v8js_named_property_enumerator(const v8::PropertyCallbackInfo<v8::Ar
- /* Allow only public methods */
- continue;
- }
-- if ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR|ZEND_ACC_CLONE)) != 0) {
-+ if ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR)) != 0) {
- /* no __construct, __destruct(), or __clone() functions */
- continue;
- }
-@@ -539,7 +539,7 @@ static void v8js_fake_call_impl(const v8::FunctionCallbackInfo<v8::Value>& info)
-
- if (method_ptr == NULL ||
- (method_ptr->common.fn_flags & ZEND_ACC_PUBLIC) == 0 ||
-- (method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR|ZEND_ACC_CLONE)) != 0) {
-+ (method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR)) != 0) {
- error_len = spprintf(&error, 0,
- "%s::__call to %s method %s", ce->name,
- (method_ptr == NULL) ? "undefined" : "non-public", method_name);
-@@ -619,7 +619,7 @@ v8::Local<v8::Value> v8js_named_property_callback(v8::Local<v8::String> property
- (method_ptr = reinterpret_cast<zend_function *>
- (zend_hash_find_ptr(&ce->function_table, method_name))) &&
- ((method_ptr->common.fn_flags & ZEND_ACC_PUBLIC) != 0) && /* Allow only public methods */
-- ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR|ZEND_ACC_CLONE)) == 0) /* no __construct, __destruct(), or __clone() functions */
-+ ((method_ptr->common.fn_flags & (ZEND_ACC_CTOR|ZEND_ACC_DTOR)) == 0) /* no __construct, __destruct(), or __clone() functions */
- ) || (method_ptr=NULL, is_magic_call)
- ) {
- if (callback_type == V8JS_PROP_GETTER) {
diff --git a/REFLECTION b/REFLECTION
index c8300d4..0f0d46c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #145 v8js version 1.4.0 ] {
+Extension [ <persistent> extension #156 v8js version 2.0.0 ] {
- INI {
Entry [ v8js.flags <ALL> ]
@@ -13,9 +13,6 @@ Extension [ <persistent> extension #145 v8js version 1.4.0 ] {
Entry [ v8js.use_array_access <ALL> ]
Current = '0'
}
- Entry [ v8js.compat_php_exceptions <ALL> ]
- Current = '0'
- }
}
- Classes [8] {
@@ -32,7 +29,7 @@ Extension [ <persistent> extension #145 v8js version 1.4.0 ] {
}
- Static methods [3] {
- Method [ <internal:v8js> static public method registerExtension ] {
+ Method [ <internal, deprecated:v8js> static public method registerExtension ] {
- Parameters [4] {
Parameter #0 [ <required> $extension_name ]
@@ -42,7 +39,7 @@ Extension [ <persistent> extension #145 v8js version 1.4.0 ] {
}
}
- Method [ <internal:v8js> static public method getExtensions ] {
+ Method [ <internal, deprecated:v8js> static public method getExtensions ] {
- Parameters [0] {
}
@@ -119,13 +116,13 @@ Extension [ <persistent> extension #145 v8js version 1.4.0 ] {
}
}
- Method [ <internal:v8js> public method getPendingException ] {
+ Method [ <internal, deprecated:v8js> public method getPendingException ] {
- Parameters [0] {
}
}
- Method [ <internal:v8js> public method clearPendingException ] {
+ Method [ <internal, deprecated:v8js> public method clearPendingException ] {
- Parameters [0] {
}
diff --git a/php-pecl-v8js.spec b/php-pecl-v8js.spec
index 720feb9..0dc66ba 100644
--- a/php-pecl-v8js.spec
+++ b/php-pecl-v8js.spec
@@ -9,6 +9,8 @@
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-v8js
+%else
+%global _root_libdir %{_libdir}
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -17,18 +19,15 @@
Summary: V8 Javascript Engine for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: 53533cd4dd972087da705550eeb3e41485d9c5be.patch
-
-# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n49
-# arm is excluded because of bz1334406
-ExclusiveArch: %{ix86} x86_64 ppc ppc64 aarch64 %{mips} s390 s390x
+# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n74
+ExclusiveArch: %{ix86} x86_64 %{arm} ppc mipsel mips64el
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
# because of https://bugzilla.redhat.com/1378889
@@ -86,7 +85,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_V8JS_VERSION/{s/.* "//;s/".*$//;p}' php_v8js_macros.h)
@@ -116,13 +114,17 @@ extension=%{pecl_name}.so
;v8js.icudtl_dat_path = ''
;v8js.use_date = 0
;v8js.use_array_access = 0
-;v8js.compat_php_exceptions = 0
EOF
%build
%{?dtsenable}
+# Hack for https://bugzilla.redhat.com/show_bug.cgi?id=1517657
+ln -s %{_root_libdir}/libv8_libbase.so.? libv8_libbase.so
+ln -s %{_root_libdir}/libv8_libplatform.so.? libv8_libplatform.so
+export LDFLAGS="%{__global_ldflags} -L$PWD"
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -235,6 +237,13 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Nov 27 2017 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- Update to 2.0.0
+- add workaround for missing symlinks in v8-devel rhbz#1517657
+
+* Wed Aug 2 2017 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- Update to 1.4.1
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.4.0-3
- rebuild for PHP 7.2.0beta1 new API