summaryrefslogtreecommitdiffstats
path: root/php-pecl-v8js.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-v8js.spec')
-rw-r--r--php-pecl-v8js.spec27
1 files changed, 18 insertions, 9 deletions
diff --git a/php-pecl-v8js.spec b/php-pecl-v8js.spec
index 720feb9..0dc66ba 100644
--- a/php-pecl-v8js.spec
+++ b/php-pecl-v8js.spec
@@ -9,6 +9,8 @@
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-v8js
+%else
+%global _root_libdir %{_libdir}
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -17,18 +19,15 @@
Summary: V8 Javascript Engine for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: 53533cd4dd972087da705550eeb3e41485d9c5be.patch
-
-# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n49
-# arm is excluded because of bz1334406
-ExclusiveArch: %{ix86} x86_64 ppc ppc64 aarch64 %{mips} s390 s390x
+# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n74
+ExclusiveArch: %{ix86} x86_64 %{arm} ppc mipsel mips64el
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
# because of https://bugzilla.redhat.com/1378889
@@ -86,7 +85,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_V8JS_VERSION/{s/.* "//;s/".*$//;p}' php_v8js_macros.h)
@@ -116,13 +114,17 @@ extension=%{pecl_name}.so
;v8js.icudtl_dat_path = ''
;v8js.use_date = 0
;v8js.use_array_access = 0
-;v8js.compat_php_exceptions = 0
EOF
%build
%{?dtsenable}
+# Hack for https://bugzilla.redhat.com/show_bug.cgi?id=1517657
+ln -s %{_root_libdir}/libv8_libbase.so.? libv8_libbase.so
+ln -s %{_root_libdir}/libv8_libplatform.so.? libv8_libplatform.so
+export LDFLAGS="%{__global_ldflags} -L$PWD"
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -235,6 +237,13 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Nov 27 2017 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- Update to 2.0.0
+- add workaround for missing symlinks in v8-devel rhbz#1517657
+
+* Wed Aug 2 2017 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- Update to 1.4.1
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.4.0-3
- rebuild for PHP 7.2.0beta1 new API