summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-24 08:03:00 +0200
committerRemi Collet <remi@php.net>2022-05-24 08:03:00 +0200
commit2136fbc0059791934e61f54b9673677945cec33c (patch)
treeb7b2be5081e7f87dbe0f0bef372a79f3c493ac61
parent72ce46a3b9d56861e8bcdc1257fa90780b1e5b8c (diff)
update to 0.1.1
open https://github.com/ace411/php-trie-ext/issues/6 bad archive open https://github.com/ace411/php-trie-ext/issues/7 bad version
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION274
-rw-r--r--php-pecl-trie.spec43
3 files changed, 204 insertions, 115 deletions
diff --git a/PHPINFO b/PHPINFO
index e36335e..358308a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
php_trie
php_trie support => enabled
-php_trie version => 0.1.0
+php_trie version => 0.1.1
php_trie author => Lochemem Bruno Michael <lochbm@gmail.com>
Trie available => yes
Hat Trie available => yes
diff --git a/REFLECTION b/REFLECTION
index 3379c68..452ebc6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
+Extension [ <persistent> extension #120 php_trie version 0.1.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -6,6 +6,9 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
- Functions {
Function [ <internal:php_trie, ctor> function __construct ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:php_trie> static function fromArray ] {
@@ -16,58 +19,78 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
Function [ <internal:php_trie> function insert ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
}
+ - Return [ void ]
}
- Function [ <internal:php_trie> function keyExists ] {
+ Function [ <internal:php_trie> function search ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ mixed ]
}
- Function [ <internal:php_trie> function search ] {
+ Function [ <internal:php_trie> function size ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [0] {
}
+ - Return [ int ]
}
- Function [ <internal:php_trie> function erase ] {
+ Function [ <internal:php_trie> function toArray ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:php_trie> function size ] {
- }
- Function [ <internal:php_trie> function offsetSet ] {
+ Function [ <internal:php_trie> function jsonSerialize ] {
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ - Parameters [0] {
}
+ - Return [ mixed ]
}
- Function [ <internal:php_trie> function offsetGet ] {
+ Function [ <internal:php_trie> function keyExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
}
Function [ <internal:php_trie> function offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
}
Function [ <internal:php_trie> function offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ void ]
}
- Function [ <internal:php_trie> function toArray ] {
+ Function [ <internal:php_trie> function erase ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ void ]
}
- Function [ <internal:php_trie> function jsonSerialize ] {
+ Function [ <internal:php_trie> function offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
+ }
+ - Return [ void ]
+ }
+ Function [ <internal:php_trie> function offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ mixed ]
}
Function [ <internal:php_trie> function prefixSearch ] {
@@ -119,73 +142,96 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
- Methods [16] {
Method [ <internal:php_trie, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:php_trie> public method insert ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
}
+ - Return [ void ]
}
- Method [ <internal:php_trie> public method keyExists ] {
+ Method [ <internal:php_trie> public method search ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ mixed ]
}
- Method [ <internal:php_trie> public method search ] {
+ Method [ <internal:php_trie> public method size ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [0] {
}
+ - Return [ int ]
}
- Method [ <internal:php_trie> public method erase ] {
+ Method [ <internal:php_trie> public method toArray ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [0] {
}
+ - Return [ array ]
}
- Method [ <internal:php_trie> public method size ] {
- }
-
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetSet ] {
+ Method [ <internal:php_trie, prototype JsonSerializable> public method jsonSerialize ] {
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ - Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetGet ] {
+ Method [ <internal:php_trie> public method keyExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
}
Method [ <internal:php_trie, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
}
Method [ <internal:php_trie, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ void ]
}
- Method [ <internal:php_trie> public method toArray ] {
+ Method [ <internal:php_trie> public method erase ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ void ]
}
- Method [ <internal:php_trie, prototype JsonSerializable> public method jsonSerialize ] {
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ mixed ]
}
Method [ <internal:php_trie> public method prefixSearch ] {
@@ -265,42 +311,71 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
}
Method [ <internal:php_trie> public method size ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:php_trie> public method filter ] {
+ Method [ <internal:php_trie> public method toArray ] {
- - Parameters [1] {
- Parameter #0 [ <required> callable $func ]
+ - Parameters [0] {
}
+ - Return [ array ]
}
- Method [ <internal:php_trie> public method insert ] {
+ Method [ <internal:php_trie, prototype JsonSerializable> public method jsonSerialize ] {
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ - Parameters [0] {
}
+ - Return [ mixed ]
}
Method [ <internal:php_trie> public method keyExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
}
- Method [ <internal:php_trie> public method search ] {
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ bool ]
+ }
+
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ void ]
}
Method [ <internal:php_trie> public method erase ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
+ - Return [ void ]
+ }
+
+ Method [ <internal:php_trie> public method filter ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $func ]
+ }
+ }
+
+ Method [ <internal:php_trie> public method search ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ mixed ]
}
Method [ <internal:php_trie> public method prefixSearch ] {
@@ -331,39 +406,30 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
}
}
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetSet ] {
+ Method [ <internal:php_trie> public method insert ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $entry ]
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
}
+ - Return [ void ]
}
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetGet ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- }
-
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetExists ] {
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetSet ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $entry ]
}
+ - Return [ void ]
}
- Method [ <internal:php_trie, prototype ArrayAccess> public method offsetUnset ] {
+ Method [ <internal:php_trie, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> mixed $key ]
}
- }
-
- Method [ <internal:php_trie> public method toArray ] {
- }
-
- Method [ <internal:php_trie, prototype JsonSerializable> public method jsonSerialize ] {
+ - Return [ mixed ]
}
Method [ <internal:php_trie> public method merge ] {
@@ -376,7 +442,7 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
}
}
- Class [ <internal:php_trie> class TrieException extends RuntimeException implements Throwable ] {
+ Class [ <internal:php_trie> class TrieException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -388,47 +454,81 @@ Extension [ <persistent> extension #91 php_trie version 0.1.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-trie.spec b/php-pecl-trie.spec
index f8d43b2..b3dc79b 100644
--- a/php-pecl-trie.spec
+++ b/php-pecl-trie.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-trie
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
Summary: PHP Trie extension
Name: %{?sub_prefix}php-pecl-trie
-Version: 0.1.0
+Version: 0.1.1
Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -30,8 +30,9 @@ Source1: https://github.com/Tessil/hat-trie/archive/v%{libver}.tar.gz
# https://github.com/ace411/php-trie-ext/pull/1
Patch0: %{pecl_name}-build.patch
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -49,20 +50,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
Provides: bundled(hat-trie) = %{libver}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Trie and HAT trie data structures for PHP.
@@ -72,7 +59,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c -a 1
-mv %{pecl_name}-%{version} NTS
+# https://github.com/ace411/php-trie-ext/issues/6
+mkdir NTS
+mv LICENSE README.md changes.md common.cpp config.m4 config.w32 examples php_trie.cpp php_trie_ext.h tests trie.h NTS/
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -80,7 +69,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr1
+# https://github.com/ace411/php-trie-ext/issues/7
+sed -e s/0.1.0/0.1.1/ -i php_trie_ext.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TRIE_EXT_EXTVER/{s/.* "//;s/".*$//;p}' php_trie_ext.h)
@@ -184,11 +174,8 @@ cd NTS
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q -P --show-diff
%if %{with_zts}
@@ -199,11 +186,8 @@ cd ../ZTS
--modules | grep %{pecl_name}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q -P --show-diff
%endif
@@ -222,6 +206,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue May 24 2022 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- update to 0.1.1
+- open https://github.com/ace411/php-trie-ext/issues/6 bad archive
+- open https://github.com/ace411/php-trie-ext/issues/7 bad version
+
* Wed Sep 9 2020 Remi Collet <remi@remirepo.net> - 0.1.0-1
- initial package, version 0.1.0 (stable)
- open https://github.com/ace411/php-trie-ext/pull/1 fix build