summaryrefslogtreecommitdiffstats
path: root/php-pecl-trie.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-trie.spec')
-rw-r--r--php-pecl-trie.spec43
1 files changed, 16 insertions, 27 deletions
diff --git a/php-pecl-trie.spec b/php-pecl-trie.spec
index f8d43b2..b3dc79b 100644
--- a/php-pecl-trie.spec
+++ b/php-pecl-trie.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-trie
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
Summary: PHP Trie extension
Name: %{?sub_prefix}php-pecl-trie
-Version: 0.1.0
+Version: 0.1.1
Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -30,8 +30,9 @@ Source1: https://github.com/Tessil/hat-trie/archive/v%{libver}.tar.gz
# https://github.com/ace411/php-trie-ext/pull/1
Patch0: %{pecl_name}-build.patch
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -49,20 +50,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
Provides: bundled(hat-trie) = %{libver}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Trie and HAT trie data structures for PHP.
@@ -72,7 +59,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c -a 1
-mv %{pecl_name}-%{version} NTS
+# https://github.com/ace411/php-trie-ext/issues/6
+mkdir NTS
+mv LICENSE README.md changes.md common.cpp config.m4 config.w32 examples php_trie.cpp php_trie_ext.h tests trie.h NTS/
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -80,7 +69,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr1
+# https://github.com/ace411/php-trie-ext/issues/7
+sed -e s/0.1.0/0.1.1/ -i php_trie_ext.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TRIE_EXT_EXTVER/{s/.* "//;s/".*$//;p}' php_trie_ext.h)
@@ -184,11 +174,8 @@ cd NTS
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q -P --show-diff
%if %{with_zts}
@@ -199,11 +186,8 @@ cd ../ZTS
--modules | grep %{pecl_name}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q -P --show-diff
%endif
@@ -222,6 +206,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue May 24 2022 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- update to 0.1.1
+- open https://github.com/ace411/php-trie-ext/issues/6 bad archive
+- open https://github.com/ace411/php-trie-ext/issues/7 bad version
+
* Wed Sep 9 2020 Remi Collet <remi@remirepo.net> - 0.1.0-1
- initial package, version 0.1.0 (stable)
- open https://github.com/ace411/php-trie-ext/pull/1 fix build