summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-28 08:30:14 +0100
committerRemi Collet <remi@php.net>2023-02-28 08:30:14 +0100
commit36a6228884889e2265030ba847c3b6c365f08855 (patch)
tree4c810d058456fae71c18014603a1aa8bed3e702a
parentb2f27d7e17799c0343e0550b5a0eca8d10c123fd (diff)
update to 3.0.3
fix license
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION29
-rw-r--r--php-pecl-tensor.spec12
3 files changed, 33 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index a9fbab5..d00464e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,6 +5,6 @@ tensor
A library and extension that provides objects for scientific computing in PHP.
tensor => enabled
Author => Andrew DalPino
-Version => 3.0.0
-Build Date => Apr 4 2022 00:00:00
-Powered by Zephir => Version 0.16.0-$Id$
+Version => 3.0.3
+Build Date => Feb 28 2023 00:00:00
+Powered by Zephir => Version 0.17.0-$Id$
diff --git a/REFLECTION b/REFLECTION
index 2719d50..5b799f8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
+Extension [ <persistent> extension #122 tensor version 3.0.3 ] {
- Dependencies {
}
@@ -219,6 +219,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
@@ -226,6 +227,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
@@ -234,6 +236,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
@@ -241,18 +244,21 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
- Parameters [0] {
}
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
}
}
@@ -629,6 +635,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
@@ -636,6 +643,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
@@ -644,6 +652,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
@@ -651,18 +660,21 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
- Parameters [0] {
}
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:tensor, inherits Tensor\Arithmetic> abstract public method multiply ] {
@@ -959,8 +971,8 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -977,6 +989,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3131,8 +3144,8 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -3149,6 +3162,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3222,8 +3236,8 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -3240,6 +3254,7 @@ Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
diff --git a/php-pecl-tensor.spec b/php-pecl-tensor.spec
index 3282287..752e231 100644
--- a/php-pecl-tensor.spec
+++ b/php-pecl-tensor.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-tensor
#
-# Copyright (c) 2020-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -16,14 +16,14 @@
# After 20-json
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.0.2
+%global upstream_version 3.0.3
#global upstream_prever alpha2
Summary: Objects for scientific computing in PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -203,6 +203,10 @@ fi
%changelog
+* Tue Feb 28 2023 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3
+- fix license
+
* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2