summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-04 08:06:32 +0200
committerRemi Collet <remi@php.net>2022-04-04 08:06:32 +0200
commitb2f27d7e17799c0343e0550b5a0eca8d10c123fd (patch)
tree5a7f337e72575665d0aeda9e2bfd8ddfc0e52d8c
parentda70554c8be52bc6b93ffd74d2c382d2dc7cff3a (diff)
update to 3.0.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION356
-rw-r--r--php-pecl-tensor.spec12
3 files changed, 266 insertions, 106 deletions
diff --git a/PHPINFO b/PHPINFO
index 4f082ab..a9fbab5 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -6,5 +6,5 @@ A library and extension that provides objects for scientific computing in PHP.
tensor => enabled
Author => Andrew DalPino
Version => 3.0.0
-Build Date => Jun 7 2021 00:00:00
-Powered by Zephir => Version 0.13.5-$Id$
+Build Date => Apr 4 2022 00:00:00
+Powered by Zephir => Version 0.16.0-$Id$
diff --git a/REFLECTION b/REFLECTION
index ae5da24..2719d50 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
+Extension [ <persistent> extension #100 tensor version 3.0.0 ] {
- Dependencies {
}
@@ -53,7 +53,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> abstract public method log ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $base ]
+ Parameter #0 [ <optional> float $base = <default> ]
}
}
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> abstract public method round ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $precision ]
+ Parameter #0 [ <optional> int $precision = <default> ]
}
}
@@ -202,7 +202,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> float $initial ]
+ Parameter #1 [ <optional> float $initial = <default> ]
}
- Return [ float ]
}
@@ -217,33 +217,36 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
@@ -400,7 +403,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> abstract public method variance ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mean ]
+ Parameter #0 [ <optional> $mean = <default> ]
}
}
@@ -486,7 +489,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
}
- Interface [ <internal:tensor> interface Tensor\Exceptions\TensorException extends Throwable ] {
+ Interface [ <internal:tensor> interface Tensor\Exceptions\TensorException extends Throwable, Stringable ] {
- Constants [0] {
}
@@ -502,27 +505,58 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Methods [8] {
Method [ <internal:Core, inherits Throwable> abstract public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Throwable> abstract public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Throwable> abstract public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Throwable> abstract public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Throwable> abstract public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Throwable> abstract public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Throwable> abstract public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Throwable> abstract public method __toString ] {
+ Method [ <internal:Core, inherits Stringable> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -578,7 +612,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> float $initial ]
+ Parameter #1 [ <optional> float $initial = <default> ]
}
- Return [ float ]
}
@@ -593,33 +627,36 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
@@ -745,7 +782,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Algebraic> abstract public method log ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $base ]
+ Parameter #0 [ <optional> float $base = <default> ]
}
}
@@ -758,7 +795,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Algebraic> abstract public method round ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $precision ]
+ Parameter #0 [ <optional> int $precision = <default> ]
}
}
@@ -843,7 +880,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Statistical> abstract public method variance ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mean ]
+ Parameter #0 [ <optional> $mean = <default> ]
}
}
@@ -908,7 +945,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
}
- Class [ <internal:tensor> class Tensor\Exceptions\InvalidArgumentException extends InvalidArgumentException implements Throwable, Tensor\Exceptions\TensorException ] {
+ Class [ <internal:tensor> class Tensor\Exceptions\InvalidArgumentException extends InvalidArgumentException implements Throwable, Stringable, Tensor\Exceptions\TensorException ] {
- Constants [0] {
}
@@ -920,47 +957,81 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -981,14 +1052,14 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> static public method build ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
}
Method [ <internal:tensor> static public method quick ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
}
@@ -1037,7 +1108,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $n ]
- Parameter #1 [ <optional> float $lambda ]
+ Parameter #1 [ <optional> float $lambda = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1055,7 +1126,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [3] {
Parameter #0 [ <required> float $start ]
Parameter #1 [ <required> float $end ]
- Parameter #2 [ <optional> float $interval ]
+ Parameter #2 [ <optional> float $interval = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1072,8 +1143,8 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [2] {
- Property [ <default> protected $a ]
- Property [ <default> protected $n ]
+ Property [ protected $a = NULL ]
+ Property [ protected $n = NULL ]
}
- Methods [108] {
@@ -1081,7 +1152,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> array $a ]
- Parameter #1 [ <optional> bool $validate ]
+ Parameter #1 [ <optional> bool $validate = <default> ]
}
}
@@ -1151,6 +1222,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
Method [ <internal:tensor> public method transpose ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tensor, prototype Tensor\ArrayLike> public method map ] {
@@ -1165,7 +1239,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> float $initial ]
+ Parameter #1 [ <optional> float $initial = <default> ]
}
- Return [ float ]
}
@@ -1182,7 +1256,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> Tensor\Vector $b ]
- Parameter #1 [ <optional> int $stride ]
+ Parameter #1 [ <optional> int $stride = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1228,7 +1302,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> public method pNorm ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $p ]
+ Parameter #0 [ <optional> float $p = <default> ]
}
- Return [ float ]
}
@@ -1369,7 +1443,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Algebraic> public method log ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $base ]
+ Parameter #0 [ <optional> float $base = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1490,7 +1564,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Statistical> public method variance ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mean ]
+ Parameter #0 [ <optional> $mean = <default> ]
}
- Return [ float ]
}
@@ -1498,7 +1572,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Algebraic> public method round ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $precision ]
+ Parameter #0 [ <optional> int $precision = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1884,6 +1958,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
Method [ <internal:tensor, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -1904,14 +1981,14 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, overwrites Tensor\Vector, prototype Tensor\Vector> static public method build ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
}
Method [ <internal:tensor, overwrites Tensor\Vector, prototype Tensor\Vector> static public method quick ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
}
@@ -1960,7 +2037,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $n ]
- Parameter #1 [ <optional> float $lambda ]
+ Parameter #1 [ <optional> float $lambda = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1978,7 +2055,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [3] {
Parameter #0 [ <required> float $start ]
Parameter #1 [ <required> float $end ]
- Parameter #2 [ <optional> float $interval ]
+ Parameter #2 [ <optional> float $interval = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -1995,8 +2072,8 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [2] {
- Property [ <default> protected $a ]
- Property [ <default> protected $n ]
+ Property [ protected $a = NULL ]
+ Property [ protected $n = NULL ]
}
- Methods [108] {
@@ -2015,6 +2092,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
Method [ <internal:tensor, overwrites Tensor\Vector, prototype Tensor\Vector> public method transpose ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tensor, overwrites Tensor\Vector, prototype Tensor\Vector> public method matmul ] {
@@ -2125,7 +2205,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> array $a ]
- Parameter #1 [ <optional> bool $validate ]
+ Parameter #1 [ <optional> bool $validate = <default> ]
}
}
@@ -2192,7 +2272,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> float $initial ]
+ Parameter #1 [ <optional> float $initial = <default> ]
}
- Return [ float ]
}
@@ -2209,7 +2289,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> Tensor\Vector $b ]
- Parameter #1 [ <optional> int $stride ]
+ Parameter #1 [ <optional> int $stride = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -2247,7 +2327,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Vector> public method pNorm ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $p ]
+ Parameter #0 [ <optional> float $p = <default> ]
}
- Return [ float ]
}
@@ -2388,7 +2468,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Vector, prototype Tensor\Algebraic> public method log ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $base ]
+ Parameter #0 [ <optional> float $base = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -2509,7 +2589,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Vector, prototype Tensor\Statistical> public method variance ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mean ]
+ Parameter #0 [ <optional> $mean = <default> ]
}
- Return [ float ]
}
@@ -2517,7 +2597,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, inherits Tensor\Vector, prototype Tensor\Algebraic> public method round ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $precision ]
+ Parameter #0 [ <optional> int $precision = <default> ]
}
- Return [ Tensor\Vector ]
}
@@ -2807,6 +2887,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
Method [ <internal:tensor, inherits Tensor\Vector, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -2830,7 +2913,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [1] {
- Property [ <default> protected $l ]
+ Property [ protected $l = NULL ]
}
- Methods [3] {
@@ -2870,15 +2953,15 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> Tensor\Matrix $a ]
- Parameter #1 [ <optional> bool $symmetric ]
+ Parameter #1 [ <optional> bool $symmetric = <default> ]
}
- Return [ Tensor\Decompositions\Eigen ]
}
}
- Properties [2] {
- Property [ <default> protected $eigenvalues ]
- Property [ <default> protected $eigenvectors ]
+ Property [ protected $eigenvalues = NULL ]
+ Property [ protected $eigenvectors = NULL ]
}
- Methods [3] {
@@ -2925,9 +3008,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [3] {
- Property [ <default> protected $l ]
- Property [ <default> protected $u ]
- Property [ <default> protected $p ]
+ Property [ protected $l = NULL ]
+ Property [ protected $u = NULL ]
+ Property [ protected $p = NULL ]
}
- Methods [4] {
@@ -2982,9 +3065,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [3] {
- Property [ <default> protected $u ]
- Property [ <default> protected $singularValues ]
- Property [ <default> protected $vT ]
+ Property [ protected $u = NULL ]
+ Property [ protected $singularValues = NULL ]
+ Property [ protected $vT = NULL ]
}
- Methods [6] {
@@ -3034,7 +3117,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
}
- Class [ <internal:tensor> class Tensor\Exceptions\DimensionalityMismatch extends Tensor\Exceptions\InvalidArgumentException implements Tensor\Exceptions\TensorException, Throwable ] {
+ Class [ <internal:tensor> class Tensor\Exceptions\DimensionalityMismatch extends Tensor\Exceptions\InvalidArgumentException implements Tensor\Exceptions\TensorException, Stringable, Throwable ] {
- Constants [0] {
}
@@ -3046,52 +3129,86 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:tensor> class Tensor\Exceptions\RuntimeException extends RuntimeException implements Throwable, Tensor\Exceptions\TensorException ] {
+ Class [ <internal:tensor> class Tensor\Exceptions\RuntimeException extends RuntimeException implements Stringable, Throwable, Tensor\Exceptions\TensorException ] {
- Constants [0] {
}
@@ -3103,47 +3220,81 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -3164,7 +3315,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> static public method build ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
- Return [ Tensor\Matrix ]
}
@@ -3172,7 +3323,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> static public method quick ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $a ]
+ Parameter #0 [ <optional> array $a = [] ]
}
- Return [ Tensor\Matrix ]
}
@@ -3244,7 +3395,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [3] {
Parameter #0 [ <required> int $m ]
Parameter #1 [ <required> int $n ]
- Parameter #2 [ <optional> float $lambda ]
+ Parameter #2 [ <optional> float $lambda = <default> ]
}
- Return [ Tensor\Matrix ]
}
@@ -3260,9 +3411,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [3] {
- Property [ <default> protected $a ]
- Property [ <default> protected $m ]
- Property [ <default> protected $n ]
+ Property [ protected $a = NULL ]
+ Property [ protected $m = NULL ]
+ Property [ protected $n = NULL ]
}
- Methods [141] {
@@ -3270,7 +3421,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> array $a ]
- Parameter #1 [ <optional> bool $validate ]
+ Parameter #1 [ <optional> bool $validate = <default> ]
}
}
@@ -3379,7 +3530,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> float $initial ]
+ Parameter #1 [ <optional> float $initial = <default> ]
}
- Return [ float ]
}
@@ -3460,7 +3611,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
- Parameters [2] {
Parameter #0 [ <required> Tensor\Matrix $b ]
- Parameter #1 [ <optional> int $stride ]
+ Parameter #1 [ <optional> int $stride = <default> ]
}
- Return [ Tensor\Matrix ]
}
@@ -3496,7 +3647,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> public method eig ] {
- Parameters [1] {
- Parameter #0 [ <optional> bool $symmetric ]
+ Parameter #0 [ <optional> bool $symmetric = <default> ]
}
- Return [ Tensor\Decompositions\Eigen ]
}
@@ -3665,7 +3816,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Algebraic> public method log ] {
- Parameters [1] {
- Parameter #0 [ <optional> float $base ]
+ Parameter #0 [ <optional> float $base = <default> ]
}
- Return [ Tensor\Matrix ]
}
@@ -3786,7 +3937,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Statistical> public method variance ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mean ]
+ Parameter #0 [ <optional> $mean = <default> ]
}
- Return [ Tensor\ColumnVector ]
}
@@ -3794,7 +3945,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor> public method covariance ] {
- Parameters [1] {
- Parameter #0 [ <optional> Tensor\ColumnVector or NULL $mean ]
+ Parameter #0 [ <optional> ?Tensor\ColumnVector $mean = <default> ]
}
- Return [ Tensor\Matrix ]
}
@@ -3802,7 +3953,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
Method [ <internal:tensor, prototype Tensor\Algebraic> public method round ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $precision ]
+ Parameter #0 [ <optional> int $precision = <default> ]
}
- Return [ Tensor\Matrix ]
}
@@ -4326,6 +4477,9 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
Method [ <internal:tensor, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -4349,8 +4503,8 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [2] {
- Property [ <default> protected $a ]
- Property [ <default> protected $swaps ]
+ Property [ protected $a = NULL ]
+ Property [ protected $swaps = NULL ]
}
- Methods [3] {
@@ -4397,7 +4551,7 @@ Extension [ <persistent> extension #102 tensor version 3.0.0 ] {
}
- Properties [1] {
- Property [ <default> protected $a ]
+ Property [ protected $a = NULL ]
}
- Methods [2] {
diff --git a/php-pecl-tensor.spec b/php-pecl-tensor.spec
index 03b7ac4..3282287 100644
--- a/php-pecl-tensor.spec
+++ b/php-pecl-tensor.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-tensor
#
-# Copyright (c) 2020-2021 Remi Collet
+# Copyright (c) 2020-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,13 +16,13 @@
# After 20-json
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.0.00
+%global upstream_version 3.0.2
#global upstream_prever alpha2
Summary: Objects for scientific computing in PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -57,6 +57,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -200,6 +203,9 @@ fi
%changelog
+* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
* Mon Jun 7 2021 Remi Collet <remi@remirepo.net> - 3.0.00-2
- update to 3.0.00 (stable, no change)