summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-07 07:09:41 +0100
committerRemi Collet <remi@php.net>2022-02-07 07:09:41 +0100
commite8271d4df8f647d8ef0bf30079b610f7f511bb26 (patch)
tree6230fbf82e16ea01342767520333fffbef98ff08
parenta57ca23ef278ee168dd6a5206d0d1550fbd893d1 (diff)
update to 0.10.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION342
-rw-r--r--php-pecl-teds.spec5
3 files changed, 345 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index 410f1e2..1b50996 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.9.2
+teds version => 0.10.0
diff --git a/REFLECTION b/REFLECTION
index 6219cf1..14e49b6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.9.2 ] {
+Extension [ <persistent> extension #99 teds version 0.10.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -99,7 +99,7 @@ Extension [ <persistent> extension #99 teds version 0.9.2 ] {
}
}
- - Classes [13] {
+ - Classes [15] {
Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
@@ -594,6 +594,175 @@ Extension [ <persistent> extension #99 teds version 0.9.2 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\IntVector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\IntVector ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [19] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> int ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> int $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\KeyValueVector implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
- Constants [0] {
@@ -808,6 +977,175 @@ Extension [ <persistent> extension #99 teds version 0.9.2 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\LowMemoryVector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\LowMemoryVector ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [19] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\SortedStrictMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index c0e6e82..90d8ef8 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.9.2
+%global upstream_version 0.10.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Mon Feb 7 2022 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+
* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 0.9.2-1
- update to 0.9.2