summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 07:11:31 +0100
committerRemi Collet <remi@php.net>2022-01-31 07:11:31 +0100
commita57ca23ef278ee168dd6a5206d0d1550fbd893d1 (patch)
tree31b2dd41697347f8062f523ab47b0f106f63ebd2
parent1bd3d89215da14ebcb430301a520bef97298283a (diff)
update to 0.9.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-teds.spec5
3 files changed, 36 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index 81c3342..410f1e2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.9.0
+teds version => 0.9.2
diff --git a/REFLECTION b/REFLECTION
index 740b232..6219cf1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.9.0 ] {
+Extension [ <persistent> extension #99 teds version 0.9.2 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -837,7 +837,7 @@ Extension [ <persistent> extension #99 teds version 0.9.0 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1015,6 +1015,20 @@ Extension [ <persistent> extension #99 teds version 0.9.0 ] {
}
- Return [ array ]
}
+
+ Method [ <internal:teds> public method debugGetTreeRepresentation ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method debugIsBalanced ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
}
}
@@ -1039,7 +1053,7 @@ Extension [ <persistent> extension #99 teds version 0.9.0 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1155,6 +1169,20 @@ Extension [ <persistent> extension #99 teds version 0.9.0 ] {
}
- Return [ array ]
}
+
+ Method [ <internal:teds> public method debugGetTreeRepresentation ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method debugIsBalanced ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
}
}
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index ad333e5..c0e6e82 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.9.0
+%global upstream_version 0.9.2
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 0.9.2-1
+- update to 0.9.2
+
* Thu Jan 27 2022 Remi Collet <remi@remirepo.net> - 0.9.0-1
- update to 0.9.0