summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-09 06:41:13 +0100
committerRemi Collet <remi@php.net>2022-02-09 06:41:13 +0100
commitdec4af1b0cfec6d53e930503888fc9207b335b78 (patch)
tree0308e251d4756cee91e5901cc5566ec473d2f585
parente8271d4df8f647d8ef0bf30079b610f7f511bb26 (diff)
update to 0.11.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION152
-rw-r--r--php-pecl-teds.spec5
3 files changed, 93 insertions, 66 deletions
diff --git a/PHPINFO b/PHPINFO
index 1b50996..b68e6bf 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.10.0
+teds version => 0.11.0
diff --git a/REFLECTION b/REFLECTION
index 14e49b6..629b04c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.10.0 ] {
+Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -477,7 +477,7 @@ Extension [ <persistent> extension #99 teds version 0.10.0 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [17] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -585,6 +585,22 @@ Extension [ <persistent> extension #99 teds version 0.10.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds> public method map ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ Teds\ImmutableSequence ]
+ }
+
+ Method [ <internal:teds> public method filter ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?callable $callback = null ]
+ }
+ - Return [ Teds\ImmutableSequence ]
+ }
+
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
- Parameters [0] {
@@ -1524,7 +1540,7 @@ Extension [ <persistent> extension #99 teds version 0.10.0 ] {
}
}
- Class [ <internal:teds> <iterateable> class Teds\StableMinHeap extends SplHeap implements Countable, Traversable, Iterator ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StableMinHeap implements Iterator, Traversable, Countable ] {
- Constants [0] {
}
@@ -1532,104 +1548,108 @@ Extension [ <persistent> extension #99 teds version 0.10.0 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $state ]
+ }
+ - Return [ Teds\StableMinHeap ]
+ }
}
- Properties [0] {
}
- - Methods [14] {
- Method [ <internal:teds, overwrites SplHeap, prototype SplHeap> public method compare ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> mixed $value1 ]
- Parameter #1 [ <required> mixed $value2 ]
- }
- - Return [ int ]
- }
-
- Method [ <internal:SPL, inherits SplHeap> public method extract ] {
+ - Methods [12] {
+ Method [ <internal:teds, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $values = [] ]
}
}
- Method [ <internal:SPL, inherits SplHeap> public method insert ] {
+ Method [ <internal:teds> public method add ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap> public method top ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:SPL, inherits SplHeap, prototype Countable> public method count ] {
+ Method [ <internal:teds> public method top ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap> public method isEmpty ] {
+ Method [ <internal:teds> public method extract ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method rewind ] {
+ Method [ <internal:teds, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method current ] {
+ Method [ <internal:teds> public method isEmpty ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method key ] {
+ Method [ <internal:teds, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method next ] {
+ Method [ <internal:teds, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method valid ] {
+ Method [ <internal:teds, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap> public method recoverFromCorruption ] {
+ Method [ <internal:teds, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap> public method isCorrupted ] {
+ Method [ <internal:teds, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Method [ <internal:SPL, inherits SplHeap> public method __debugInfo ] {
+ Method [ <internal:teds> public method clear ] {
- Parameters [0] {
}
+ - Return [ void ]
}
}
}
- Class [ <internal:teds> <iterateable> class Teds\StableMaxHeap extends SplHeap implements Countable, Traversable, Iterator ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StableMaxHeap implements Iterator, Traversable, Countable ] {
- Constants [0] {
}
@@ -1637,99 +1657,103 @@ Extension [ <persistent> extension #99 teds version 0.10.0 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $state ]
+ }
+ - Return [ Teds\StableMaxHeap ]
+ }
}
- Properties [0] {
}
- - Methods [14] {
- Method [ <internal:teds, overwrites SplHeap, prototype SplHeap> public method compare ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> mixed $value1 ]
- Parameter #1 [ <required> mixed $value2 ]
- }
- - Return [ int ]
- }
-
- Method [ <internal:SPL, inherits SplHeap> public method extract ] {
+ - Methods [12] {
+ Method [ <internal:teds, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $values = [] ]
}
}
- Method [ <internal:SPL, inherits SplHeap> public method insert ] {
+ Method [ <internal:teds> public method add ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap> public method top ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:SPL, inherits SplHeap, prototype Countable> public method count ] {
+ Method [ <internal:teds> public method top ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap> public method isEmpty ] {
+ Method [ <internal:teds> public method extract ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method rewind ] {
+ Method [ <internal:teds, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method current ] {
+ Method [ <internal:teds> public method isEmpty ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method key ] {
+ Method [ <internal:teds, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method next ] {
+ Method [ <internal:teds, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap, prototype Iterator> public method valid ] {
+ Method [ <internal:teds, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Return [ mixed ]
}
- Method [ <internal:SPL, inherits SplHeap> public method recoverFromCorruption ] {
+ Method [ <internal:teds, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:SPL, inherits SplHeap> public method isCorrupted ] {
+ Method [ <internal:teds, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
- Method [ <internal:SPL, inherits SplHeap> public method __debugInfo ] {
+ Method [ <internal:teds> public method clear ] {
- Parameters [0] {
}
+ - Return [ void ]
}
}
}
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 90d8ef8..933cbda 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.10.0
+%global upstream_version 0.11.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Wed Feb 9 2022 Remi Collet <remi@remirepo.net> - 0.11.0-1
+- update to 0.11.0
+
* Mon Feb 7 2022 Remi Collet <remi@remirepo.net> - 0.10.0-1
- update to 0.10.0