summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-14 07:04:24 +0100
committerRemi Collet <remi@php.net>2022-02-14 07:04:24 +0100
commitc9f9fd9fe0125caedf1bf7a7f462326777094da5 (patch)
treeb56de1d35466034cfb745246739046847ebac03f
parentdec4af1b0cfec6d53e930503888fc9207b335b78 (diff)
update to 0.12.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION612
-rw-r--r--php-pecl-teds.spec5
3 files changed, 537 insertions, 82 deletions
diff --git a/PHPINFO b/PHPINFO
index b68e6bf..0a00202 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.11.0
+teds version => 0.12.0
diff --git a/REFLECTION b/REFLECTION
index 629b04c..33dcd80 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.11.0 ] {
+Extension [ <persistent> extension #99 teds version 0.12.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -99,8 +99,263 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- - Classes [15] {
- Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ - Classes [18] {
+ Interface [ <internal:teds> interface Teds\Values extends Traversable, Countable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:teds> abstract public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> abstract public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> abstract public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:Core, inherits Countable> abstract public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:teds> interface Teds\Collection extends Teds\Values, Countable, Traversable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:teds> abstract public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> abstract public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:Core, inherits Countable> abstract public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:teds> interface Teds\ListInterface extends Teds\Collection, ArrayAccess, Traversable, Countable, Teds\Values ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [14] {
+ Method [ <internal:teds> abstract public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> abstract public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> abstract public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> abstract public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Collection> abstract public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Collection> abstract public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, inherits Teds\Values> abstract public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:Core, inherits Countable> abstract public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
- Constants [0] {
}
@@ -121,7 +376,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -143,7 +398,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -172,7 +427,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method push ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method push ] {
- Parameters [1] {
Parameter #0 [ <optional> mixed ...$values ]
@@ -188,7 +443,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method pop ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method pop ] {
- Parameters [0] {
}
@@ -216,14 +471,21 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method toArray ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
- Parameters [0] {
}
- Return [ array ]
}
- Method [ <internal:teds> public method get ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -231,7 +493,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method set ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method set ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -256,6 +518,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
@@ -281,7 +551,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ ?int ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -305,7 +575,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\ImmutableKeyValueSequence implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableKeyValueSequence implements IteratorAggregate, Traversable, Teds\Values, Countable, JsonSerializable ] {
- Constants [0] {
}
@@ -334,7 +604,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [17] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -356,7 +626,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -392,7 +662,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ array ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -447,6 +717,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
- Parameters [0] {
@@ -456,7 +734,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\ImmutableSequence implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableSequence implements IteratorAggregate, Traversable, Teds\Collection, ArrayAccess, Countable, Teds\Values, JsonSerializable ] {
- Constants [0] {
}
@@ -477,7 +755,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [19] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -499,7 +777,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -521,7 +799,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method toArray ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -552,6 +837,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
@@ -577,7 +870,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ ?int ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -610,7 +903,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\IntVector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\IntVector implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
- Constants [0] {
}
@@ -631,7 +924,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [19] {
+ - Methods [23] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -653,7 +946,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -682,7 +975,15 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method push ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pushInts ] {
- Parameters [1] {
Parameter #0 [ <optional> int ...$values ]
@@ -690,21 +991,28 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method pop ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method pop ] {
- Parameters [0] {
}
- Return [ int ]
}
- Method [ <internal:teds> public method toArray ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
- Parameters [0] {
}
- Return [ array ]
}
- Method [ <internal:teds> public method get ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -712,7 +1020,16 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method set ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method setInt ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -737,6 +1054,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
@@ -762,10 +1087,10 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ ?int ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
- Parameter #0 [ <required> int $value ]
+ Parameter #0 [ <required> mixed $value ]
}
- Return [ bool ]
}
@@ -808,7 +1133,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [25] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -977,6 +1302,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method shrinkToFit ] {
- Parameters [0] {
@@ -993,7 +1326,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\LowMemoryVector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\LowMemoryVector implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
- Constants [0] {
}
@@ -1014,7 +1347,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [19] {
+ - Methods [21] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1036,7 +1369,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -1065,7 +1398,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method push ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method push ] {
- Parameters [1] {
Parameter #0 [ <optional> mixed ...$values ]
@@ -1073,21 +1406,28 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method pop ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method pop ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method toArray ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
- Parameters [0] {
}
- Return [ array ]
}
- Method [ <internal:teds> public method get ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -1095,7 +1435,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method set ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method set ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -1120,6 +1460,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
@@ -1145,7 +1493,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ ?int ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -1162,7 +1510,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\SortedStrictMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\SortedStrictMap implements IteratorAggregate, Traversable, Teds\Collection, ArrayAccess, Countable, Teds\Values, JsonSerializable ] {
- Constants [0] {
}
@@ -1191,7 +1539,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [28] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1213,7 +1561,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -1234,6 +1582,13 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ array ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
Method [ <internal:teds> public method __serialize ] {
- Parameters [0] {
@@ -1249,7 +1604,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -1347,7 +1702,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method containsValue ] {
+ Method [ <internal, deprecated:teds> public method containsValue ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -1355,7 +1710,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
- Method [ <internal:teds> public method containsKey ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -1363,6 +1718,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
- Parameters [0] {
@@ -1386,7 +1749,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\SortedStrictSet implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+ Class [ <internal:teds> <iterateable> final class Teds\SortedStrictSet implements IteratorAggregate, Traversable, Teds\Values, Countable, JsonSerializable ] {
- Constants [0] {
}
@@ -1429,7 +1792,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -1458,7 +1821,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -1493,7 +1856,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -1561,7 +1924,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [15] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1646,6 +2009,28 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
- Return [ void ]
}
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
}
}
@@ -1670,7 +2055,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [15] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1755,10 +2140,32 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
- Return [ void ]
}
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
}
}
- Class [ <internal:teds> <iterateable> final class Teds\StableSortedListMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StableSortedListMap implements IteratorAggregate, Traversable, Teds\Collection, ArrayAccess, Countable, Teds\Values, JsonSerializable ] {
- Constants [0] {
}
@@ -1787,7 +2194,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1809,7 +2216,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -1845,7 +2252,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -1951,7 +2365,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
- Method [ <internal:teds> public method containsKey ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -1959,6 +2373,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
- Parameters [0] {
@@ -1968,7 +2390,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\StableSortedListSet implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StableSortedListSet implements IteratorAggregate, Traversable, Teds\Values, Countable, JsonSerializable ] {
- Constants [0] {
}
@@ -2011,7 +2433,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -2040,7 +2462,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -2075,7 +2497,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -2108,7 +2530,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\StrictMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StrictMap implements IteratorAggregate, Traversable, Teds\Collection, ArrayAccess, Countable, Teds\Values, JsonSerializable ] {
- Constants [0] {
}
@@ -2137,7 +2559,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [18] {
+ - Methods [20] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2159,7 +2581,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -2195,7 +2617,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
@@ -2242,7 +2671,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method containsValue ] {
+ Method [ <internal, deprecated:teds> public method containsValue ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -2250,7 +2679,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
- Method [ <internal:teds> public method containsKey ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -2258,6 +2687,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method get ] {
- Parameters [2] {
@@ -2276,7 +2713,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\StrictSet implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+ Class [ <internal:teds> <iterateable> final class Teds\StrictSet implements IteratorAggregate, Traversable, Teds\Values, Countable, JsonSerializable ] {
- Constants [0] {
}
@@ -2319,7 +2756,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -2348,14 +2785,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method values ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
- Parameters [0] {
}
- Return [ array ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
@@ -2388,7 +2825,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\Vector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+ Class [ <internal:teds> <iterateable> final class Teds\Vector implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
- Constants [0] {
}
@@ -2409,7 +2846,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Properties [0] {
}
- - Methods [25] {
+ - Methods [27] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2431,7 +2868,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method isEmpty ] {
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
- Parameters [0] {
}
@@ -2491,7 +2928,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method push ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method push ] {
- Parameters [1] {
Parameter #0 [ <optional> mixed ...$values ]
@@ -2499,21 +2936,28 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method pop ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method pop ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method toArray ] {
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
- Parameters [0] {
}
- Return [ array ]
}
- Method [ <internal:teds> public method get ] {
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -2521,7 +2965,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method set ] {
+ Method [ <internal:teds, prototype Teds\ListInterface> public method set ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -2546,6 +2990,14 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ bool ]
}
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
@@ -2571,7 +3023,7 @@ Extension [ <persistent> extension #99 teds version 0.11.0 ] {
- Return [ ?int ]
}
- Method [ <internal:teds> public method contains ] {
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 933cbda..1c97555 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.11.0
+%global upstream_version 0.12.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Thu Feb 10 2022 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+
* Wed Feb 9 2022 Remi Collet <remi@remirepo.net> - 0.11.0-1
- update to 0.11.0