summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-20 07:05:02 +0200
committerRemi Collet <remi@remirepo.net>2021-09-20 07:05:02 +0200
commit249fc762bc7cadfcce92617ad074a366c74b1e06 (patch)
treec9b653b2f48815ac5d85864ed8e2a4a48ff55074
parenta4198e8e6ed98b6ad068e786054a5cf7c41b2f2e (diff)
update to 0.3.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION41
-rw-r--r--php-pecl-teds.spec5
3 files changed, 30 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 8d8da33..5a20b34 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.2.1
+teds version => 0.3.0
diff --git a/REFLECTION b/REFLECTION
index 632a007..865bbf5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #82 teds version 0.2.1 ] {
+Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -163,7 +163,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ array ]
}
- Method [ <internal:teds> public method valueAt ] {
+ Method [ <internal:teds> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -171,7 +171,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method setValueAt ] {
+ Method [ <internal:teds> public method set ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -218,7 +218,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method contains ] {
@@ -346,7 +346,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method indexOfValue ] {
@@ -354,7 +354,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method containsKey ] {
@@ -447,7 +447,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ array ]
}
- Method [ <internal:teds> public method valueAt ] {
+ Method [ <internal:teds> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -493,7 +493,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method contains ] {
@@ -677,7 +677,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method indexOfValue ] {
@@ -685,7 +685,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method containsKey ] {
@@ -741,7 +741,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [2] {
@@ -778,6 +778,14 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method reserve ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $capacity ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds> public method clear ] {
- Parameters [0] {
@@ -787,8 +795,9 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
Method [ <internal:teds> public method setSize ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> int $size ]
+ Parameter #1 [ <optional> mixed $value = null ]
}
- Return [ void ]
}
@@ -811,7 +820,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
Method [ <internal:teds> public method push ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $value ]
+ Parameter #0 [ <optional> mixed ...$values ]
}
- Return [ void ]
}
@@ -830,7 +839,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ array ]
}
- Method [ <internal:teds> public method valueAt ] {
+ Method [ <internal:teds> public method get ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
@@ -838,7 +847,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method setValueAt ] {
+ Method [ <internal:teds> public method set ] {
- Parameters [2] {
Parameter #0 [ <required> int $offset ]
@@ -885,7 +894,7 @@ Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
- - Return [ int|false ]
+ - Return [ ?int ]
}
Method [ <internal:teds> public method contains ] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 97ee03e..37765f1 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.2.1
+%global upstream_version 0.3.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -195,6 +195,9 @@ fi
%changelog
+* Mon Sep 20 2021 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+
* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 0.2.1-1
- update to 0.2.1