summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-18 12:33:13 +0200
committerRemi Collet <remi@remirepo.net>2021-09-18 12:33:13 +0200
commita4198e8e6ed98b6ad068e786054a5cf7c41b2f2e (patch)
tree49c8d5cb2aef4b117972d40f9316ed75672e0719
parent19952f569c601e748d931932bc598868602fde03 (diff)
update to 0.2.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-teds.spec5
3 files changed, 26 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index be84ae8..8d8da33 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.2.0
+teds version => 0.2.1
diff --git a/REFLECTION b/REFLECTION
index 4ceb981..632a007 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #82 teds version 0.2.0 ] {
+Extension [ <persistent> extension #82 teds version 0.2.1 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -741,7 +741,7 @@ Extension [ <persistent> extension #82 teds version 0.2.0 ] {
- Properties [0] {
}
- - Methods [21] {
+ - Methods [23] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [2] {
@@ -771,6 +771,13 @@ Extension [ <persistent> extension #82 teds version 0.2.0 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method shrinkToFit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds> public method clear ] {
- Parameters [0] {
@@ -889,11 +896,20 @@ Extension [ <persistent> extension #82 teds version 0.2.0 ] {
- Return [ bool ]
}
- Method [ <internal:teds> public method shrinkToFit ] {
+ Method [ <internal:teds> public method map ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
}
- - Return [ void ]
+ - Return [ Teds\Vector ]
+ }
+
+ Method [ <internal:teds> public method filter ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?callable $callback = null ]
+ }
+ - Return [ Teds\Vector ]
}
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 75b62d3..97ee03e 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.2.0
+%global upstream_version 0.2.1
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -195,6 +195,9 @@ fi
%changelog
+* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 0.2.1-1
+- update to 0.2.1
+
* Mon Sep 13 2021 Remi Collet <remi@remirepo.net> - 0.2.0-1
- update to 0.2.0