summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-04 06:50:58 +0100
committerRemi Collet <remi@php.net>2022-03-04 06:50:58 +0100
commit1f946001760a5e69868578f1c7a039c0fc0ec283 (patch)
tree099f73a41664ea8224be4507e3e17a132ce16e20
parent71da333ae521f57a6ef72fb82d1c390eb30a757d (diff)
update to 1.2.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION629
-rw-r--r--php-pecl-teds.spec5
3 files changed, 607 insertions, 29 deletions
diff --git a/PHPINFO b/PHPINFO
index 774118b..4f85831 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 1.1.2
+teds version => 1.2.0
diff --git a/REFLECTION b/REFLECTION
index b82a9dd..b30939d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 1.1.2 ] {
+Extension [ <persistent> extension #99 teds version 1.2.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -107,7 +107,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
}
}
- - Classes [22] {
+ - Classes [25] {
Interface [ <internal:teds> interface Teds\Collection extends Traversable, Countable ] {
- Constants [0] {
@@ -181,7 +181,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [19] {
Method [ <internal:teds> abstract public method get ] {
- Parameters [1] {
@@ -199,6 +199,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds> abstract public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds> abstract public method push ] {
- Parameters [1] {
@@ -229,6 +238,20 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> abstract public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> abstract public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds, inherits Teds\Collection> abstract public method values ] {
- Parameters [0] {
@@ -564,7 +587,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
}
}
- Class [ <internal:teds> <iterateable> final class Teds\BitSet implements IteratorAggregate, Traversable, Teds\Sequence, ArrayAccess, Countable, Teds\Collection, JsonSerializable ] {
+ Class [ <internal:teds> <iterateable> final class Teds\BitVector implements IteratorAggregate, Traversable, Teds\Sequence, ArrayAccess, Countable, Teds\Collection, JsonSerializable ] {
- Constants [0] {
}
@@ -578,7 +601,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> string $data ]
}
- - Return [ Teds\BitSet ]
+ - Return [ Teds\BitVector ]
}
Method [ <internal:teds> static public method fromBinaryString ] {
@@ -586,7 +609,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> string $data ]
}
- - Return [ Teds\BitSet ]
+ - Return [ Teds\BitVector ]
}
Method [ <internal:teds> static public method __set_state ] {
@@ -594,14 +617,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> array $array ]
}
- - Return [ Teds\BitSet ]
+ - Return [ Teds\BitVector ]
}
}
- Properties [0] {
}
- - Methods [42] {
+ - Methods [43] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -682,6 +705,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds> public method pushBits ] {
- Parameters [1] {
@@ -690,14 +722,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
- Return [ bool ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -1126,7 +1158,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [28] {
+ - Methods [29] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1207,7 +1239,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
@@ -1221,7 +1253,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -1266,6 +1298,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
@@ -1533,11 +1574,11 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [27] {
+ - Methods [28] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $iterator ]
+ Parameter #0 [ <optional> iterable $iterator = [] ]
}
}
@@ -1608,6 +1649,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method push ] {
- Parameters [1] {
@@ -1638,14 +1688,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -1741,6 +1791,170 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableSortedStringSet implements IteratorAggregate, Traversable, Teds\Set, Countable, Teds\Collection, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:teds> static public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ Teds\ImmutableSortedStringSet ]
+ }
+
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\ImmutableSortedStringSet ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [18] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\IntVector implements IteratorAggregate, Traversable, Teds\Sequence, ArrayAccess, Countable, Teds\Collection, JsonSerializable ] {
- Constants [0] {
@@ -1749,7 +1963,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [2] {
+ Method [ <internal:teds> static public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ Teds\IntVector ]
+ }
+
Method [ <internal:teds> static public method __set_state ] {
- Parameters [1] {
@@ -1762,7 +1984,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [28] {
+ - Methods [30] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1813,6 +2035,13 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method push ] {
- Parameters [1] {
@@ -1836,14 +2065,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
- Return [ int ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -1865,6 +2094,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method shift ] {
- Parameters [0] {
@@ -1978,6 +2216,325 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\SortedIntVectorSet implements IteratorAggregate, Traversable, Teds\Set, Countable, Teds\Collection, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\IntVector ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [20] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method shift ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableSortedIntSet implements IteratorAggregate, Traversable, Teds\Set, Countable, Teds\Collection, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\ImmutableSortedIntSet ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [17] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Set> public method remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\MutableIterable implements IteratorAggregate, Traversable, Teds\Collection, Countable, JsonSerializable ] {
- Constants [0] {
@@ -2228,7 +2785,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [27] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2279,14 +2836,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -2316,6 +2873,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method shift ] {
- Parameters [0] {
@@ -3898,7 +4464,7 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Properties [0] {
}
- - Methods [31] {
+ - Methods [32] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -4010,14 +4576,14 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ mixed ]
}
- Method [ <internal:teds> public method first ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method first ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method last ] {
+ Method [ <internal:teds, prototype Teds\Sequence> public method last ] {
- Parameters [0] {
}
@@ -4055,6 +4621,15 @@ Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Return [ void ]
}
+ Method [ <internal:teds, prototype Teds\Sequence> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 6a5ea23..04a128c 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.1.2
+%global upstream_version 1.2.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Fri Mar 4 2022 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
* Mon Feb 21 2022 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2